
 

 

 

Unit-1 

 

Opening Excel 

 

Using Windows 7  

 

Click on the Start Button. 

In the Search Program and Files box type Excel. 

Click on Excel 2013 from the Program results. 

The Microsoft Excel 2013 program will open. 

 

 

Using Windows 8   

 

Press the Windows key on the keyboard. 

Type Excel. 

Click on Excel 2013 under the Apps results. 

 

 

Using iOS 7  

 

Click on Launchpad. 

Select Microsoft Excel. 

 

 

Getting Started 

 

When you open Excel 2013 for the first time, the Excel Start Screen will appear. From here, you'll be able to 

create a new workbook, choose a template, and access your recently edited workbooks. 

 

From the Excel Start Screen, locate and select Blank workbook to access the Excel interface. 

Click Open Other Workbooks to work on an existing workbook. 



 

 

 

 

 
 

 

 

To set up Excel so it automatically opens a new workbook   

 

Click File then Options. 

On the General tab, under Start up options, uncheck the Show the Start screen when this application starts box. 

The next time you start Excel, it opens a blank workbook automatically similar to older versions of Excel. 

 

The Excel Interface 

 

After starting Excel, you will see two windows - one within the other. The outer window is the Application 

Window and the inner window is the Workbook Window. When maximized, the Excel Workbook Window 

blends in with the Application Window. 

 

After completing this module, you should be able to: 

 

Identify the components of the Application Window. 

Identify the components of the Workbook Window. 

Create a new workbook 

Open an existing workbook 



 

 

 

 

 
 

 

The Application Window 

 

The Application Window provides the space for your worksheets and workbook elements such as charts. The 

components of the Application Window are described below. 

 

The Quick Access Toolbar 

 

The Quick Access Toolbar lets you access common commands no matter which tab is selected. 

 

By default, it includes the Save, Undo, and Repeat commands. You can add other commands depending on your 

preference. 

 

To add commands to the Quick Access toolbar  

 

Click the drop-down arrow to the right of the Quick Access toolbar. 

Quick Access Toolbar 

The Ribbon 

Command Group 

Name Box Formula Bar 
Colum 

Cell 

Row 

Vertical and Horizontal Scroll Bars 

Worksheets 

Worksheet View Option Zoom Control 



 

 

 

 

Select the command you wish to add from the drop-down menu. To choose from more commands, select More 

Commands. 

 

 

 

 

The command will be added to the Quick Access toolbar. 

 

 

 

 

 

 

The Ribbon 

 

Excel 2013 uses a tabbed Ribbon system instead of traditional menus. The Ribbon contains multiple tabs, each 

with several groups of commands. You will use these tabs to perform the most common tasks in Excel.  



 

 

 

 

 

 
 

 

 

To minimize and maximize the Ribbon  

 

The Ribbon is designed to respond to your current task, but you can choose to minimize it if you find that it 

takes up too much screen space. 

 

Click the Ribbon Display Options arrow in the upper-right corner of the Ribbon. 

 

Click a tab to see 
more commands 

Each tab is divided 
into groups 



 

 

 

 

Select the desired minimizing option from the drop-down menu: 

 

Auto-hide Ribbon: Auto-hide displays your workbook in full-screen mode and completely hides the Ribbon. To 

show the Ribbon, click the Expand Ribbon command at the top of screen. 

 

 

Show Tabs: This option hides all command groups when not in use, but tabs will remain visible. To show the 

Ribbon, simply click a tab. 

 Show Tabs and Commands: This option maximizes the Ribbon. All of the tabs and commands will be visible. 

This option is selected by default when you open Excel for the first time. 

 

To Customize the Ribbon in Excel 2013  

 

You can customize the Ribbon by creating your own tabs with whichever commands you want. Commands are 

always housed within a group, and you can create as many groups as you want in order to keep your tab 

organized. If you want, you can even add commands to any of the default tabs, as long as you create a custom 

group in the tab. 

 

Right-click the Ribbon and then select Customize the Ribbon... from the drop-down menu. 

 

 

The Excel Options dialog box will appear. Locate and select New Tab. 

Ribbon is hidden and workbook 

appears in full screen 
Click the Expand Ribbon 

command to show the Ribbon 



 

 

 

 

 
 

Make sure the New Group is selected, select a command, and then click Add. You can also drag commands 

directly into a group. 

When you are done adding commands, click OK. The commands will be added to the Ribbon. 

 

 

Select 

commands and 

click Add 
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The Formula Bar 

 

In the formula bar, you can enter or edit data, a formula, or a function that will appear in a specific cell. 

 

In the image below, cell C1 is selected and 1984 is entered into the formula bar. Note how the data appears in 

both the formula bar and in cell C1. 

 

 

 

The Name Box 

 

The Name box displays the location, or "name" of a selected cell. 

 

In the image below, cell B4 is selected. Note that cell B4 is where column B and row 4 intersect. 

 

 

The Backstage View (The File Menu) 

 

Click the File tab on the Ribbon. Backstage view will appear. 

 

 



 

 

 

 

 

 

 
 

 

The Worksheet Views 

 

Excel 2013 has a variety of viewing options that change how your workbook is displayed. You can choose to 

view any workbook in Normal view, Page Layout view, or Page Break view. These views can be useful for 

various tasks, especially if you're planning to print the spreadsheet. 

 

To change worksheet views, locate and select the desired worksheet view command in the bottom-right corner 

of the Excel window. 

Return to Excel 
Info contains 

information about the 
current workbook. You 

can also inspect the 
workbook and set 

protection controls. 
New: you can create a new, blank 
workbook, or choose from a large 

selection of templates. 

Open: you can open 
recent workbooks, as 

well as workbooks saved 

to your OneDrive or on Use Save and Save As to save 

your computer. your workbook to your computer 
or to Office 365. 

From the Print pane, 
you can change the 

print settings and print 

your workbook. You 

can also see a preview 

of your workbook. 

Share: you can invite people to view and 
collaborate on your workbook. You can also share 

your workbook by emailing it as an attachment. 

Export: you can choose 
to export your 

workbook in another 
format, such as 

PDF/XPS or Excel 
1997-2003. 

Close the current workbook. 
 

From the Account pane, you can access your 
Microsoft account information, modify your theme 

and background, and sign out of your account. 

Options: you can change various Excel options. For 
example, you can control the Quick Analysis preferences, 

Auto Recover settings, or Language preferences. 



 

 

 

 

 
 

 

Zoom Control 

 

To use the Zoom control, click and drag the slider. The number to the right of the slider reflects the zoom 

percentage. 

 

 

Page Layout 

View 

Normal View Page Break 

View 



 

 

 

 

The Workbook Window 

 

In Excel 2013, when you open up a new workbook it now contains only 1 worksheet There can be a max of 

1,048,576 rows and 16,384 columns in an excel work sheet. 

 

The Worksheet 

 

Excel files are called workbooks. Each workbook holds one or more worksheets (also known as "spreadsheets"). 

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. A worksheet is a grid 

of columns and rows where columns are designated by letters running across the top of the worksheet and rows 

are designated by numbers running down the left side of the worksheet. 

 

 

 

When working with a large amount of data, you can create multiple worksheets to help organize your workbook 

and make it easier to find content. You can also group worksheets to quickly add information to multiple 

worksheets at the same time. 

 

To rename a worksheet  

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. You can rename a 

worksheet to better reflect its content. In our example, we will create a training log organized by month. 

 

Right-click the worksheet you wish to rename, then select Rename from the worksheet menu. 



 

 

 

 

 
 

Type the desired name for the worksheet. 

 

 

Click anywhere outside of the worksheet, or press Enter on your keyboard. The worksheet will be renamed. 

 

 

To insert a new worksheet  

 

Locate and select the New sheet button. 

 

 

Click to add a 

new worksheet 



 

 

 

 

A new, blank worksheet will appear. 

 

 TIP: To change the default number of worksheets, navigate to Backstage view, click Options, and then 

choose the desired number of worksheets to include in each new workbook. 

 

 

 

To delete a worksheet  

 

Right-click the worksheet you wish to delete, then select Delete from the worksheet menu. 

 

 

The worksheet will be deleted from your workbook. 



 

 

 

 

 
 

 

 

Alternatively, from the Home Tab in the Cells Group click on Delete and select Delete Sheet. Warning: The 

Undo button will not undo the deletion of a worksheet. 

To copy a worksheet  

 

If you need to duplicate the content of one worksheet to another, Excel allows you to copy an existing 

worksheet. 

 

Right-click the worksheet you want to copy, then select Move or Copy from the worksheet menu. 

 

 

 

 

The Move or Copy dialog box will appear. Choose where the sheet will appear in the Before sheet: field. In our 

example, we'll choose (move to end) to place the worksheet to the right of the existing worksheet. 

Check the box next to Create a copy, then click OK. 



 

 

 

 

 
 

The worksheet will be copied. It will have the same title as the original worksheet, as well as a version number.  

 

TIP: You can also copy a worksheet to an entirely different workbook. You can select any workbook that is 

currently open from the To book: drop-down menu. 

 

 

To move a worksheet  

 

Sometimes you may want to move a worksheet to rearrange your workbook. 

 

Select the worksheet you wish to move. The cursor will become a small worksheet icon . 

Hold and drag the mouse until a small black arrow appears above the desired location. 



 

 

 

 

 
 

Release the mouse. The worksheet will be moved. 

 

To change the worksheet color  

 

You can change a worksheet's color to help organize your worksheets and make your workbook easier to 

navigate. 

 

Right-click the desired worksheet, and hover the mouse over Tab Color. The Color menu will appear. 

Select the desired color. A live preview of the new worksheet color will appear as you hover the mouse over 

different options. In our example, we'll choose Red. 

The worksheet color will be changed. 



 

 

 

 

The worksheet color is considerably less noticeable when the worksheet is selected. Select another worksheet to 

see how the color will appear when the worksheet is not selected. 

 

 

 

 

 

. 

 



 

 

 

 

The Scroll Bars 

 

Your spreadsheet may frequently have more data than you can see on the screen at once. Click, hold and drag 

the vertical or horizontal scroll bar depending on what part of the page you want to see. 

 

 

 

 

 

Creating and Opening Workbooks 

 

Excel files are called workbooks. Whenever you start a new project in Excel, you'll need to create a new 

workbook. There are several ways to start working with a workbook in Excel 2013. You can choose to create a 

new workbook—either with a blank workbook or a predesigned template—or open an existing workbook. 

 

Create a new blank workbook 

 

Select the File tab. Backstage view will appear. 

 

Vertical 

scroll bar 

Horizontal 
scroll bar 



 

 

 

 

Select New, then click Blank workbook. 

A new blank workbook will appear. 

 

Open an existing workbook 

 

In addition to creating new workbooks, you'll often need to open a workbook that was previously saved. 

Navigate to Backstage view, then click Open. 

 

 

 

 

Select Computer, and then click Browse. 

 



 

 

 

 

The Open dialog box will appear. Locate and select your workbook, then click Open. 

 

 

 

 TIP: If you've opened the desired workbook recently, you can browse your Recent Workbooks rather than 

searching for the file. 

 



 

 

 

 

To pin a workbook  

If you frequently work with the same workbook, you can pin it to Backstage view for quick access. 

Navigate to Backstage view and then click Open. Your recently edited workbooks will appear. 

Hover the mouse over the workbook you wish to pin. A pushpin icon will appear next to the workbook. Click 

the pushpin icon. 

 

 

The workbook will stay in Recent Workbooks. To unpin a workbook, simply click the pushpin icon again. 

 

 TIP: You can also pin folders to Backstage view for quick access. From Backstage view, click Open, then 

locate the folder you wish to pin and click the pushpin icon. 

 

 

Compatibility mode 

 

Sometimes you may need to work with workbooks that were created in earlier versions of Microsoft Excel, such 

as Excel 2003 or Excel 2000. When you open these kinds of workbooks, they will appear in Compatibility 

mode. 

 



 

 

 

 

Compatibility mode disables certain features, so you'll only be able to access commands found in the program 

that was used to create the workbook. For example, if you open a workbook created in Excel 2003, you can only 

use tabs and commands found in Excel 2003. 

In order to exit Compatibility mode, you'll need to convert the workbook to the current version type. However, 

if you're collaborating with others who only have access to an earlier version of Excel, it's best to leave the 

workbook in Compatibility mode so the format will not change. 

To convert a workbook  

If you want access to all of the Excel 2013 features, you can convert the workbook to the 2013 file format. Note 

that converting a file may cause some changes to the original layout of the workbook. 

Click the File tab to access Backstage view. 

Locate and select Convert command. 

 

 

 

 

The Save As dialog box will appear. Select the location where you wish to save the workbook, enter a file name 

for the presentation, and click Save. 

The workbook will be converted to the newest file type. 

 

 



 

 

 

 

Saving and Sharing Workbooks 

 

Whenever you create a new workbook in Excel, you'll need to know how to save it in order to access and edit it 

later. As with previous versions of Excel, you can save files locally to your computer. But unlike older versions, 

Excel 2013 also lets you save a workbook to the cloud using OneDrive. You can also export and share 

workbooks with others directly from Excel. 

 

Save and Save As 

 

Excel offers two ways to save a file: Save and Save As. These options work in similar ways, with a few 

important differences: 

Save: When you create or edit a workbook, you'll use the Save command to save your changes. You'll use this 

command most of the time. When you save a file, you'll only need to choose a file name and location the first 

time. After that, you can just click the Save command to save it with the same name and location. 

Save As: You'll use this command to create a copy of a workbook while keeping the original. When you use 

Save As, you'll need to choose a different name and/or location for the copied version. 

 

To save a workbook  

  

It's important to save your workbook whenever you start a new project or make changes to an existing one. 

Saving early and often can prevent your work from being lost. You'll also need to pay close attention to where 

you save the workbook so it will be easy to find later. 

 

Locate and select the Save command on the Quick Access Toolbar. 

 

 

If you're saving the file for the first time, the Save As pane will appear in Backstage view. 

You'll then need to choose where to save the file and give it a file name. To save the workbook to your 

computer, select Computer, then click Browse. Alternatively, you can click OneDrive to save the file to your 

OneDrive. 

The Save As dialog box will appear. Select the location where you wish to save the workbook. 



 

 

 

 

Enter a file name for the workbook, then click Save. 

 

 

 

The workbook will be saved. You can click the Save command again to save your changes as you modify the 

workbook. 

 

Using Save As to make a copy  

  

If you want to save a different version of a workbook while keeping the original, you can create a copy. For 

example, if you have a file named "Sales Data" you could save it as "Sales Data 2" so you'll be able to edit the 

new file and still refer back to the original version. 

To do this, you'll click the Save As command in Backstage view. Just like when saving a file for the first time, 

you'll need to choose where to save the file and give it a new file name. 

 

AutoRecover 

 

Excel automatically saves your workbooks to a temporary folder while you are working on them. If you forget 

to save your changes, or if Excel crashes, you can restore the file using AutoRecover. 

 

To use Auto Recover  

  

Open Excel 2013. If auto-saved versions of a file are found, the Document Recovery pane will appear. 

Choose a location, and 

then type the file name. 



 

 

 

 

Click to open an available file. The workbook will be recovered. 

 

 

 

 

 

 TIP: By default, Excel autosaves every 10 minutes. If you are editing a workbook for less than 10 minutes, 

Excel may not create an autosaved version. 

If you don't see the file you need, you can browse all autosaved files from Backstage view. Just select the File 

tab, click Manage Versions, and then choose Recover Unsaved Workbooks. 

 

 

Exporting workbooks 

 

By default, Excel workbooks are saved in the .xlsx file type. However, there may be times when you need to use 

another file type, such as a PDF or Excel 97-2003 workbook. It's easy to export your workbook from Excel in a 

variety of file types. 

To export a workbook as a PDF file  

Exporting your workbook as an Adobe Acrobat document, commonly known as a PDF file, can be especially 

useful if sharing a workbook with someone who does not have Excel. A PDF will make it possible for recipients 

to view, but not edit, the content of your workbook. 

Click the File tab to access Backstage view. 

Click Export, then select Create PDF/XPS. 



 

 

 

 

 
 

 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Publish. 

 

 TIP: By default, Excel will only export the active worksheet. If you have multiple worksheets and want to 

save all of them in the same PDF file, click Options in the Save as dialog box. The Options dialog box will 

appear. Select Entire workbook, then click OK. 

 

 

 

 

To export a workbook in other file types  

  

You may also find it helpful to export your workbook in other file types, such as an Excel 97-2003 Workbook if 

you need to share with people using an older version of Excel, or a .CSV file if you need a plain-text version of 

your workbook. 



 

 

 

 

Click the File tab to access Backstage view. 

Click Export, then select Change File Type. 

Select a common file type, then click Save As. 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Save. 

 

 

Challenge! 

Create a new blank workbook. 

Use the Save command to save the workbook to your desktop. 

Save the workbook to OneDrive and invite someone else to view it. 

Export the workbook as a PDF file. 

 

 

Cell Basics 

 

Whenever you work with Excel, you'll enter information, or content, into cells. Cells are the basic building 

blocks of a worksheet. You'll need to learn the basics of cells and cell content to calculate, analyze, and organize 

data in Excel. 

 

 

Understanding Cells 

 

Every worksheet is made up of thousands of rectangles, which are called cells. A cell is the intersection of a row 

and a column. Columns are identified by letters (A, B, C), while rows are identified by numbers (1, 2, 3). 

 

Colum 

Row Cell 



 

 

 

 

Each cell has its own name, or cell address, based on its column and row. In this example, the selected cell 

intersects column C and row 5, so the cell address is C5. The cell address will also appear in the Name box. 

Note that a cell's column and row headings are highlighted when the cell is selected. 

 

 

 

 

You can also select multiple cells at the same time. A group of cells is known as a cell range. Rather than a 

single cell address, you will refer to a cell range using the cell addresses of the first and last cells in the cell 

range, separated by a colon. For example, a cell range that included cells A1, A2, A3, A4, and A5 would be 

written as A1:A5. 

 

In the images below, two different cell ranges are selected: 

 

Cell range A1:A8 

 

 

Cell range A1:B8 

Cell Address 



 

 

 

 

 
 

To select a cell range  

 

Sometimes you may want to select a larger group of cells, or a cell range. 

 

Click, hold, and drag the mouse until all of the adjoining cells you wish to select are highlighted. 

Release the mouse to select the desired cell range. The cells will remain selected until you click another cell in 

the worksheet. 

Cell Content 

 

Any information you enter into a spreadsheet will be stored in a cell. Each cell can contain several different 

kinds of content, including text, formatting, formulas, and functions. 

 

Text 

Cells can contain text, such as letters, numbers, and dates. 
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Formatting Attributes 

Cells can contain formatting attributes that change the way letters, numbers, and dates are displayed. For 

example, percentages can appear as 0.15 or 15%. You can even change a cell's background color. 

 

Formulas and Functions 

Cells can contain formulas and functions that calculate cell values. In our example, SUM(B4:B7) adds the value 

of each cell in cell range B4:B7 and displays the total in cell B8. 

 

 

To insert content  

Click a cell to select it. 

 

Type content into the selected cell, then press Enter on your keyboard. The content will appear in the cell and 

the formula bar. You can also input and edit cell content in the formula bar. 

 

 

 
 
 
 

Content appears in cell 

and formula bar 



 

 

 

 

To delete cell content  

Select the cell with content you wish to delete. 

Press the Delete or Backspace key on your keyboard. The cell's contents will be deleted. 

To delete cells  

There is an important difference between deleting the content of a cell and deleting the cell itself. If you delete 

the entire cell, the cells below it will shift up and replace the deleted cells. 

Select the cell(s) you wish to delete. 

Select the Delete command from the Home tab on the Ribbon. 

The cells below will shift up. 

 

 

 

 

To copy and paste cell content  

Excel allows you to copy content that is already entered into your spreadsheet and paste that content to other 

cells, which can save you time and effort. 

Select the cell(s) you wish to copy. 

Click the Copy command on the Home tab, or press Ctrl+C on your keyboard. 



 

 

 

 

 
 

 

Select the cell(s) where you wish to paste the content. The copied cells will now have a dashed box around 

them. 

Click the Paste command on the Home tab, or press Ctrl+V on your keyboard. 

The content will be pasted into the selected cells. 

 

 

To access more paste options  

You can also access additional paste options, which are especially convenient when working with cells that 

contain formulas or formatting. 

 To access more paste options, click the drop-down arrow on the Paste command. 

 



 

 

 

 

 TIP: Rather than choosing commands from the Ribbon, you can access commands quickly by right- clicking. 

Simply select the cell(s) you wish to format, then right-click the mouse. A drop-down menu will appear, where 

you'll find several commands that are also located on the Ribbon. 

 

 

To drag and drop cells  

Rather than cutting, copying, and pasting, you can drag and drop cells to move their contents. 

Select the cell(s) you wish to move. 

Hover the mouse over the border of the selected cell(s) until the cursor changes from a white cross to a black 

cross with four arrows. 

Click, hold, and drag the cells to the desired location. 

Release the mouse, and the cells will be dropped in the selected location. 

 

 

To use the fill handle  

There may be times when you need to copy the content of one cell to several other cells in your worksheet. You 

could copy and paste the content into each cell, but this method would be very time consuming. Instead, you can 

use the fill handle to quickly copy and paste content to adjacent cells in the same row or column. 

Select the cell(s) containing the content you wish to use. The fill handle will appear as a small square in the 

bottom-right corner of the selected cell(s). 



 

 

 

 

 
Click, hold, and drag the fill handle until all of the cells you wish to fill are selected. 

 

 

 

 

Release the mouse to fill the selected cells. 

 

To continue a series with the fill handle  

The fill handle can also be used to continue a series. Whenever the content of a row or column follows a 

sequential order, like numbers (1, 2, 3) or days (Monday, Tuesday, Wednesday), the fill handle can guess what 

should come next in the series. In many cases, you may need to select multiple cells before using the fill handle 

to help Excel determine the series order. In our example below, the fill handle is used to extend a series of dates 

in a column. 

The fill handle 



 

 

 

 

 

 

  
 

 

 

 

Find and Replace 

 

When working with a lot of data in Excel, it can be difficult and time consuming to locate specific information. 

You can easily search your workbook using the Find feature, which also allows you to modify content using the 

Replace feature. 

To find content  

From the Home tab, click the Find and Select command, then select Find... from the drop-down menu. 

 

 

 

 

 

 

 

 

 

 

The Find and Replace dialog box will appear. Enter the content you wish to find. 

Click Find Next. If the content is found, the cell containing that content will be selected. 



 

 

 

 

 
 

 

 

Click Find Next to find further instances or Find All to see every instance of the search term. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 TIP: You can also access the Find command by pressing Ctrl+F on your keyboard. 

 TIP: Click Options to see advanced search criteria in the Find and Replace dialog box. 

 

 

 

 

To replace cell content  

At times, you may discover that you've repeatedly made a mistake throughout your workbook (such as 

misspelling someone's name), or that you need to exchange a particular word or phrase for another. You can use 

Excel's Find and Replace feature to make quick revisions. 



 

 

 

 

From the Home tab, click the Find and Select command, then select Replace... from the drop- down menu. 

The Find and Replace dialog box will appear. Type the text you wish to find in the Find what: field. 

Type the text you wish to replace it with in the Replace with: field, then click Find Next. 

If the content is found, the cell containing that content will be selected. 

Review the text to make sure you want to replace it. 

If you wish to replace it, select one of the replace options: 

Replace will replace individual instances. 

Replace All will replace every instance of the text throughout the workbook. In our example, we'll choose this 

option to save time. 

A dialog box will appear, confirming the number of replacements made. Click OK to continue. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 

Formatting Cells 

 

All cell content uses the same formatting by default, which can make it difficult to read a workbook with a lot of 

information. Basic formatting can customize the look and feel of your workbook, allowing you to draw attention 

to specific sections and making your content easier to view and understand. You can also apply number 

formatting to tell Excel exactly what type of data you’re using in the workbook, such as percentages (%), 

currency ($), and so on. 



 

 

 

 

Font Formatting 

 

To change the font  

By default, the font of each new workbook is set to Calibri. However, Excel provides a variety of other fonts 

you can use to customize your cell text. In the example below, we'll format our title cell to help distinguish it 

from the rest of the worksheet. 

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font command on the Home tab. The Font drop-down menu will appear. 

Select the desired font. A live preview of the new font will appear as you hover the mouse over different 

options. 

 

 

 

The text will change to the selected font. 

 

 TIP: When creating a workbook in the workplace, you'll want to select a font that is easy to read. 

Along with Calibri, standard reading fonts include Cambria, Times New Roman, and Arial. 

To change the font size  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Size command on the Home tab. The Font Size drop- down menu 

will appear. 

Select the desired font size. A live preview of the new font size will appear as you hover the mouse over 

different options. 

The text will change to the selected font size. 

 TIP: You can also use the Increase Font Size and Decrease Font Size commands or enter a custom font size 

using your keyboard. 



 

 

 

 
 

To change the font color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Color command on the Home tab. The Color menu will appear. 

Select the desired font color. A live preview of the new font color will appear as you hover the mouse over 

different options. 

 

 

The text will change to the selected font color. 

 

 

To use the Bold, Italic, and Underline commands  

Select the cell(s) you wish to modify. 

Click the Bold (B), Italic (I), or Underline (U) command on the Home tab. In our example, we'll make the 

selected cells bold. 

Entering a custom 

font size 
Increase and 

Decrease Font 

Size commands 



 

 

 

 

 
 

 

The selected style will be applied to the text. 

 TIP: You can also press Ctrl+B on your keyboard to make selected text bold, Ctrl+I to apply italics, and 

Ctrl+U to apply an underline. 

 

Text Alignment 

 

By default, any text entered into your worksheet will be aligned to the bottom-left of a cell. Any numbers will 

be aligned to the bottom-right of a cell. Changing the alignment of your cell content allows you to choose how 

the content is displayed in any cell, which can make your cell content easier to read. 

To change horizontal text alignment  

Select the cell(s) you wish to modify. 

Select one of the three horizontal alignment commands on the Home tab. In our example, we'll choose Center 

Align. 

 

The text will realign. 

To change vertical text alignment  

Select the cell(s) you wish to modify. 

Select one of the three vertical alignment commands on the Home tab. In our example, we'll choose Middle 

Align. 



 

 

 

 

 
 

The text will realign. 

 

 

Cell borders and fill colors 

 

Cell borders and fill colors allow you to create clear and defined boundaries for different sections of your 

worksheet. 

To add a border  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Borders command on the Home tab. The Borders drop- down menu will 

appear. 

 

 

Select the border style you want to use. 

The selected border style will appear. 

 TIP: You can draw borders and change the line style and color of borders with the Draw Borders tools at the 

bottom of the Borders drop-down menu. 



 

 

 

 

 
 

 

To add a fill color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Fill Color command on the Home tab. The Fill Color menu will appear. 

Select the fill color you want to use. A live preview of the new fill color will appear as you hover the mouse 

over different options. In our example, we'll choose Light Green. 

 

 

The selected fill color will appear in the selected cells. 



 

 

 

 

Cell styles 

 

Rather than formatting cells manually, you can use Excel's predesigned cell styles. Cell styles are a quick way to 

include professional formatting for different parts of your workbook, such as titles and headers. 

To apply a cell style  

Select the cell(s) you wish to modify. 

Click the Cell Styles command on the Home tab, then choose the desired style from the drop-down menu. 

 

 

The selected cell style will appear. 

 TIP: Applying a cell style will replace any existing cell formatting except for text alignment. You may not 

want to use cell styles if you've already added a lot of formatting to your workbook. 

 

Formatting text and numbers 

 

One of the most powerful tools in Excel is the ability to apply specific formatting for text and numbers. Instead 

of displaying all cell content in exactly the same way, you can use formatting to change the appearance of dates, 

times, decimals, percentages (%), currency ($), and much more. 

To apply number formatting  

Select the cells(s) you wish to modify. 

Click the drop-down arrow next to the Number Format command on the Home tab. The Number Formatting 

drop-down menu will appear. 

Select the desired formatting option. 

The selected cells will change to the new formatting style. 



 

 

 

General is the default format for any cell. 
When you enter a number into the cell, 

Excel will guess the number format that is 

most appropriate. 
Number formats numbers 
with decimal places. 

Currency formats numbers as currency 
with a currency symbol. 

Short Date formats numbers 
as M/D/YYYY. 

Accounting formats numbers as monetary 
values like the Currency format, but it also 

aligns currency symbols and decimal 

places within columns. 

Long Date formats numbers as 
Weekday, Month DD, YYYY. 

Time formats numbers as HH/MM/SS 
and notes AM or PM. 

Percentage formats numbers with 
decimal places and the percent sign. 

Fraction formats numbers as fractions 
separated by the forward slash. 

Scientific formats numbers 
in scientific notation. 

Text formats numbers as text, meaning 
that what you enter into the cell will 

appear exactly as it was entered. 

You can easily customize any format in 
More Number Formats. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Challenge! 

Open an existing Excel 2013 workbook. 

Select a cell and change the font style, size, and color of the text. 

Apply bold, italics, or underline to a cell. 

Try changing the vertical and horizontal text alignment for some cells. 

Add a border to a cell range. 

Change the fill color of a cell range. 

Try changing the formatting of a number. 



 

 

 

 

Modifying Columns, Rows and Cells 

 

By default, every row and column of a new workbook is always set to the same height and width. Excel allows 

you to modify column width and row height in different ways, including wrapping text and merging cells. 

 

 

To modify column width  

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

 

Click, hold, and drag the mouse to increase or decrease the column width. 

Release the mouse. The column width will be changed. 

 TIP: If you see pound signs (#######) in a cell, it means that the column is not wide enough to display the 

cell content. Simply increase the column width to show the cell content. 

 

 

To AutoFit column width  

The AutoFit feature will allow you to set a column's width to fit its content automatically. 

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

Double-click the mouse. The column width will be changed automatically to fit the content. 

 TIP: You can also AutoFit the width for several columns at the same time. Simply select the columns you 

would like to AutoFit, then select the AutoFit Column Width command from the Format drop- down menu on 

the Home tab. This method can also be used for Row height. 



 

 

 

 

 

 
To modify row height  

Position the cursor over the row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse. The height of the selected row will be changed. 

 

 

To modify all rows or columns  

Rather than resizing rows and columns individually, you can modify the height and width of every row and 

column at the same time. This method allows you to set a uniform size for every row and column in your 

worksheet. 

Locate and click the Select All button just below the formula bar to select every cell in the worksheet. 

 

 

 

 

 

 

 

 

 

 

Position the mouse over a row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse when you are satisfied with the new row height for the worksheet. 



 

 

 

 

Inserting, deleting, moving, and hiding rows and columns 

 

After you've been working with a workbook for a while, you may find that you want to insert new columns or 

rows, delete certain rows or columns, move them to a different location in the worksheet, or even hide them. 

To insert rows  

Select the row heading below where you want the new row to appear. 

Click the Insert command on the Home tab. 

 

The new row will appear above the selected row. 

 

 TIP: When inserting new rows, columns, or cells, you will see the Insert Options button next to the 

inserted cells. This button allows you to choose how Excel formats these cells. By default, Excel formats 

inserted rows with the same formatting as the cells in the row above. To access more options, hover your mouse 

over the Insert Options button, then click the drop-down arrow. 

 

 



 

 

 

 

To insert columns  

Select the column heading to the right of where you want the new column to appear. 

Click the Insert command on the Home tab. 

 

The new column will appear to the left of the selected column. 

 

 TIP: When inserting rows and columns, make sure you select the entire row or column by clicking the 

heading. If you select only a cell in the row or column, the Insert command will only insert a new cell. 

 

To delete rows  

It's easy to delete any row that you no longer need in your workbook. 

Select the row(s) you want to delete. 

Click the Delete command on the Home tab. 

 



 

 

 

 

The selected row(s) will be deleted, and the rows below will shift up. 

To delete columns  

Select the columns(s) you want to delete. 

Click the Delete command on the Home tab. 

 

 

 

 

 

 

 

The selected columns(s) will be deleted, and the columns to the right will shift left. 

 TIP: It's important to understand the difference between deleting a row or column and simply clearing its 

contents. If you want to remove the content of a row or column without causing others to shift, right-click a 

heading, then select Clear Contents from the drop-down menu. 

 

 



 

 

 

 

To move a row or column  

Sometimes you may want to move a column or row to rearrange the content of your worksheet. 

Select the desired column heading for the column you wish to move, then click the Cut command on the Home 

tab or press Ctrl+X on your keyboard. 

Select the column heading to the right of where you want to move the column. For example, if you want to 

move a column between columns B and C, select column C. 

Click the Insert command on the Home tab, then select Insert Cut Cells from the drop-down menu. 

 

The column will be moved to the selected location, and the columns to the right will shift right. 

 

 TIP: You can also access the Cut and Insert commands by right-clicking the mouse and then selecting the 

desired commands from the drop-down menu. 

 

 

To hide and unhide a row or column  

At times, you may want to compare certain rows or columns without changing the organization of your 

worksheet. Excel allows you to hide rows and columns as needed. 

Select the column(s) you wish to hide, right-click the mouse, then select Hide from the formatting menu. 



 

 

 

 

The columns will be hidden. The green column line indicates the location of the hidden columns. 

 

 

 

 

To unhide the columns, select the columns to the left and right of the hidden columns (in other words, the 

columns on both sides of the hidden columns). 

Right-click the mouse, then select Unhide from the formatting menu. The hidden columns will reappear. 

 

 

Wrapping text and merging cells 

 

Whenever you have too much cell content to be displayed in a single cell, you may decide to wrap the text or 

merge the cell rather than resizing a column. Wrapping the text will automatically modify a cell's row height, 

allowing cell contents to be displayed on multiple lines. Merging allows you to combine a cell with adjacent, 

empty cells to create one large cell. 

Select the cells you wish to wrap. 

Select the Wrap Text command on the Home tab. 

 

Green 

column line 



 

 

 

 

The text in the selected cells will be wrapped. 

 TIP: Click the Wrap Text command again to unwrap the text. 

 

 

To merge cells using the Merge & Center command  

Select the cell range you want to merge together. 

Select the Merge & Center command on the Home tab. 

 

 

 

The selected cells will be merged, and the text will be centered. 

To access more merge options  

Click the drop-down arrow next to the Merge & Center command on the Home tab. The Merge drop-down 

menu will appear. From here, you can choose to: 

Merge & Center: Merges the selected cells into one cell and centers the text 

Merge Across: Merges the selected cells into larger cells while keeping each row separate 

Merge Cells: Merges the selected cells into one cell, but does not center the text 

Unmerge Cells: Unmerges selected cells 

 



 

 

 

 

 

Formulas and Functions 

 

One of the most powerful features in Excel is the ability to calculate numerical information using formulas. 

 

 

Simple Formulas 

 

Just like a calculator, Excel can add, subtract, multiply, and divide. In this lesson, we'll show you how to use 

cell references to create simple formulas. 

Mathematical operators  

Excel uses standard operators for formulas, such as a plus sign for addition (+), a minus sign for subtraction (-), 

an asterisk for multiplication (*), a forward slash for division (/), and a caret (^) for exponents. 

 

 

 

All formulas in Excel must begin with an equals sign (=). This is because the cell contains, or is equal to, the 

formula and the value it calculates. 



 

 

 

 

Understanding cell references  

While you can create simple formulas in Excel manually (for example, =2+2 or =5*5), most of the time you will 

use cell addresses to create a formula. This is known as making a cell reference. Using cell references will 

ensure that your formulas are always accurate because you can change the value of referenced cells without 

having to rewrite the formula. 

 

 

 

By combining a mathematical operator with cell references, you can create a variety of simple formulas in 

Excel. Formulas can also include a combination of cell references and numbers, as in the examples below: 

 

  

 
 
 

 
The formula in cell A3 

refers to the value in cell A1 

plus the value in cell A2 

 

The formula calculates 

and displays the answer  

to the equation A1 plus A2 



 

 

 

 

To create a formula  

Select the cell that will contain the formula. 

Type the equals sign (=). Notice how it appears in both the cell and the formula bar. 

 

 

 

 

Type the cell address of the cell you wish to reference first in the formula: cell D1 in our example. A blue 

border will appear around the referenced cell. 

Type the mathematical operator you wish to use. In our example, we'll type the addition sign (+). 

Type the cell address of the cell you wish to reference second in the formula: cell D2 in our example. A red 

border will appear around the referenced cell. 

 

 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell.  

 TIP: If the result of a formula is too  large to  be displayed  in  a  cell, it may appear as  pound  signs 

(#######) instead of a value. This means that the column is not wide enough to display the cell content. Simply 

increase the column width to show the cell content. 

 

 

Modifying values with cell references  

The true advantage of cell references is that they allow you to update data in your worksheet without having to 

rewrite formulas. 

 TIP: Excel will not always tell you if your formula contains an error, so it's up to you to check all of your 

formulas. 

 
 
 

 
Formula will appear in 

both the cell and the 

formula bar. 



 

 

 

 

To create a formula using the point-and-click method  

Rather than typing cell addresses manually, you can point and click on the cells you wish to include in your 

formula. This method can save a lot of time and effort when creating formulas. In our example below, we'll 

create a formula to calculate the cost of ordering several boxes of plastic silverware. 

Select the cell that will contain the formula. In our example, we'll select cell D3. 

 

 

 

Type the equals sign (=). 

Select the cell you wish to reference first in the formula: cell B3 in our example. The cell address will appear in 

the formula, and a dashed blue line will appear around the referenced cell. 

 

 

 

Type the mathematical operator you wish to use. In our example, we'll type the multiplication sign (*). 

Select the cell you wish to reference second in the formula: cell C3 in our example. The cell address will appear 

in the formula, and a dashed red line will appear around the referenced cell. 



 

 

 

 

 
 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell. 

 

 

 

Formulas can also be copied to adjacent cells with the fill handle, which can save a lot of time and effort if you 

need to perform the same calculation multiple times in a worksheet. 

To edit a formula  

Sometimes you may want to modify an existing formula. In the example below, we've entered an incorrect cell 

address in our formula, so we'll need to correct it. 

Select the cell containing the formula you wish to edit. 

Click the formula bar to edit the formula. You can also double-click the cell to view and edit the formula 

directly within the cell. 

A border will appear around any referenced cells. 

 

When finished, press Enter on your keyboard or select the Enter command in the formula bar. 

The formula will be updated, and the new value will be displayed in the cell. 

 TIP: If you change your mind, you can press the Esc key on your keyboard or click the Cancel command

 in the formula bar to avoid accidentally making changes to your formula. 



 

 

 

 

 TIP: To show all of the formulas in a spreadsheet, you can hold the Ctrl key and press ` (grave accent). The 

grave accent key is usually located in the upper-left corner of the keyboard. You can press Ctrl+` again to 

switch back to the normal view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

Unit-IV 

 

Complex Formulas 

 

A simple formula is a mathematical expression with one operator, such as 7+9. A complex formula has more 

than one mathematical operator, such as 5+2*8. When there is more than one operation in a formula, the order 

of operations tells Excel which operation to calculate first. In order to use Excel to calculate complex formulas, 

you will need to understand the order of operations. 

Order of operations  

Excel calculates formulas based on the following order of operations: 

Operations enclosed in parentheses 

Exponential calculations (3^2, for example) 

Multiplication and division, whichever comes first 

Addition and subtraction, whichever comes first 

 

 

Creating complex formulas  

In the example below, we will demonstrate how Excel solves a complex formula using the order of operations. 

Here, we want to calculate the cost of sales tax for an invoice. To do this, we'll write our formula as 

=(D2+D3)*0.075 in cell D4. This formula will add the prices of our items together and then multiply that value 

by the 7.5% tax rate (which is written as 0.075) to calculate the cost of sales tax. 



 

 

 

 

 
 

 

 TIP: It is especially important to enter complex formulas with the correct order of operations. Otherwise, 

Excel will not calculate the results accurately. In our example, if the parentheses are not included, the 

multiplication is calculated first and the result is incorrect. Parentheses are the best way to define which 

calculations will be performed first in Excel. 

 

 

Relative and Absolute Cell References 

 

There are two types of cell references: relative and absolute. Relative and absolute references behave differently 

when copied and filled to other cells. Relative references change when a formula is copied to another cell. 

Absolute references, on the other hand, remain constant, no matter where they are copied. 

 

 

Relative cell references 

 

By default, all cell references are relative references. When copied across multiple cells, they change based on 

the relative position of rows and columns. For example, if you copy the formula =A1+B1 from row 1 to row 2, 

the formula will become =A2+B2. Relative references are especially convenient whenever you need to repeat 

the same calculation across multiple rows or columns. 

 

 

To create and copy a formula using relative references  

In the following example, we want to create a formula that will multiply each item's price by the quantity. 

Rather than creating a new formula for each row, we can create a single formula in cell D2 and then copy 



 

 

 

 

it to the other rows. We'll use relative references so the formula correctly calculates the total for each item. 

Select the cell that will contain the formula. In our example, we'll select cell D2. 

Enter the formula to calculate the desired value. In our example, we'll type =B2*C2. 

 

 

 

 

 

Press Enter on your keyboard. The formula will be calculated, and the result will be displayed in the cell.  

Locate the fill handle in the lower-right corner of the desired cell. In our example, we'll locate the fill handle for 

cell D2. 

 

 

 

 

The fill handle 



 

 

 

 

 

 

Click, hold, and drag the fill handle over the cells you wish to fill. 

 

 

 

 

 

Release the mouse. The formula will be copied to the selected cells with relative references, and the values will 

be calculated in each cell. 

 

 

 TIP: You can double-click the filled cells to check their formulas for accuracy. The relative cell references 

should be different for each cell, depending on their rows. 

 

 

 

Click, hold and drag the fill handle to 

copy the formula to adjacent cells 



 

 

 

 

Absolute cell references 

 

There may be times when you do not want a cell reference to change when filling cells. Unlike relative 

references, absolute references do not change when copied or filled. You can use an absolute reference to keep a 

row and/or column constant. 

An absolute reference is designated in a formula by the addition of a dollar sign ($). It can precede the column 

reference, the row reference, or both. 

 

You will generally use the $A$2 format when creating formulas that contain absolute references. The other two 

formats are used much less frequently. 

 TIP: When writing a formula, you can press the F4 key on your keyboard to switch between relative and 

absolute cell references. This is an easy way to quickly insert an absolute reference. 

 

 

To create and copy a formula using absolute references  

In our example, we'll use the 7.5% sales tax rate in cell E1 to calculate the sales tax for all items in column 

D. We'll need to use the absolute cell reference $E$1 in our formula. Since each formula is using the same tax 

rate, we want that reference to remain constant when the formula is copied and filled to other cells in column D. 

Select the cell that will contain the formula. In our example, we'll select cell D3. 

Enter the formula to calculate the desired value. In our example, we'll type =(B3*C3)*$E$1. 

Press Enter on your keyboard. The formula will calculate, and the result will display in the cell.  



 

 

 

 

 

 
 

 

Locate the fill handle in the lower-right corner of the desired cell. 

Release the mouse. The formula will be copied to the selected cells with an absolute reference, and the values 

will be calculated in each cell. 

Challenge! 

Open an existing Excel workbook. 

Create a formula that uses a relative reference. Double-click a cell to see the copied formula and the relative cell 

references. 

Create a formula that uses an absolute reference. 

 

Functions 

 

A function is a predefined formula that performs calculations using specific values in a particular order. Excel 

includes many common functions that can be useful for quickly finding the sum, average, count, maximum 

value, and minimum value for a range of cells. In order to use functions correctly, you'll need to understand the 

different parts of a function and how to create arguments to calculate values and cell references. 

 

 

 

 

The parts of a function  

Formula =A1+A2+A3+A4+A5+A6+A7+A8 

Function =SUM(A1:A8) 

 

In order to work correctly, a function must be written a specific way, which is called the syntax. The basic 

syntax for a function is an equals sign (=), the function name (SUM, for example), and one or more arguments. 

Arguments contain the information you want to calculate. 



 

 

 

 

 

 

 
 

Working with arguments  

Arguments can refer to both individual cells and cell ranges and must be enclosed within parentheses. You can 

include one argument or multiple arguments, depending on the syntax required for the function. 

 

 

For example, the function =AVERAGE(B1:B9) would calculate the average of the values in the cell range 

B1:B9. This function contains only one argument. 

 

 

Multiple arguments must be separated by a comma. For example, the function =SUM(A1:A3, C1:C2, E2) will 

add the values of all the cells in the three arguments. 

=SUM(A1:A20) 

Equal sign Argument 

Function name 



 

 

 

 

 

 
 

Creating a function 

 

Excel has a variety of functions available. Here are some of the most common functions you'll use: 

SUM: This function adds all of the values of the cells in the argument. 

AVERAGE: This function determines the average of the values included in the argument. It calculates the sum 

of the cells and then divides that value by the number of cells in the argument. 

COUNT: This function counts the number of cells with numerical data in the argument. This function is useful 

for quickly counting items in a cell range. 

MAX: This function determines the highest cell value included in the argument. 

MIN: This function determines the lowest cell value included in the argument. 

 

 

To create a basic function  

In our example below, we'll create a basic function to calculate the average price per unit for a list of recently 

ordered items using the AVERAGE function. 

Select the cell that will contain the function. 

Type the equals sign (=) and enter the desired function name. You can also select the desired function from the 

list of suggested functions that will appear below the cell as you type. In our example, we'll type =AVERAGE. 



 

 

 

 

 
 

Enter the cell range for the argument inside parentheses. In our example, we'll type (D3:D12). 

Press Enter on your keyboard. The function will be calculated, and the result will appear in the cell.  

 

 

To create a function using the AutoSum command  

The AutoSum command allows you to automatically insert the most common functions into your formula, 

including SUM, AVERAGE, COUNT, MIN, and MAX. In our example below, we'll create a function to 

calculate the total cost for a list of recently ordered items using the SUM function. 

Select the cell that will contain the function. 

In the Editing group on the Home tab, locate and select the arrow next to the AutoSum command and then 

choose the desired function from the drop-down menu. In our example, we'll select Sum. 

 



 

 

 

 

The selected function will appear in the cell. If logically placed, the AutoSum command will automatically 

select a cell range for the argument. You can also manually enter the desired cell range into the argument. 

 

 

Press Enter on your keyboard. 

 

 

The Function Library 

 

While there are hundreds of functions in Excel, the ones you use most frequently will depend on the type of data 

your workbooks contains. There is no need to learn every single function, but exploring some of the different 

types of functions will be helpful as you create new projects. You can search for functions by category, such as 

Financial, Logical, Text, Date & Time, and more from the Function Library on the Formulas tab. 

 To access the Function Library, select the Formulas tab on the Ribbon. The Function Library will appear. 

 

 



 

 

 

 

 
 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. 

The AutoSum command allows you to automatically return results for common functions, like SUM, 

AVERAGE, and COUNT. 

The Recently Used command gives you access to functions that you have recently worked with. 

The Financial category contains functions for financial calculations like determining a payment (PMT) or 

interest rate for a loan (RATE). 

Functions in the Logical category check arguments for a value or condition. For example, if an order is over 

$50 add $4.99 for shipping, but if it is over $100, do not charge for shipping (IF). 

The Text category contains functions that work with the text in arguments to perform tasks, such as converting 

text to lowercase (LOWER) or replacing text (REPLACE). 

The Date & Time category contains functions for working with dates and time and will return results like the 

current date and time (NOW) or the seconds (SECOND). 

The Lookup & Reference category contains functions that will return results for finding and referencing 

information. For example, you can add a hyperlink (HYPERLINK) to a cell or return the value of a particular 

row and column intersection (INDEX). 

The Math & Trig category includes functions for numerical arguments. For example, you can round values 

(ROUND), find the value of Pi (PI) multiply (PRODUCT), subtotal (SUBTOTAL), and much more. 

More Functions contains additional functions under categories for Statistical, Engineering, Cube, Information, 

and Compatibility. 

 

To insert a function from the Function Library  

 

Select the cell that will contain the function. 

 

Click the Formulas tab on the Ribbon to access the Function Library. 

 

From the Function Library group, select the desired function category. 

 

Select the desired function from the drop-down menu. 



 

 

 

 

 
 

 

 

The Function Arguments dialog box will appear. From here, you'll be able to enter or select the cells that will 

make up the arguments in the function. 

 

 

 

When you're satisfied with the arguments, click OK. 

 

The function will be calculated, and the result will appear in the cell. 



 

 

 

 

Like formulas, functions can be copied to adjacent cells. Hover the mouse over the cell that contains the 

function, then click, hold, and drag the fill handle over the cells you wish to fill. The function will be copied, 

and values for those cells will be calculated relative to their rows or columns. 

 

 

 

 

 

 

The Insert Function command 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. While it can be extremely useful, this command is sometimes a little difficult to use. 

If you don't have much experience with functions, you may have more success browsing the Function Library 

instead. For more advanced users, however, the Insert Function command can be a powerful way to find a 

function quickly. 

 

 

To use the Insert Function command  

Select the cell that will contain the function. 

Click the Formulas tab on the Ribbon, then select the Insert Function command. 

The Insert Function dialog box will appear. 

Type a few keywords describing the calculation you want the function to perform, then click Go. 

Review the results to find the desired function, then click OK. 



 

 

 

 

 
 

 

The Function Arguments dialog box will appear. 

When you're satisfied, click OK. 

The function will be calculated, and the result will appear in the cell. 

 

 



 

 

 

Unit-V 

 

 

SUM 

Formula: =SUM(5, 5) or =SUM(A1, B1) or =SUM(A1:B5) 

The SUM formula does exactly what you would expect. It allows you to add 2 or more numbers together. You 

can use cell references as well in this formula. 

 

 

COUNT 

Formula: =COUNT(A1:A10) 

The count formula counts the number of cells in a range that have numbers in them. 

 

 

It only counts the cells where there are numbers. 

 

 

COUNTA 

Formula: =COUNTA(A1:A10) 

Counts the number of non-empty cells in a range. It will count cells that have numbers and/or any other 

characters in them. 

The COUNTA Formula works with all data types. 



 

 

 

 

 
 

 

It counts the number of non-empty cells no matter the data type. 

LEN 

Formula: =LEN(A1) 

The LEN formula counts the number of characters in a cell. This includes spaces! 

 

Notice the difference in the formula results: 10 characters without spaces in between the words, 12 with spaces 

between the words. 

VLOOKUP 

Formula: =VLOOKUP(lookup_value, table_array, col_index_num, range_lookup) 

Basically, VLOOKUP lets you search for specific information in your spreadsheet. For example, if you have a 

list of products with prices, you could search for the price of a specific item. 

We’re going to use VLOOKUP to find the price of the Photo frame. You can probably already see that the price 

is $9.99, but that’s because this is a simple example. Once you learn how to use VLOOKUP, you’ll be able to 

use it with larger, more complex spreadsheets, and that’s when it will become truly useful.  



 

 

 

 

 
 

As with any formula, you’ll start with an equal sign (=). Then, type the formula name. 

=VLOOKUP(“Photo frame” 

The second argument is the cell range that contains the data. In this example, our data is in A2:B16. As with any 

function, you’ll need to use a comma to separate each argument: 

=VLOOKUP(“Photo frame”, A2:B16 

Note: It’s important to know that VLOOKUP will always search the first column in this range. In this example, 

it will search column A for “Photo frame”. In some cases, you may need to move the columns around so that the 

first column contains the correct data. 

The third argument is the column index number. It’s simpler than it sounds: The first column in the range is 1, 

the second column is 2, etc. In this case, we are trying to find the price of the item, and the prices are contained 

in the second column. That means our third argument will be 2: 

=VLOOKUP(“Photo frame”, A2:B16, 2 

The fourth argument tells VLOOKUP whether to look for approximate matches, and it can be either TRUE or 

FALSE. If it is TRUE, it will look for approximate matches. Generally, this is only useful if the first column has 

numerical values that have been sorted. Since we’re only looking for exact matches, the fourth argument should 

be FALSE. This is our last argument, so go ahead and close the parentheses: 

=VLOOKUP(“Photo frame”, A2:B16, 2, FALSE) 

And that’s it! When you press enter, it should give you the answer, which is 9.99. 



 

 

 

 

 
 

 

IF Statements 

Formula: =IF(logical_statement, return this if logical statement is true, return this if logical statement is false). 

Example 

Let’s say a salesperson has a quota to meet. You used VLOOKUP to put the revenue next to the name. Now you 

can use an IF statement that says: “IF the salesperson met their quota, say “Met quota”, if not say “Did not meet 

quota” 

=IF(C3>D3, “Met Quota”, “Did Not Meet Quota”) 

This IF statement will tell us if the first salesperson met their quota or not. We would then copy and paste this 

formula along all the entries in the list. It would change for each sales person. 

 

 



 

 

 

 

Working with Data 

 

Whenever you're working with a lot of data, it can be difficult to compare information in your workbook. 

Freezing Panes and View Options 

 

Excel includes several tools that make it easier to view content from different parts of your workbook at the 

same time, such as the ability to freeze panes and split your worksheet. 

To freeze rows  

You may want to see certain rows or columns all the time in your worksheet, especially header cells. By 

freezing rows or columns in place, you'll be able to scroll through your content while continuing to view the 

frozen cells. 

Select the row below the row(s) you wish to freeze. 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

 

 

 

The rows will be frozen in place, as indicated by the gray line. You can scroll down the worksheet while 

continuing to view the frozen rows at the top. 

To freeze columns  

Select the column to the right of the column(s) you wish to freeze. 



 

 

 

 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

The column will be frozen in place, as indicated by the gray line. You can scroll across the worksheet while 

continuing to view the frozen column on the left. 

To unfreeze rows or columns, click the Freeze Panes command, then select Unfreeze Panes from the drop-down 

menu. 

 

 

To split a worksheet  

Sometimes you may want to compare different sections of the same workbook without creating a new window. 

The Split command allows you to divide the worksheet into multiple panes that scroll separately. 

Select the cell where you wish to split the worksheet. 

Click the View tab on the Ribbon, then select the Split command. 

 

The workbook will be split into different panes. You can scroll through each pane separately using the scroll 

bars, allowing you to compare different sections of the workbook. 

To remove the split, click the Split command again. 

 

 

. 

 

Sorting Data 

 

As you add more content to a worksheet, organizing that information becomes especially important. You can 

quickly reorganize a worksheet by sorting your data. For example, you could organize a list of contact 

information by last name. Content can be sorted alphabetically, numerically, and in many other ways. 



 

 

 

 

When sorting data, it's important to first decide if you would like the sort to apply to the entire worksheet or just 

a cell range. 

Sort sheet organizes all of the data in your worksheet by one column. 

Sort range sorts the data in a range of cells, which can be helpful when working with a sheet that contains 

several tables. Sorting a range will not affect other content on the worksheet. 

 

To sort a sheet  

In our example, we'll sort a T-shirt order form alphabetically by Last Name (column C). 

Select a cell in the column you wish to sort by. In our example, we'll select cell C2. 

 

 

 

Select the Data tab on the Ribbon, then click the Ascending command  to Sort A to Z, or the Descending 

command  to Sort Z to A. In our example, we'll click the Ascending command. 

 

 

The worksheet will be sorted by the selected column. In our example, the worksheet is now sorted by last name. 



 

 

 

 

 
 

 

Filtering Data 

 

If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters can be used to 

narrow down the data in your worksheet, allowing you to view only the information you need. 

To filter data  

In order for filtering to work correctly, your worksheet should include a header row, which is used to identify 

the name of each column. 

Select the Data tab, then click the Filter command. 

 

 

A drop-down arrow will appear in the header cell for each column. 

Click the drop-down arrow for the column you wish to filter. 



 

 

 

 

The Filter menu will appear. 

Uncheck the box next to Select All to quickly deselect all data. 

Check the boxes next to the data you wish to filter, then click OK. 

To remove all filters from your worksheet, click the Filter command on the Data tab. 

 

 

Working with Charts 

 

Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart types that you can 

choose from when you create a chart. Excel offers Pie, Line, Bar, and Column charts to name but a few. 

Showing data in a chart can make it clearer, more interesting and easier to read. Charts can also help you 

evaluate your data and make comparisons between different values. 

 

 

Understanding charts 

 

Excel has several different types of charts, allowing you to choose the one that best fits your data. In order to 

use charts effectively, you'll need to understand how different charts are used. 

Types of Charts: 

Column charts use vertical bars to represent data. They can work with many different types of data, but they're 

most frequently used for comparing information. 

Line charts are ideal for showing trends. The data points are connected with lines, making it easy to see whether 

values are increasing or decreasing over time. 

Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so it's easy to see 

which values make up the percentage of a whole. 

Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars. 

Area charts are similar to line charts, except that the areas under the lines are filled in. 

Surface charts allow you to display data across a 3D landscape. They work best with large data sets, allowing 

you to see a variety of information at the same time. 

 

 

To insert a chart  

  

Select the cells you want to chart, including the column titles and row labels. These cells will be the source data 

for the chart. 



 

 

 

 

From the Insert tab, click the desired Chart command. 

Choose the desired chart type from the drop-down menu. 

 

 

 

 

The selected chart will be inserted in the worksheet. 

 TIP: If you're not sure which type of chart to use, the Recommended Charts command will suggest several 

different charts based on the source data. 

 

 

 

Chart layout and style 

 

After inserting a chart, there are several things you may want to change about the way your data is displayed. 

It's easy to edit a chart's layout and style from the Design tab. 

Excel allows you to add chart elements—such as chart titles, legends, and data labels—to make your chart 

easier to read. To add a chart element, click the Add Chart Element command on the Design tab, then choose 

the desired element from the drop-down menu. 



 

 

 

 

 
 

 

To edit a chart element, like a chart title, simply double-click the placeholder and begin typing. 

 

 

If you don't want to add chart elements individually, you can use one of Excel's predefined layouts. Simply click 

the Quick Layout command, then choose the desired layout from the drop-down menu. 

Excel also includes several different chart styles, which allow you to quickly modify the look and feel of your 

chart. To change the chart style, select the desired style from the Chart styles group. 



 

 

 

 

 
 

 TIP: You can also use the chart formatting shortcut buttons to quickly add chart elements, change the chart 

style, and filter the chart data. 

 

 

 

 

Other chart options 

 

There are lots of other ways to customize and organize your charts. For example, Excel allows you to rearrange 

a chart's data, change the chart type, and even move the chart to a different location in the workbook. 

To switch row and column data  

Sometimes you may want to change the way charts group your data. For example, in the chart below, the Book 

Sales data are grouped by year, with columns for each genre. However, we could switch the rows and columns 

so the chart will group the data by genre, with columns for each year. In both cases, the chart contains the same 

data—it's just organized differently. 

Select the chart you wish to modify. 



 

 

 

 

From the Design tab, select the Switch Row/Column command. 

 

The rows and columns will be switched. 

 

 

To change the chart type  

If you find that your data isn't well suited to a certain chart, it's easy to switch to a new chart type. In our 

example, we'll change our chart from a Column chart to a Line chart. 

From the Design tab, click the Change Chart Type command. 

 

The Change Chart Type dialog box will appear. 

The selected chart type will appear. 

 

 

To move a chart  

Whenever you insert a new chart, it will appear as an object on the same worksheet that contains its source data. 

Alternatively, you can move the chart to a new worksheet to help keep your data organized. 

Select the chart you wish to move. 

Click the Design tab, then select the Move Chart command. 

 



 

 

 

 

The Move Chart dialog box will appear. Select the desired location for the chart. 

Click OK. 

The chart will appear in the selected location. 

 

 

Challenge! 

Open an existing Excel workbook. 

Use worksheet data to create a chart. 

Change the chart layout. 

Apply a chart style. 

Move the chart. 

 

 

Printing Workbooks 

 

There may be times when you want to print a workbook to view and share your data offline. Once you've 

chosen your page layout settings, it's easy to preview and print a workbook from Excel using the Print pane. 

 

 

To access the Print pane  

Select the File tab. Backstage view will appear. 

 

 

 

 

 

Select Print. The Print pane will appear. 



 

 

 

 

 

 

Here you can choose how many copies of the workbook you wish to print. 

 

 

When you are ready to print the workbook, click the Print button. 

 

You may need to select the printer you want to use if your computer is connected to multiple printers. 

 

 

 

 

 

Here you can choose to print the active sheets, the entire workbook, or a selection of 

 

 

 

 

If you are printing multiple copies, you 

can choose whether you want the 

copies collated or uncollated. 

Here you can choose whether to print on 

one side or both sides of the paper. 

 

 

 

If your printer uses different paper sizes, 

you can choose the paper size you wish 

to use. 

 

 

Here you can choose how to scale your 

worksheets for the printed page. You can 

scale worksheets at their actual size, fit 

the entire worksheet on one page, fit all 

columns on one page, or fit all rows on 

one page. 

Here you can choose Portrait 

or Landscape orientation. 

 

 

 

Here you can adjust the page 

margins, which can help your data 

fit more comfortably on the page. 

 

 

 

Choosing a print area 

 

Before you print an Excel workbook, it's important to decide exactly what information you want to print. For 

example, if you have multiple worksheets in your workbook, you will need to decide if you want to print the 

entire workbook or only active worksheets. There may also be times when you want to print only a selection of 

content from your workbook. 



 

 

 

 

To print active sheets  

Worksheets are considered active when selected. 

Select the worksheet you want to print. To print multiple worksheets, click the first worksheet, hold the Ctrl key 

on your keyboard, then click any other worksheets you want to select. 

 

Navigate to the Print pane. 

Select Print Active Sheets from the Print Range drop-down menu. 

 

Click the Print button. 

 

 

 

 

 

To print the entire workbook  

Navigate to the Print pane. 

Select Print Entire Workbook from the Print Range drop-down menu. 



 

 

 

 

 
 

Click the Print button. 

 

 

 

To print a selection  

Select the cells you wish to print. 

Navigate to the Print pane. 

Select Print Selection from the Print Range drop-down menu. 

 

A preview of your selection will appear in the Preview pane. 

Click the Print button to print the selection. 



 

 

 

 

 
 

 TIP: If you prefer, you can also set the print area in advance so you'll be able to visualize which cells will be 

printed as you work in Excel. Simply select the cells you want to print, click the Page Layout tab, select the 

Print Area command, then choose Set Print Area. 

 

 

 

 

 

 

Fitting and scaling content 

 

On occasion, you may need to make small adjustments from the Print pane to fit your workbook content neatly 

onto a printed page. The Print pane includes several tools to help fit and scale your content, such as scaling and 

page margins. 

  



 

 

 

 

To fit content before printing  

If some of your content is being cut off by the printer, you can use scaling to fit your workbook to the page 

automatically. 

Navigate to the Print pane. 

Select the desired option from the Scaling drop-down menu. In our example, we'll select Fit Sheet on One Page. 

 

The worksheet will be condensed to fit onto a single page. 

When you're satisfied with the scaling, click Print. 

 

 

To modify margins in the Preview pane  

Sometimes you may only need to adjust a single margin to make your data fit more comfortably. You can 

modify individual page margins from the Preview pane. 

Navigate to the Print pane, then click the Show Margins button in the lower-right corner. 



 

 

 

 

 
The page margins will appear in the Preview pane. Hover the mouse over one of the margin 

markers until the cursor becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the margin width. 

Release the mouse. The margin will be modified. In our example, we were able to fit an additional column on 

the page. 

 

 

Show Margins 
button. 



 

 

 

Unit-1 

 

Opening Excel 

 

Using Windows 7  

 

Click on the Start Button. 

In the Search Program and Files box type Excel. 

Click on Excel 2013 from the Program results. 

The Microsoft Excel 2013 program will open. 

 

 

Using Windows 8   

 

Press the Windows key on the keyboard. 

Type Excel. 

Click on Excel 2013 under the Apps results. 

 

 

Using iOS 7  

 

Click on Launchpad. 

Select Microsoft Excel. 

 

 

Getting Started 

 

When you open Excel 2013 for the first time, the Excel Start Screen will appear. From here, you'll be able to 

create a new workbook, choose a template, and access your recently edited workbooks. 

 

From the Excel Start Screen, locate and select Blank workbook to access the Excel interface. 

Click Open Other Workbooks to work on an existing workbook. 



 

 

 

 

 
 

 

 

To set up Excel so it automatically opens a new workbook   

 

Click File then Options. 

On the General tab, under Start up options, uncheck the Show the Start screen when this application starts box. 

The next time you start Excel, it opens a blank workbook automatically similar to older versions of Excel. 

 

The Excel Interface 

 

After starting Excel, you will see two windows - one within the other. The outer window is the Application 

Window and the inner window is the Workbook Window. When maximized, the Excel Workbook Window 

blends in with the Application Window. 

 

After completing this module, you should be able to: 

 

Identify the components of the Application Window. 

Identify the components of the Workbook Window. 

Create a new workbook 

Open an existing workbook 



 

 

 

 

 
 

 

The Application Window 

 

The Application Window provides the space for your worksheets and workbook elements such as charts. The 

components of the Application Window are described below. 

 

The Quick Access Toolbar 

 

The Quick Access Toolbar lets you access common commands no matter which tab is selected. 

 

By default, it includes the Save, Undo, and Repeat commands. You can add other commands depending on your 

preference. 

 

To add commands to the Quick Access toolbar  

 

Click the drop-down arrow to the right of the Quick Access toolbar. 

Quick Access Toolbar 

The Ribbon 

Command Group 

Name Box Formula Bar 
Colum 

Cell 

Row 

Vertical and Horizontal Scroll Bars 

Worksheets 

Worksheet View Option Zoom Control 



 

 

 

 

Select the command you wish to add from the drop-down menu. To choose from more commands, select More 

Commands. 

 

 

 

 

The command will be added to the Quick Access toolbar. 

 

 

 

 

 

 

The Ribbon 

 

Excel 2013 uses a tabbed Ribbon system instead of traditional menus. The Ribbon contains multiple tabs, each 

with several groups of commands. You will use these tabs to perform the most common tasks in Excel.  



 

 

 

 

 

 
 

 

 

To minimize and maximize the Ribbon  

 

The Ribbon is designed to respond to your current task, but you can choose to minimize it if you find that it 

takes up too much screen space. 

 

Click the Ribbon Display Options arrow in the upper-right corner of the Ribbon. 

 

Click a tab to see 
more commands 

Each tab is divided 
into groups 



 

 

 

 

Select the desired minimizing option from the drop-down menu: 

 

Auto-hide Ribbon: Auto-hide displays your workbook in full-screen mode and completely hides the Ribbon. To 

show the Ribbon, click the Expand Ribbon command at the top of screen. 

 

 

Show Tabs: This option hides all command groups when not in use, but tabs will remain visible. To show the 

Ribbon, simply click a tab. 

 Show Tabs and Commands: This option maximizes the Ribbon. All of the tabs and commands will be visible. 

This option is selected by default when you open Excel for the first time. 

 

To Customize the Ribbon in Excel 2013  

 

You can customize the Ribbon by creating your own tabs with whichever commands you want. Commands are 

always housed within a group, and you can create as many groups as you want in order to keep your tab 

organized. If you want, you can even add commands to any of the default tabs, as long as you create a custom 

group in the tab. 

 

Right-click the Ribbon and then select Customize the Ribbon... from the drop-down menu. 

 

 

The Excel Options dialog box will appear. Locate and select New Tab. 

Ribbon is hidden and workbook 

appears in full screen 
Click the Expand Ribbon 

command to show the Ribbon 



 

 

 

 

 
 

Make sure the New Group is selected, select a command, and then click Add. You can also drag commands 

directly into a group. 

When you are done adding commands, click OK. The commands will be added to the Ribbon. 

 

 

Select 

commands and 

click Add 



 

 

 

Unit-II 

 

 

The Formula Bar 

 

In the formula bar, you can enter or edit data, a formula, or a function that will appear in a specific cell. 

 

In the image below, cell C1 is selected and 1984 is entered into the formula bar. Note how the data appears in 

both the formula bar and in cell C1. 

 

 

 

The Name Box 

 

The Name box displays the location, or "name" of a selected cell. 

 

In the image below, cell B4 is selected. Note that cell B4 is where column B and row 4 intersect. 

 

 

The Backstage View (The File Menu) 

 

Click the File tab on the Ribbon. Backstage view will appear. 

 

 



 

 

 

 

 

 

 
 

 

The Worksheet Views 

 

Excel 2013 has a variety of viewing options that change how your workbook is displayed. You can choose to 

view any workbook in Normal view, Page Layout view, or Page Break view. These views can be useful for 

various tasks, especially if you're planning to print the spreadsheet. 

 

To change worksheet views, locate and select the desired worksheet view command in the bottom-right corner 

of the Excel window. 

Return to Excel 
Info contains 

information about the 
current workbook. You 

can also inspect the 
workbook and set 

protection controls. 
New: you can create a new, blank 
workbook, or choose from a large 

selection of templates. 

Open: you can open 
recent workbooks, as 

well as workbooks saved 

to your OneDrive or on Use Save and Save As to save 

your computer. your workbook to your computer 
or to Office 365. 

From the Print pane, 
you can change the 

print settings and print 

your workbook. You 

can also see a preview 

of your workbook. 

Share: you can invite people to view and 
collaborate on your workbook. You can also share 

your workbook by emailing it as an attachment. 

Export: you can choose 
to export your 

workbook in another 
format, such as 

PDF/XPS or Excel 
1997-2003. 

Close the current workbook. 
 

From the Account pane, you can access your 
Microsoft account information, modify your theme 

and background, and sign out of your account. 

Options: you can change various Excel options. For 
example, you can control the Quick Analysis preferences, 

Auto Recover settings, or Language preferences. 



 

 

 

 

 
 

 

Zoom Control 

 

To use the Zoom control, click and drag the slider. The number to the right of the slider reflects the zoom 

percentage. 

 

 

Page Layout 

View 

Normal View Page Break 

View 



 

 

 

 

The Workbook Window 

 

In Excel 2013, when you open up a new workbook it now contains only 1 worksheet There can be a max of 

1,048,576 rows and 16,384 columns in an excel work sheet. 

 

The Worksheet 

 

Excel files are called workbooks. Each workbook holds one or more worksheets (also known as "spreadsheets"). 

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. A worksheet is a grid 

of columns and rows where columns are designated by letters running across the top of the worksheet and rows 

are designated by numbers running down the left side of the worksheet. 

 

 

 

When working with a large amount of data, you can create multiple worksheets to help organize your workbook 

and make it easier to find content. You can also group worksheets to quickly add information to multiple 

worksheets at the same time. 

 

To rename a worksheet  

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. You can rename a 

worksheet to better reflect its content. In our example, we will create a training log organized by month. 

 

Right-click the worksheet you wish to rename, then select Rename from the worksheet menu. 



 

 

 

 

 
 

Type the desired name for the worksheet. 

 

 

Click anywhere outside of the worksheet, or press Enter on your keyboard. The worksheet will be renamed. 

 

 

To insert a new worksheet  

 

Locate and select the New sheet button. 

 

 

Click to add a 

new worksheet 



 

 

 

 

A new, blank worksheet will appear. 

 

 TIP: To change the default number of worksheets, navigate to Backstage view, click Options, and then 

choose the desired number of worksheets to include in each new workbook. 

 

 

 

To delete a worksheet  

 

Right-click the worksheet you wish to delete, then select Delete from the worksheet menu. 

 

 

The worksheet will be deleted from your workbook. 



 

 

 

 

 
 

 

 

Alternatively, from the Home Tab in the Cells Group click on Delete and select Delete Sheet. Warning: The 

Undo button will not undo the deletion of a worksheet. 

To copy a worksheet  

 

If you need to duplicate the content of one worksheet to another, Excel allows you to copy an existing 

worksheet. 

 

Right-click the worksheet you want to copy, then select Move or Copy from the worksheet menu. 

 

 

 

 

The Move or Copy dialog box will appear. Choose where the sheet will appear in the Before sheet: field. In our 

example, we'll choose (move to end) to place the worksheet to the right of the existing worksheet. 

Check the box next to Create a copy, then click OK. 



 

 

 

 

 
 

The worksheet will be copied. It will have the same title as the original worksheet, as well as a version number.  

 

TIP: You can also copy a worksheet to an entirely different workbook. You can select any workbook that is 

currently open from the To book: drop-down menu. 

 

 

To move a worksheet  

 

Sometimes you may want to move a worksheet to rearrange your workbook. 

 

Select the worksheet you wish to move. The cursor will become a small worksheet icon . 

Hold and drag the mouse until a small black arrow appears above the desired location. 



 

 

 

 

 
 

Release the mouse. The worksheet will be moved. 

 

To change the worksheet color  

 

You can change a worksheet's color to help organize your worksheets and make your workbook easier to 

navigate. 

 

Right-click the desired worksheet, and hover the mouse over Tab Color. The Color menu will appear. 

Select the desired color. A live preview of the new worksheet color will appear as you hover the mouse over 

different options. In our example, we'll choose Red. 

The worksheet color will be changed. 



 

 

 

 

The worksheet color is considerably less noticeable when the worksheet is selected. Select another worksheet to 

see how the color will appear when the worksheet is not selected. 

 

 

 

 

 

. 

 



 

 

 

 

The Scroll Bars 

 

Your spreadsheet may frequently have more data than you can see on the screen at once. Click, hold and drag 

the vertical or horizontal scroll bar depending on what part of the page you want to see. 

 

 

 

 

 

Creating and Opening Workbooks 

 

Excel files are called workbooks. Whenever you start a new project in Excel, you'll need to create a new 

workbook. There are several ways to start working with a workbook in Excel 2013. You can choose to create a 

new workbook—either with a blank workbook or a predesigned template—or open an existing workbook. 

 

Create a new blank workbook 

 

Select the File tab. Backstage view will appear. 

 

Vertical 

scroll bar 

Horizontal 
scroll bar 



 

 

 

 

Select New, then click Blank workbook. 

A new blank workbook will appear. 

 

Open an existing workbook 

 

In addition to creating new workbooks, you'll often need to open a workbook that was previously saved. 

Navigate to Backstage view, then click Open. 

 

 

 

 

Select Computer, and then click Browse. 

 



 

 

 

 

The Open dialog box will appear. Locate and select your workbook, then click Open. 

 

 

 

 TIP: If you've opened the desired workbook recently, you can browse your Recent Workbooks rather than 

searching for the file. 

 



 

 

 

 

To pin a workbook  

If you frequently work with the same workbook, you can pin it to Backstage view for quick access. 

Navigate to Backstage view and then click Open. Your recently edited workbooks will appear. 

Hover the mouse over the workbook you wish to pin. A pushpin icon will appear next to the workbook. Click 

the pushpin icon. 

 

 

The workbook will stay in Recent Workbooks. To unpin a workbook, simply click the pushpin icon again. 

 

 TIP: You can also pin folders to Backstage view for quick access. From Backstage view, click Open, then 

locate the folder you wish to pin and click the pushpin icon. 

 

 

Compatibility mode 

 

Sometimes you may need to work with workbooks that were created in earlier versions of Microsoft Excel, such 

as Excel 2003 or Excel 2000. When you open these kinds of workbooks, they will appear in Compatibility 

mode. 

 



 

 

 

 

Compatibility mode disables certain features, so you'll only be able to access commands found in the program 

that was used to create the workbook. For example, if you open a workbook created in Excel 2003, you can only 

use tabs and commands found in Excel 2003. 

In order to exit Compatibility mode, you'll need to convert the workbook to the current version type. However, 

if you're collaborating with others who only have access to an earlier version of Excel, it's best to leave the 

workbook in Compatibility mode so the format will not change. 

To convert a workbook  

If you want access to all of the Excel 2013 features, you can convert the workbook to the 2013 file format. Note 

that converting a file may cause some changes to the original layout of the workbook. 

Click the File tab to access Backstage view. 

Locate and select Convert command. 

 

 

 

 

The Save As dialog box will appear. Select the location where you wish to save the workbook, enter a file name 

for the presentation, and click Save. 

The workbook will be converted to the newest file type. 

 

 



 

 

 

 

Saving and Sharing Workbooks 

 

Whenever you create a new workbook in Excel, you'll need to know how to save it in order to access and edit it 

later. As with previous versions of Excel, you can save files locally to your computer. But unlike older versions, 

Excel 2013 also lets you save a workbook to the cloud using OneDrive. You can also export and share 

workbooks with others directly from Excel. 

 

Save and Save As 

 

Excel offers two ways to save a file: Save and Save As. These options work in similar ways, with a few 

important differences: 

Save: When you create or edit a workbook, you'll use the Save command to save your changes. You'll use this 

command most of the time. When you save a file, you'll only need to choose a file name and location the first 

time. After that, you can just click the Save command to save it with the same name and location. 

Save As: You'll use this command to create a copy of a workbook while keeping the original. When you use 

Save As, you'll need to choose a different name and/or location for the copied version. 

 

To save a workbook  

  

It's important to save your workbook whenever you start a new project or make changes to an existing one. 

Saving early and often can prevent your work from being lost. You'll also need to pay close attention to where 

you save the workbook so it will be easy to find later. 

 

Locate and select the Save command on the Quick Access Toolbar. 

 

 

If you're saving the file for the first time, the Save As pane will appear in Backstage view. 

You'll then need to choose where to save the file and give it a file name. To save the workbook to your 

computer, select Computer, then click Browse. Alternatively, you can click OneDrive to save the file to your 

OneDrive. 

The Save As dialog box will appear. Select the location where you wish to save the workbook. 



 

 

 

 

Enter a file name for the workbook, then click Save. 

 

 

 

The workbook will be saved. You can click the Save command again to save your changes as you modify the 

workbook. 

 

Using Save As to make a copy  

  

If you want to save a different version of a workbook while keeping the original, you can create a copy. For 

example, if you have a file named "Sales Data" you could save it as "Sales Data 2" so you'll be able to edit the 

new file and still refer back to the original version. 

To do this, you'll click the Save As command in Backstage view. Just like when saving a file for the first time, 

you'll need to choose where to save the file and give it a new file name. 

 

AutoRecover 

 

Excel automatically saves your workbooks to a temporary folder while you are working on them. If you forget 

to save your changes, or if Excel crashes, you can restore the file using AutoRecover. 

 

To use Auto Recover  

  

Open Excel 2013. If auto-saved versions of a file are found, the Document Recovery pane will appear. 

Choose a location, and 

then type the file name. 



 

 

 

 

Click to open an available file. The workbook will be recovered. 

 

 

 

 

 

 TIP: By default, Excel autosaves every 10 minutes. If you are editing a workbook for less than 10 minutes, 

Excel may not create an autosaved version. 

If you don't see the file you need, you can browse all autosaved files from Backstage view. Just select the File 

tab, click Manage Versions, and then choose Recover Unsaved Workbooks. 

 

 

Exporting workbooks 

 

By default, Excel workbooks are saved in the .xlsx file type. However, there may be times when you need to use 

another file type, such as a PDF or Excel 97-2003 workbook. It's easy to export your workbook from Excel in a 

variety of file types. 

To export a workbook as a PDF file  

Exporting your workbook as an Adobe Acrobat document, commonly known as a PDF file, can be especially 

useful if sharing a workbook with someone who does not have Excel. A PDF will make it possible for recipients 

to view, but not edit, the content of your workbook. 

Click the File tab to access Backstage view. 

Click Export, then select Create PDF/XPS. 



 

 

 

 

 
 

 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Publish. 

 

 TIP: By default, Excel will only export the active worksheet. If you have multiple worksheets and want to 

save all of them in the same PDF file, click Options in the Save as dialog box. The Options dialog box will 

appear. Select Entire workbook, then click OK. 

 

 

 

 

To export a workbook in other file types  

  

You may also find it helpful to export your workbook in other file types, such as an Excel 97-2003 Workbook if 

you need to share with people using an older version of Excel, or a .CSV file if you need a plain-text version of 

your workbook. 



 

 

 

 

Click the File tab to access Backstage view. 

Click Export, then select Change File Type. 

Select a common file type, then click Save As. 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Save. 

 

 

Challenge! 

Create a new blank workbook. 

Use the Save command to save the workbook to your desktop. 

Save the workbook to OneDrive and invite someone else to view it. 

Export the workbook as a PDF file. 

 

 

Cell Basics 

 

Whenever you work with Excel, you'll enter information, or content, into cells. Cells are the basic building 

blocks of a worksheet. You'll need to learn the basics of cells and cell content to calculate, analyze, and organize 

data in Excel. 

 

 

Understanding Cells 

 

Every worksheet is made up of thousands of rectangles, which are called cells. A cell is the intersection of a row 

and a column. Columns are identified by letters (A, B, C), while rows are identified by numbers (1, 2, 3). 

 

Colum 

Row Cell 



 

 

 

 

Each cell has its own name, or cell address, based on its column and row. In this example, the selected cell 

intersects column C and row 5, so the cell address is C5. The cell address will also appear in the Name box. 

Note that a cell's column and row headings are highlighted when the cell is selected. 

 

 

 

 

You can also select multiple cells at the same time. A group of cells is known as a cell range. Rather than a 

single cell address, you will refer to a cell range using the cell addresses of the first and last cells in the cell 

range, separated by a colon. For example, a cell range that included cells A1, A2, A3, A4, and A5 would be 

written as A1:A5. 

 

In the images below, two different cell ranges are selected: 

 

Cell range A1:A8 

 

 

Cell range A1:B8 

Cell Address 



 

 

 

 

 
 

To select a cell range  

 

Sometimes you may want to select a larger group of cells, or a cell range. 

 

Click, hold, and drag the mouse until all of the adjoining cells you wish to select are highlighted. 

Release the mouse to select the desired cell range. The cells will remain selected until you click another cell in 

the worksheet. 

Cell Content 

 

Any information you enter into a spreadsheet will be stored in a cell. Each cell can contain several different 

kinds of content, including text, formatting, formulas, and functions. 

 

Text 

Cells can contain text, such as letters, numbers, and dates. 

 



 

 

 

Unit-III 

 

Formatting Attributes 

Cells can contain formatting attributes that change the way letters, numbers, and dates are displayed. For 

example, percentages can appear as 0.15 or 15%. You can even change a cell's background color. 

 

Formulas and Functions 

Cells can contain formulas and functions that calculate cell values. In our example, SUM(B4:B7) adds the value 

of each cell in cell range B4:B7 and displays the total in cell B8. 

 

 

To insert content  

Click a cell to select it. 

 

Type content into the selected cell, then press Enter on your keyboard. The content will appear in the cell and 

the formula bar. You can also input and edit cell content in the formula bar. 

 

 

 
 
 
 

Content appears in cell 

and formula bar 



 

 

 

 

To delete cell content  

Select the cell with content you wish to delete. 

Press the Delete or Backspace key on your keyboard. The cell's contents will be deleted. 

To delete cells  

There is an important difference between deleting the content of a cell and deleting the cell itself. If you delete 

the entire cell, the cells below it will shift up and replace the deleted cells. 

Select the cell(s) you wish to delete. 

Select the Delete command from the Home tab on the Ribbon. 

The cells below will shift up. 

 

 

 

 

To copy and paste cell content  

Excel allows you to copy content that is already entered into your spreadsheet and paste that content to other 

cells, which can save you time and effort. 

Select the cell(s) you wish to copy. 

Click the Copy command on the Home tab, or press Ctrl+C on your keyboard. 



 

 

 

 

 
 

 

Select the cell(s) where you wish to paste the content. The copied cells will now have a dashed box around 

them. 

Click the Paste command on the Home tab, or press Ctrl+V on your keyboard. 

The content will be pasted into the selected cells. 

 

 

To access more paste options  

You can also access additional paste options, which are especially convenient when working with cells that 

contain formulas or formatting. 

 To access more paste options, click the drop-down arrow on the Paste command. 

 



 

 

 

 

 TIP: Rather than choosing commands from the Ribbon, you can access commands quickly by right- clicking. 

Simply select the cell(s) you wish to format, then right-click the mouse. A drop-down menu will appear, where 

you'll find several commands that are also located on the Ribbon. 

 

 

To drag and drop cells  

Rather than cutting, copying, and pasting, you can drag and drop cells to move their contents. 

Select the cell(s) you wish to move. 

Hover the mouse over the border of the selected cell(s) until the cursor changes from a white cross to a black 

cross with four arrows. 

Click, hold, and drag the cells to the desired location. 

Release the mouse, and the cells will be dropped in the selected location. 

 

 

To use the fill handle  

There may be times when you need to copy the content of one cell to several other cells in your worksheet. You 

could copy and paste the content into each cell, but this method would be very time consuming. Instead, you can 

use the fill handle to quickly copy and paste content to adjacent cells in the same row or column. 

Select the cell(s) containing the content you wish to use. The fill handle will appear as a small square in the 

bottom-right corner of the selected cell(s). 



 

 

 

 

 
Click, hold, and drag the fill handle until all of the cells you wish to fill are selected. 

 

 

 

 

Release the mouse to fill the selected cells. 

 

To continue a series with the fill handle  

The fill handle can also be used to continue a series. Whenever the content of a row or column follows a 

sequential order, like numbers (1, 2, 3) or days (Monday, Tuesday, Wednesday), the fill handle can guess what 

should come next in the series. In many cases, you may need to select multiple cells before using the fill handle 

to help Excel determine the series order. In our example below, the fill handle is used to extend a series of dates 

in a column. 

The fill handle 



 

 

 

 

 

 

  
 

 

 

 

Find and Replace 

 

When working with a lot of data in Excel, it can be difficult and time consuming to locate specific information. 

You can easily search your workbook using the Find feature, which also allows you to modify content using the 

Replace feature. 

To find content  

From the Home tab, click the Find and Select command, then select Find... from the drop-down menu. 

 

 

 

 

 

 

 

 

 

 

The Find and Replace dialog box will appear. Enter the content you wish to find. 

Click Find Next. If the content is found, the cell containing that content will be selected. 



 

 

 

 

 
 

 

 

Click Find Next to find further instances or Find All to see every instance of the search term. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 TIP: You can also access the Find command by pressing Ctrl+F on your keyboard. 

 TIP: Click Options to see advanced search criteria in the Find and Replace dialog box. 

 

 

 

 

To replace cell content  

At times, you may discover that you've repeatedly made a mistake throughout your workbook (such as 

misspelling someone's name), or that you need to exchange a particular word or phrase for another. You can use 

Excel's Find and Replace feature to make quick revisions. 



 

 

 

 

From the Home tab, click the Find and Select command, then select Replace... from the drop- down menu. 

The Find and Replace dialog box will appear. Type the text you wish to find in the Find what: field. 

Type the text you wish to replace it with in the Replace with: field, then click Find Next. 

If the content is found, the cell containing that content will be selected. 

Review the text to make sure you want to replace it. 

If you wish to replace it, select one of the replace options: 

Replace will replace individual instances. 

Replace All will replace every instance of the text throughout the workbook. In our example, we'll choose this 

option to save time. 

A dialog box will appear, confirming the number of replacements made. Click OK to continue. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 

Formatting Cells 

 

All cell content uses the same formatting by default, which can make it difficult to read a workbook with a lot of 

information. Basic formatting can customize the look and feel of your workbook, allowing you to draw attention 

to specific sections and making your content easier to view and understand. You can also apply number 

formatting to tell Excel exactly what type of data you’re using in the workbook, such as percentages (%), 

currency ($), and so on. 



 

 

 

 

Font Formatting 

 

To change the font  

By default, the font of each new workbook is set to Calibri. However, Excel provides a variety of other fonts 

you can use to customize your cell text. In the example below, we'll format our title cell to help distinguish it 

from the rest of the worksheet. 

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font command on the Home tab. The Font drop-down menu will appear. 

Select the desired font. A live preview of the new font will appear as you hover the mouse over different 

options. 

 

 

 

The text will change to the selected font. 

 

 TIP: When creating a workbook in the workplace, you'll want to select a font that is easy to read. 

Along with Calibri, standard reading fonts include Cambria, Times New Roman, and Arial. 

To change the font size  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Size command on the Home tab. The Font Size drop- down menu 

will appear. 

Select the desired font size. A live preview of the new font size will appear as you hover the mouse over 

different options. 

The text will change to the selected font size. 

 TIP: You can also use the Increase Font Size and Decrease Font Size commands or enter a custom font size 

using your keyboard. 



 

 

 

 
 

To change the font color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Color command on the Home tab. The Color menu will appear. 

Select the desired font color. A live preview of the new font color will appear as you hover the mouse over 

different options. 

 

 

The text will change to the selected font color. 

 

 

To use the Bold, Italic, and Underline commands  

Select the cell(s) you wish to modify. 

Click the Bold (B), Italic (I), or Underline (U) command on the Home tab. In our example, we'll make the 

selected cells bold. 

Entering a custom 

font size 
Increase and 

Decrease Font 

Size commands 



 

 

 

 

 
 

 

The selected style will be applied to the text. 

 TIP: You can also press Ctrl+B on your keyboard to make selected text bold, Ctrl+I to apply italics, and 

Ctrl+U to apply an underline. 

 

Text Alignment 

 

By default, any text entered into your worksheet will be aligned to the bottom-left of a cell. Any numbers will 

be aligned to the bottom-right of a cell. Changing the alignment of your cell content allows you to choose how 

the content is displayed in any cell, which can make your cell content easier to read. 

To change horizontal text alignment  

Select the cell(s) you wish to modify. 

Select one of the three horizontal alignment commands on the Home tab. In our example, we'll choose Center 

Align. 

 

The text will realign. 

To change vertical text alignment  

Select the cell(s) you wish to modify. 

Select one of the three vertical alignment commands on the Home tab. In our example, we'll choose Middle 

Align. 



 

 

 

 

 
 

The text will realign. 

 

 

Cell borders and fill colors 

 

Cell borders and fill colors allow you to create clear and defined boundaries for different sections of your 

worksheet. 

To add a border  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Borders command on the Home tab. The Borders drop- down menu will 

appear. 

 

 

Select the border style you want to use. 

The selected border style will appear. 

 TIP: You can draw borders and change the line style and color of borders with the Draw Borders tools at the 

bottom of the Borders drop-down menu. 



 

 

 

 

 
 

 

To add a fill color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Fill Color command on the Home tab. The Fill Color menu will appear. 

Select the fill color you want to use. A live preview of the new fill color will appear as you hover the mouse 

over different options. In our example, we'll choose Light Green. 

 

 

The selected fill color will appear in the selected cells. 



 

 

 

 

Cell styles 

 

Rather than formatting cells manually, you can use Excel's predesigned cell styles. Cell styles are a quick way to 

include professional formatting for different parts of your workbook, such as titles and headers. 

To apply a cell style  

Select the cell(s) you wish to modify. 

Click the Cell Styles command on the Home tab, then choose the desired style from the drop-down menu. 

 

 

The selected cell style will appear. 

 TIP: Applying a cell style will replace any existing cell formatting except for text alignment. You may not 

want to use cell styles if you've already added a lot of formatting to your workbook. 

 

Formatting text and numbers 

 

One of the most powerful tools in Excel is the ability to apply specific formatting for text and numbers. Instead 

of displaying all cell content in exactly the same way, you can use formatting to change the appearance of dates, 

times, decimals, percentages (%), currency ($), and much more. 

To apply number formatting  

Select the cells(s) you wish to modify. 

Click the drop-down arrow next to the Number Format command on the Home tab. The Number Formatting 

drop-down menu will appear. 

Select the desired formatting option. 

The selected cells will change to the new formatting style. 



 

 

 

General is the default format for any cell. 
When you enter a number into the cell, 

Excel will guess the number format that is 

most appropriate. 
Number formats numbers 
with decimal places. 

Currency formats numbers as currency 
with a currency symbol. 

Short Date formats numbers 
as M/D/YYYY. 

Accounting formats numbers as monetary 
values like the Currency format, but it also 

aligns currency symbols and decimal 

places within columns. 

Long Date formats numbers as 
Weekday, Month DD, YYYY. 

Time formats numbers as HH/MM/SS 
and notes AM or PM. 

Percentage formats numbers with 
decimal places and the percent sign. 

Fraction formats numbers as fractions 
separated by the forward slash. 

Scientific formats numbers 
in scientific notation. 

Text formats numbers as text, meaning 
that what you enter into the cell will 

appear exactly as it was entered. 

You can easily customize any format in 
More Number Formats. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Challenge! 

Open an existing Excel 2013 workbook. 

Select a cell and change the font style, size, and color of the text. 

Apply bold, italics, or underline to a cell. 

Try changing the vertical and horizontal text alignment for some cells. 

Add a border to a cell range. 

Change the fill color of a cell range. 

Try changing the formatting of a number. 



 

 

 

 

Modifying Columns, Rows and Cells 

 

By default, every row and column of a new workbook is always set to the same height and width. Excel allows 

you to modify column width and row height in different ways, including wrapping text and merging cells. 

 

 

To modify column width  

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

 

Click, hold, and drag the mouse to increase or decrease the column width. 

Release the mouse. The column width will be changed. 

 TIP: If you see pound signs (#######) in a cell, it means that the column is not wide enough to display the 

cell content. Simply increase the column width to show the cell content. 

 

 

To AutoFit column width  

The AutoFit feature will allow you to set a column's width to fit its content automatically. 

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

Double-click the mouse. The column width will be changed automatically to fit the content. 

 TIP: You can also AutoFit the width for several columns at the same time. Simply select the columns you 

would like to AutoFit, then select the AutoFit Column Width command from the Format drop- down menu on 

the Home tab. This method can also be used for Row height. 



 

 

 

 

 

 
To modify row height  

Position the cursor over the row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse. The height of the selected row will be changed. 

 

 

To modify all rows or columns  

Rather than resizing rows and columns individually, you can modify the height and width of every row and 

column at the same time. This method allows you to set a uniform size for every row and column in your 

worksheet. 

Locate and click the Select All button just below the formula bar to select every cell in the worksheet. 

 

 

 

 

 

 

 

 

 

 

Position the mouse over a row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse when you are satisfied with the new row height for the worksheet. 



 

 

 

 

Inserting, deleting, moving, and hiding rows and columns 

 

After you've been working with a workbook for a while, you may find that you want to insert new columns or 

rows, delete certain rows or columns, move them to a different location in the worksheet, or even hide them. 

To insert rows  

Select the row heading below where you want the new row to appear. 

Click the Insert command on the Home tab. 

 

The new row will appear above the selected row. 

 

 TIP: When inserting new rows, columns, or cells, you will see the Insert Options button next to the 

inserted cells. This button allows you to choose how Excel formats these cells. By default, Excel formats 

inserted rows with the same formatting as the cells in the row above. To access more options, hover your mouse 

over the Insert Options button, then click the drop-down arrow. 

 

 



 

 

 

 

To insert columns  

Select the column heading to the right of where you want the new column to appear. 

Click the Insert command on the Home tab. 

 

The new column will appear to the left of the selected column. 

 

 TIP: When inserting rows and columns, make sure you select the entire row or column by clicking the 

heading. If you select only a cell in the row or column, the Insert command will only insert a new cell. 

 

To delete rows  

It's easy to delete any row that you no longer need in your workbook. 

Select the row(s) you want to delete. 

Click the Delete command on the Home tab. 

 



 

 

 

 

The selected row(s) will be deleted, and the rows below will shift up. 

To delete columns  

Select the columns(s) you want to delete. 

Click the Delete command on the Home tab. 

 

 

 

 

 

 

 

The selected columns(s) will be deleted, and the columns to the right will shift left. 

 TIP: It's important to understand the difference between deleting a row or column and simply clearing its 

contents. If you want to remove the content of a row or column without causing others to shift, right-click a 

heading, then select Clear Contents from the drop-down menu. 

 

 



 

 

 

 

To move a row or column  

Sometimes you may want to move a column or row to rearrange the content of your worksheet. 

Select the desired column heading for the column you wish to move, then click the Cut command on the Home 

tab or press Ctrl+X on your keyboard. 

Select the column heading to the right of where you want to move the column. For example, if you want to 

move a column between columns B and C, select column C. 

Click the Insert command on the Home tab, then select Insert Cut Cells from the drop-down menu. 

 

The column will be moved to the selected location, and the columns to the right will shift right. 

 

 TIP: You can also access the Cut and Insert commands by right-clicking the mouse and then selecting the 

desired commands from the drop-down menu. 

 

 

To hide and unhide a row or column  

At times, you may want to compare certain rows or columns without changing the organization of your 

worksheet. Excel allows you to hide rows and columns as needed. 

Select the column(s) you wish to hide, right-click the mouse, then select Hide from the formatting menu. 



 

 

 

 

The columns will be hidden. The green column line indicates the location of the hidden columns. 

 

 

 

 

To unhide the columns, select the columns to the left and right of the hidden columns (in other words, the 

columns on both sides of the hidden columns). 

Right-click the mouse, then select Unhide from the formatting menu. The hidden columns will reappear. 

 

 

Wrapping text and merging cells 

 

Whenever you have too much cell content to be displayed in a single cell, you may decide to wrap the text or 

merge the cell rather than resizing a column. Wrapping the text will automatically modify a cell's row height, 

allowing cell contents to be displayed on multiple lines. Merging allows you to combine a cell with adjacent, 

empty cells to create one large cell. 

Select the cells you wish to wrap. 

Select the Wrap Text command on the Home tab. 

 

Green 

column line 



 

 

 

 

The text in the selected cells will be wrapped. 

 TIP: Click the Wrap Text command again to unwrap the text. 

 

 

To merge cells using the Merge & Center command  

Select the cell range you want to merge together. 

Select the Merge & Center command on the Home tab. 

 

 

 

The selected cells will be merged, and the text will be centered. 

To access more merge options  

Click the drop-down arrow next to the Merge & Center command on the Home tab. The Merge drop-down 

menu will appear. From here, you can choose to: 

Merge & Center: Merges the selected cells into one cell and centers the text 

Merge Across: Merges the selected cells into larger cells while keeping each row separate 

Merge Cells: Merges the selected cells into one cell, but does not center the text 

Unmerge Cells: Unmerges selected cells 

 



 

 

 

 

 

Formulas and Functions 

 

One of the most powerful features in Excel is the ability to calculate numerical information using formulas. 

 

 

Simple Formulas 

 

Just like a calculator, Excel can add, subtract, multiply, and divide. In this lesson, we'll show you how to use 

cell references to create simple formulas. 

Mathematical operators  

Excel uses standard operators for formulas, such as a plus sign for addition (+), a minus sign for subtraction (-), 

an asterisk for multiplication (*), a forward slash for division (/), and a caret (^) for exponents. 

 

 

 

All formulas in Excel must begin with an equals sign (=). This is because the cell contains, or is equal to, the 

formula and the value it calculates. 



 

 

 

 

Understanding cell references  

While you can create simple formulas in Excel manually (for example, =2+2 or =5*5), most of the time you will 

use cell addresses to create a formula. This is known as making a cell reference. Using cell references will 

ensure that your formulas are always accurate because you can change the value of referenced cells without 

having to rewrite the formula. 

 

 

 

By combining a mathematical operator with cell references, you can create a variety of simple formulas in 

Excel. Formulas can also include a combination of cell references and numbers, as in the examples below: 

 

  

 
 
 

 
The formula in cell A3 

refers to the value in cell A1 

plus the value in cell A2 

 

The formula calculates 

and displays the answer  

to the equation A1 plus A2 



 

 

 

 

To create a formula  

Select the cell that will contain the formula. 

Type the equals sign (=). Notice how it appears in both the cell and the formula bar. 

 

 

 

 

Type the cell address of the cell you wish to reference first in the formula: cell D1 in our example. A blue 

border will appear around the referenced cell. 

Type the mathematical operator you wish to use. In our example, we'll type the addition sign (+). 

Type the cell address of the cell you wish to reference second in the formula: cell D2 in our example. A red 

border will appear around the referenced cell. 

 

 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell.  

 TIP: If the result of a formula is too  large to  be displayed  in  a  cell, it may appear as  pound  signs 

(#######) instead of a value. This means that the column is not wide enough to display the cell content. Simply 

increase the column width to show the cell content. 

 

 

Modifying values with cell references  

The true advantage of cell references is that they allow you to update data in your worksheet without having to 

rewrite formulas. 

 TIP: Excel will not always tell you if your formula contains an error, so it's up to you to check all of your 

formulas. 

 
 
 

 
Formula will appear in 

both the cell and the 

formula bar. 



 

 

 

 

To create a formula using the point-and-click method  

Rather than typing cell addresses manually, you can point and click on the cells you wish to include in your 

formula. This method can save a lot of time and effort when creating formulas. In our example below, we'll 

create a formula to calculate the cost of ordering several boxes of plastic silverware. 

Select the cell that will contain the formula. In our example, we'll select cell D3. 

 

 

 

Type the equals sign (=). 

Select the cell you wish to reference first in the formula: cell B3 in our example. The cell address will appear in 

the formula, and a dashed blue line will appear around the referenced cell. 

 

 

 

Type the mathematical operator you wish to use. In our example, we'll type the multiplication sign (*). 

Select the cell you wish to reference second in the formula: cell C3 in our example. The cell address will appear 

in the formula, and a dashed red line will appear around the referenced cell. 



 

 

 

 

 
 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell. 

 

 

 

Formulas can also be copied to adjacent cells with the fill handle, which can save a lot of time and effort if you 

need to perform the same calculation multiple times in a worksheet. 

To edit a formula  

Sometimes you may want to modify an existing formula. In the example below, we've entered an incorrect cell 

address in our formula, so we'll need to correct it. 

Select the cell containing the formula you wish to edit. 

Click the formula bar to edit the formula. You can also double-click the cell to view and edit the formula 

directly within the cell. 

A border will appear around any referenced cells. 

 

When finished, press Enter on your keyboard or select the Enter command in the formula bar. 

The formula will be updated, and the new value will be displayed in the cell. 

 TIP: If you change your mind, you can press the Esc key on your keyboard or click the Cancel command

 in the formula bar to avoid accidentally making changes to your formula. 



 

 

 

 

 TIP: To show all of the formulas in a spreadsheet, you can hold the Ctrl key and press ` (grave accent). The 

grave accent key is usually located in the upper-left corner of the keyboard. You can press Ctrl+` again to 

switch back to the normal view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

Unit-IV 

 

Complex Formulas 

 

A simple formula is a mathematical expression with one operator, such as 7+9. A complex formula has more 

than one mathematical operator, such as 5+2*8. When there is more than one operation in a formula, the order 

of operations tells Excel which operation to calculate first. In order to use Excel to calculate complex formulas, 

you will need to understand the order of operations. 

Order of operations  

Excel calculates formulas based on the following order of operations: 

Operations enclosed in parentheses 

Exponential calculations (3^2, for example) 

Multiplication and division, whichever comes first 

Addition and subtraction, whichever comes first 

 

 

Creating complex formulas  

In the example below, we will demonstrate how Excel solves a complex formula using the order of operations. 

Here, we want to calculate the cost of sales tax for an invoice. To do this, we'll write our formula as 

=(D2+D3)*0.075 in cell D4. This formula will add the prices of our items together and then multiply that value 

by the 7.5% tax rate (which is written as 0.075) to calculate the cost of sales tax. 



 

 

 

 

 
 

 

 TIP: It is especially important to enter complex formulas with the correct order of operations. Otherwise, 

Excel will not calculate the results accurately. In our example, if the parentheses are not included, the 

multiplication is calculated first and the result is incorrect. Parentheses are the best way to define which 

calculations will be performed first in Excel. 

 

 

Relative and Absolute Cell References 

 

There are two types of cell references: relative and absolute. Relative and absolute references behave differently 

when copied and filled to other cells. Relative references change when a formula is copied to another cell. 

Absolute references, on the other hand, remain constant, no matter where they are copied. 

 

 

Relative cell references 

 

By default, all cell references are relative references. When copied across multiple cells, they change based on 

the relative position of rows and columns. For example, if you copy the formula =A1+B1 from row 1 to row 2, 

the formula will become =A2+B2. Relative references are especially convenient whenever you need to repeat 

the same calculation across multiple rows or columns. 

 

 

To create and copy a formula using relative references  

In the following example, we want to create a formula that will multiply each item's price by the quantity. 

Rather than creating a new formula for each row, we can create a single formula in cell D2 and then copy 



 

 

 

 

it to the other rows. We'll use relative references so the formula correctly calculates the total for each item. 

Select the cell that will contain the formula. In our example, we'll select cell D2. 

Enter the formula to calculate the desired value. In our example, we'll type =B2*C2. 

 

 

 

 

 

Press Enter on your keyboard. The formula will be calculated, and the result will be displayed in the cell.  

Locate the fill handle in the lower-right corner of the desired cell. In our example, we'll locate the fill handle for 

cell D2. 

 

 

 

 

The fill handle 



 

 

 

 

 

 

Click, hold, and drag the fill handle over the cells you wish to fill. 

 

 

 

 

 

Release the mouse. The formula will be copied to the selected cells with relative references, and the values will 

be calculated in each cell. 

 

 

 TIP: You can double-click the filled cells to check their formulas for accuracy. The relative cell references 

should be different for each cell, depending on their rows. 

 

 

 

Click, hold and drag the fill handle to 

copy the formula to adjacent cells 



 

 

 

 

Absolute cell references 

 

There may be times when you do not want a cell reference to change when filling cells. Unlike relative 

references, absolute references do not change when copied or filled. You can use an absolute reference to keep a 

row and/or column constant. 

An absolute reference is designated in a formula by the addition of a dollar sign ($). It can precede the column 

reference, the row reference, or both. 

 

You will generally use the $A$2 format when creating formulas that contain absolute references. The other two 

formats are used much less frequently. 

 TIP: When writing a formula, you can press the F4 key on your keyboard to switch between relative and 

absolute cell references. This is an easy way to quickly insert an absolute reference. 

 

 

To create and copy a formula using absolute references  

In our example, we'll use the 7.5% sales tax rate in cell E1 to calculate the sales tax for all items in column 

D. We'll need to use the absolute cell reference $E$1 in our formula. Since each formula is using the same tax 

rate, we want that reference to remain constant when the formula is copied and filled to other cells in column D. 

Select the cell that will contain the formula. In our example, we'll select cell D3. 

Enter the formula to calculate the desired value. In our example, we'll type =(B3*C3)*$E$1. 

Press Enter on your keyboard. The formula will calculate, and the result will display in the cell.  



 

 

 

 

 

 
 

 

Locate the fill handle in the lower-right corner of the desired cell. 

Release the mouse. The formula will be copied to the selected cells with an absolute reference, and the values 

will be calculated in each cell. 

Challenge! 

Open an existing Excel workbook. 

Create a formula that uses a relative reference. Double-click a cell to see the copied formula and the relative cell 

references. 

Create a formula that uses an absolute reference. 

 

Functions 

 

A function is a predefined formula that performs calculations using specific values in a particular order. Excel 

includes many common functions that can be useful for quickly finding the sum, average, count, maximum 

value, and minimum value for a range of cells. In order to use functions correctly, you'll need to understand the 

different parts of a function and how to create arguments to calculate values and cell references. 

 

 

 

 

The parts of a function  

Formula =A1+A2+A3+A4+A5+A6+A7+A8 

Function =SUM(A1:A8) 

 

In order to work correctly, a function must be written a specific way, which is called the syntax. The basic 

syntax for a function is an equals sign (=), the function name (SUM, for example), and one or more arguments. 

Arguments contain the information you want to calculate. 



 

 

 

 

 

 

 
 

Working with arguments  

Arguments can refer to both individual cells and cell ranges and must be enclosed within parentheses. You can 

include one argument or multiple arguments, depending on the syntax required for the function. 

 

 

For example, the function =AVERAGE(B1:B9) would calculate the average of the values in the cell range 

B1:B9. This function contains only one argument. 

 

 

Multiple arguments must be separated by a comma. For example, the function =SUM(A1:A3, C1:C2, E2) will 

add the values of all the cells in the three arguments. 

=SUM(A1:A20) 

Equal sign Argument 

Function name 



 

 

 

 

 

 
 

Creating a function 

 

Excel has a variety of functions available. Here are some of the most common functions you'll use: 

SUM: This function adds all of the values of the cells in the argument. 

AVERAGE: This function determines the average of the values included in the argument. It calculates the sum 

of the cells and then divides that value by the number of cells in the argument. 

COUNT: This function counts the number of cells with numerical data in the argument. This function is useful 

for quickly counting items in a cell range. 

MAX: This function determines the highest cell value included in the argument. 

MIN: This function determines the lowest cell value included in the argument. 

 

 

To create a basic function  

In our example below, we'll create a basic function to calculate the average price per unit for a list of recently 

ordered items using the AVERAGE function. 

Select the cell that will contain the function. 

Type the equals sign (=) and enter the desired function name. You can also select the desired function from the 

list of suggested functions that will appear below the cell as you type. In our example, we'll type =AVERAGE. 



 

 

 

 

 
 

Enter the cell range for the argument inside parentheses. In our example, we'll type (D3:D12). 

Press Enter on your keyboard. The function will be calculated, and the result will appear in the cell.  

 

 

To create a function using the AutoSum command  

The AutoSum command allows you to automatically insert the most common functions into your formula, 

including SUM, AVERAGE, COUNT, MIN, and MAX. In our example below, we'll create a function to 

calculate the total cost for a list of recently ordered items using the SUM function. 

Select the cell that will contain the function. 

In the Editing group on the Home tab, locate and select the arrow next to the AutoSum command and then 

choose the desired function from the drop-down menu. In our example, we'll select Sum. 

 



 

 

 

 

The selected function will appear in the cell. If logically placed, the AutoSum command will automatically 

select a cell range for the argument. You can also manually enter the desired cell range into the argument. 

 

 

Press Enter on your keyboard. 

 

 

The Function Library 

 

While there are hundreds of functions in Excel, the ones you use most frequently will depend on the type of data 

your workbooks contains. There is no need to learn every single function, but exploring some of the different 

types of functions will be helpful as you create new projects. You can search for functions by category, such as 

Financial, Logical, Text, Date & Time, and more from the Function Library on the Formulas tab. 

 To access the Function Library, select the Formulas tab on the Ribbon. The Function Library will appear. 

 

 



 

 

 

 

 
 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. 

The AutoSum command allows you to automatically return results for common functions, like SUM, 

AVERAGE, and COUNT. 

The Recently Used command gives you access to functions that you have recently worked with. 

The Financial category contains functions for financial calculations like determining a payment (PMT) or 

interest rate for a loan (RATE). 

Functions in the Logical category check arguments for a value or condition. For example, if an order is over 

$50 add $4.99 for shipping, but if it is over $100, do not charge for shipping (IF). 

The Text category contains functions that work with the text in arguments to perform tasks, such as converting 

text to lowercase (LOWER) or replacing text (REPLACE). 

The Date & Time category contains functions for working with dates and time and will return results like the 

current date and time (NOW) or the seconds (SECOND). 

The Lookup & Reference category contains functions that will return results for finding and referencing 

information. For example, you can add a hyperlink (HYPERLINK) to a cell or return the value of a particular 

row and column intersection (INDEX). 

The Math & Trig category includes functions for numerical arguments. For example, you can round values 

(ROUND), find the value of Pi (PI) multiply (PRODUCT), subtotal (SUBTOTAL), and much more. 

More Functions contains additional functions under categories for Statistical, Engineering, Cube, Information, 

and Compatibility. 

 

To insert a function from the Function Library  

 

Select the cell that will contain the function. 

 

Click the Formulas tab on the Ribbon to access the Function Library. 

 

From the Function Library group, select the desired function category. 

 

Select the desired function from the drop-down menu. 



 

 

 

 

 
 

 

 

The Function Arguments dialog box will appear. From here, you'll be able to enter or select the cells that will 

make up the arguments in the function. 

 

 

 

When you're satisfied with the arguments, click OK. 

 

The function will be calculated, and the result will appear in the cell. 



 

 

 

 

Like formulas, functions can be copied to adjacent cells. Hover the mouse over the cell that contains the 

function, then click, hold, and drag the fill handle over the cells you wish to fill. The function will be copied, 

and values for those cells will be calculated relative to their rows or columns. 

 

 

 

 

 

 

The Insert Function command 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. While it can be extremely useful, this command is sometimes a little difficult to use. 

If you don't have much experience with functions, you may have more success browsing the Function Library 

instead. For more advanced users, however, the Insert Function command can be a powerful way to find a 

function quickly. 

 

 

To use the Insert Function command  

Select the cell that will contain the function. 

Click the Formulas tab on the Ribbon, then select the Insert Function command. 

The Insert Function dialog box will appear. 

Type a few keywords describing the calculation you want the function to perform, then click Go. 

Review the results to find the desired function, then click OK. 



 

 

 

 

 
 

 

The Function Arguments dialog box will appear. 

When you're satisfied, click OK. 

The function will be calculated, and the result will appear in the cell. 

 

 



 

 

 

Unit-V 

 

 

SUM 

Formula: =SUM(5, 5) or =SUM(A1, B1) or =SUM(A1:B5) 

The SUM formula does exactly what you would expect. It allows you to add 2 or more numbers together. You 

can use cell references as well in this formula. 

 

 

COUNT 

Formula: =COUNT(A1:A10) 

The count formula counts the number of cells in a range that have numbers in them. 

 

 

It only counts the cells where there are numbers. 

 

 

COUNTA 

Formula: =COUNTA(A1:A10) 

Counts the number of non-empty cells in a range. It will count cells that have numbers and/or any other 

characters in them. 

The COUNTA Formula works with all data types. 



 

 

 

 

 
 

 

It counts the number of non-empty cells no matter the data type. 

LEN 

Formula: =LEN(A1) 

The LEN formula counts the number of characters in a cell. This includes spaces! 

 

Notice the difference in the formula results: 10 characters without spaces in between the words, 12 with spaces 

between the words. 

VLOOKUP 

Formula: =VLOOKUP(lookup_value, table_array, col_index_num, range_lookup) 

Basically, VLOOKUP lets you search for specific information in your spreadsheet. For example, if you have a 

list of products with prices, you could search for the price of a specific item. 

We’re going to use VLOOKUP to find the price of the Photo frame. You can probably already see that the price 

is $9.99, but that’s because this is a simple example. Once you learn how to use VLOOKUP, you’ll be able to 

use it with larger, more complex spreadsheets, and that’s when it will become truly useful.  



 

 

 

 

 
 

As with any formula, you’ll start with an equal sign (=). Then, type the formula name. 

=VLOOKUP(“Photo frame” 

The second argument is the cell range that contains the data. In this example, our data is in A2:B16. As with any 

function, you’ll need to use a comma to separate each argument: 

=VLOOKUP(“Photo frame”, A2:B16 

Note: It’s important to know that VLOOKUP will always search the first column in this range. In this example, 

it will search column A for “Photo frame”. In some cases, you may need to move the columns around so that the 

first column contains the correct data. 

The third argument is the column index number. It’s simpler than it sounds: The first column in the range is 1, 

the second column is 2, etc. In this case, we are trying to find the price of the item, and the prices are contained 

in the second column. That means our third argument will be 2: 

=VLOOKUP(“Photo frame”, A2:B16, 2 

The fourth argument tells VLOOKUP whether to look for approximate matches, and it can be either TRUE or 

FALSE. If it is TRUE, it will look for approximate matches. Generally, this is only useful if the first column has 

numerical values that have been sorted. Since we’re only looking for exact matches, the fourth argument should 

be FALSE. This is our last argument, so go ahead and close the parentheses: 

=VLOOKUP(“Photo frame”, A2:B16, 2, FALSE) 

And that’s it! When you press enter, it should give you the answer, which is 9.99. 



 

 

 

 

 
 

 

IF Statements 

Formula: =IF(logical_statement, return this if logical statement is true, return this if logical statement is false). 

Example 

Let’s say a salesperson has a quota to meet. You used VLOOKUP to put the revenue next to the name. Now you 

can use an IF statement that says: “IF the salesperson met their quota, say “Met quota”, if not say “Did not meet 

quota” 

=IF(C3>D3, “Met Quota”, “Did Not Meet Quota”) 

This IF statement will tell us if the first salesperson met their quota or not. We would then copy and paste this 

formula along all the entries in the list. It would change for each sales person. 

 

 



 

 

 

 

Working with Data 

 

Whenever you're working with a lot of data, it can be difficult to compare information in your workbook. 

Freezing Panes and View Options 

 

Excel includes several tools that make it easier to view content from different parts of your workbook at the 

same time, such as the ability to freeze panes and split your worksheet. 

To freeze rows  

You may want to see certain rows or columns all the time in your worksheet, especially header cells. By 

freezing rows or columns in place, you'll be able to scroll through your content while continuing to view the 

frozen cells. 

Select the row below the row(s) you wish to freeze. 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

 

 

 

The rows will be frozen in place, as indicated by the gray line. You can scroll down the worksheet while 

continuing to view the frozen rows at the top. 

To freeze columns  

Select the column to the right of the column(s) you wish to freeze. 



 

 

 

 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

The column will be frozen in place, as indicated by the gray line. You can scroll across the worksheet while 

continuing to view the frozen column on the left. 

To unfreeze rows or columns, click the Freeze Panes command, then select Unfreeze Panes from the drop-down 

menu. 

 

 

To split a worksheet  

Sometimes you may want to compare different sections of the same workbook without creating a new window. 

The Split command allows you to divide the worksheet into multiple panes that scroll separately. 

Select the cell where you wish to split the worksheet. 

Click the View tab on the Ribbon, then select the Split command. 

 

The workbook will be split into different panes. You can scroll through each pane separately using the scroll 

bars, allowing you to compare different sections of the workbook. 

To remove the split, click the Split command again. 

 

 

. 

 

Sorting Data 

 

As you add more content to a worksheet, organizing that information becomes especially important. You can 

quickly reorganize a worksheet by sorting your data. For example, you could organize a list of contact 

information by last name. Content can be sorted alphabetically, numerically, and in many other ways. 



 

 

 

 

When sorting data, it's important to first decide if you would like the sort to apply to the entire worksheet or just 

a cell range. 

Sort sheet organizes all of the data in your worksheet by one column. 

Sort range sorts the data in a range of cells, which can be helpful when working with a sheet that contains 

several tables. Sorting a range will not affect other content on the worksheet. 

 

To sort a sheet  

In our example, we'll sort a T-shirt order form alphabetically by Last Name (column C). 

Select a cell in the column you wish to sort by. In our example, we'll select cell C2. 

 

 

 

Select the Data tab on the Ribbon, then click the Ascending command  to Sort A to Z, or the Descending 

command  to Sort Z to A. In our example, we'll click the Ascending command. 

 

 

The worksheet will be sorted by the selected column. In our example, the worksheet is now sorted by last name. 



 

 

 

 

 
 

 

Filtering Data 

 

If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters can be used to 

narrow down the data in your worksheet, allowing you to view only the information you need. 

To filter data  

In order for filtering to work correctly, your worksheet should include a header row, which is used to identify 

the name of each column. 

Select the Data tab, then click the Filter command. 

 

 

A drop-down arrow will appear in the header cell for each column. 

Click the drop-down arrow for the column you wish to filter. 



 

 

 

 

The Filter menu will appear. 

Uncheck the box next to Select All to quickly deselect all data. 

Check the boxes next to the data you wish to filter, then click OK. 

To remove all filters from your worksheet, click the Filter command on the Data tab. 

 

 

Working with Charts 

 

Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart types that you can 

choose from when you create a chart. Excel offers Pie, Line, Bar, and Column charts to name but a few. 

Showing data in a chart can make it clearer, more interesting and easier to read. Charts can also help you 

evaluate your data and make comparisons between different values. 

 

 

Understanding charts 

 

Excel has several different types of charts, allowing you to choose the one that best fits your data. In order to 

use charts effectively, you'll need to understand how different charts are used. 

Types of Charts: 

Column charts use vertical bars to represent data. They can work with many different types of data, but they're 

most frequently used for comparing information. 

Line charts are ideal for showing trends. The data points are connected with lines, making it easy to see whether 

values are increasing or decreasing over time. 

Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so it's easy to see 

which values make up the percentage of a whole. 

Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars. 

Area charts are similar to line charts, except that the areas under the lines are filled in. 

Surface charts allow you to display data across a 3D landscape. They work best with large data sets, allowing 

you to see a variety of information at the same time. 

 

 

To insert a chart  

  

Select the cells you want to chart, including the column titles and row labels. These cells will be the source data 

for the chart. 



 

 

 

 

From the Insert tab, click the desired Chart command. 

Choose the desired chart type from the drop-down menu. 

 

 

 

 

The selected chart will be inserted in the worksheet. 

 TIP: If you're not sure which type of chart to use, the Recommended Charts command will suggest several 

different charts based on the source data. 

 

 

 

Chart layout and style 

 

After inserting a chart, there are several things you may want to change about the way your data is displayed. 

It's easy to edit a chart's layout and style from the Design tab. 

Excel allows you to add chart elements—such as chart titles, legends, and data labels—to make your chart 

easier to read. To add a chart element, click the Add Chart Element command on the Design tab, then choose 

the desired element from the drop-down menu. 



 

 

 

 

 
 

 

To edit a chart element, like a chart title, simply double-click the placeholder and begin typing. 

 

 

If you don't want to add chart elements individually, you can use one of Excel's predefined layouts. Simply click 

the Quick Layout command, then choose the desired layout from the drop-down menu. 

Excel also includes several different chart styles, which allow you to quickly modify the look and feel of your 

chart. To change the chart style, select the desired style from the Chart styles group. 



 

 

 

 

 
 

 TIP: You can also use the chart formatting shortcut buttons to quickly add chart elements, change the chart 

style, and filter the chart data. 

 

 

 

 

Other chart options 

 

There are lots of other ways to customize and organize your charts. For example, Excel allows you to rearrange 

a chart's data, change the chart type, and even move the chart to a different location in the workbook. 

To switch row and column data  

Sometimes you may want to change the way charts group your data. For example, in the chart below, the Book 

Sales data are grouped by year, with columns for each genre. However, we could switch the rows and columns 

so the chart will group the data by genre, with columns for each year. In both cases, the chart contains the same 

data—it's just organized differently. 

Select the chart you wish to modify. 



 

 

 

 

From the Design tab, select the Switch Row/Column command. 

 

The rows and columns will be switched. 

 

 

To change the chart type  

If you find that your data isn't well suited to a certain chart, it's easy to switch to a new chart type. In our 

example, we'll change our chart from a Column chart to a Line chart. 

From the Design tab, click the Change Chart Type command. 

 

The Change Chart Type dialog box will appear. 

The selected chart type will appear. 

 

 

To move a chart  

Whenever you insert a new chart, it will appear as an object on the same worksheet that contains its source data. 

Alternatively, you can move the chart to a new worksheet to help keep your data organized. 

Select the chart you wish to move. 

Click the Design tab, then select the Move Chart command. 

 



 

 

 

 

The Move Chart dialog box will appear. Select the desired location for the chart. 

Click OK. 

The chart will appear in the selected location. 

 

 

Challenge! 

Open an existing Excel workbook. 

Use worksheet data to create a chart. 

Change the chart layout. 

Apply a chart style. 

Move the chart. 

 

 

Printing Workbooks 

 

There may be times when you want to print a workbook to view and share your data offline. Once you've 

chosen your page layout settings, it's easy to preview and print a workbook from Excel using the Print pane. 

 

 

To access the Print pane  

Select the File tab. Backstage view will appear. 

 

 

 

 

 

Select Print. The Print pane will appear. 



 

 

 

 

 

 

Here you can choose how many copies of the workbook you wish to print. 

 

 

When you are ready to print the workbook, click the Print button. 

 

You may need to select the printer you want to use if your computer is connected to multiple printers. 

 

 

 

 

 

Here you can choose to print the active sheets, the entire workbook, or a selection of 

 

 

 

 

If you are printing multiple copies, you 

can choose whether you want the 

copies collated or uncollated. 

Here you can choose whether to print on 

one side or both sides of the paper. 

 

 

 

If your printer uses different paper sizes, 

you can choose the paper size you wish 

to use. 

 

 

Here you can choose how to scale your 

worksheets for the printed page. You can 

scale worksheets at their actual size, fit 

the entire worksheet on one page, fit all 

columns on one page, or fit all rows on 

one page. 

Here you can choose Portrait 

or Landscape orientation. 

 

 

 

Here you can adjust the page 

margins, which can help your data 

fit more comfortably on the page. 

 

 

 

Choosing a print area 

 

Before you print an Excel workbook, it's important to decide exactly what information you want to print. For 

example, if you have multiple worksheets in your workbook, you will need to decide if you want to print the 

entire workbook or only active worksheets. There may also be times when you want to print only a selection of 

content from your workbook. 



 

 

 

 

To print active sheets  

Worksheets are considered active when selected. 

Select the worksheet you want to print. To print multiple worksheets, click the first worksheet, hold the Ctrl key 

on your keyboard, then click any other worksheets you want to select. 

 

Navigate to the Print pane. 

Select Print Active Sheets from the Print Range drop-down menu. 

 

Click the Print button. 

 

 

 

 

 

To print the entire workbook  

Navigate to the Print pane. 

Select Print Entire Workbook from the Print Range drop-down menu. 



 

 

 

 

 
 

Click the Print button. 

 

 

 

To print a selection  

Select the cells you wish to print. 

Navigate to the Print pane. 

Select Print Selection from the Print Range drop-down menu. 

 

A preview of your selection will appear in the Preview pane. 

Click the Print button to print the selection. 



 

 

 

 

 
 

 TIP: If you prefer, you can also set the print area in advance so you'll be able to visualize which cells will be 

printed as you work in Excel. Simply select the cells you want to print, click the Page Layout tab, select the 

Print Area command, then choose Set Print Area. 

 

 

 

 

 

 

Fitting and scaling content 

 

On occasion, you may need to make small adjustments from the Print pane to fit your workbook content neatly 

onto a printed page. The Print pane includes several tools to help fit and scale your content, such as scaling and 

page margins. 

  



 

 

 

 

To fit content before printing  

If some of your content is being cut off by the printer, you can use scaling to fit your workbook to the page 

automatically. 

Navigate to the Print pane. 

Select the desired option from the Scaling drop-down menu. In our example, we'll select Fit Sheet on One Page. 

 

The worksheet will be condensed to fit onto a single page. 

When you're satisfied with the scaling, click Print. 

 

 

To modify margins in the Preview pane  

Sometimes you may only need to adjust a single margin to make your data fit more comfortably. You can 

modify individual page margins from the Preview pane. 

Navigate to the Print pane, then click the Show Margins button in the lower-right corner. 



 

 

 

 

 
The page margins will appear in the Preview pane. Hover the mouse over one of the margin 

markers until the cursor becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the margin width. 

Release the mouse. The margin will be modified. In our example, we were able to fit an additional column on 

the page. 

 

 

Show Margins 
button. 



 

 

 

Unit-1 

 

Opening Excel 

 

Using Windows 7  

 

Click on the Start Button. 

In the Search Program and Files box type Excel. 

Click on Excel 2013 from the Program results. 

The Microsoft Excel 2013 program will open. 

 

 

Using Windows 8   

 

Press the Windows key on the keyboard. 

Type Excel. 

Click on Excel 2013 under the Apps results. 

 

 

Using iOS 7  

 

Click on Launchpad. 

Select Microsoft Excel. 

 

 

Getting Started 

 

When you open Excel 2013 for the first time, the Excel Start Screen will appear. From here, you'll be able to 

create a new workbook, choose a template, and access your recently edited workbooks. 

 

From the Excel Start Screen, locate and select Blank workbook to access the Excel interface. 

Click Open Other Workbooks to work on an existing workbook. 



 

 

 

 

 
 

 

 

To set up Excel so it automatically opens a new workbook   

 

Click File then Options. 

On the General tab, under Start up options, uncheck the Show the Start screen when this application starts box. 

The next time you start Excel, it opens a blank workbook automatically similar to older versions of Excel. 

 

The Excel Interface 

 

After starting Excel, you will see two windows - one within the other. The outer window is the Application 

Window and the inner window is the Workbook Window. When maximized, the Excel Workbook Window 

blends in with the Application Window. 

 

After completing this module, you should be able to: 

 

Identify the components of the Application Window. 

Identify the components of the Workbook Window. 

Create a new workbook 

Open an existing workbook 



 

 

 

 

 
 

 

The Application Window 

 

The Application Window provides the space for your worksheets and workbook elements such as charts. The 

components of the Application Window are described below. 

 

The Quick Access Toolbar 

 

The Quick Access Toolbar lets you access common commands no matter which tab is selected. 

 

By default, it includes the Save, Undo, and Repeat commands. You can add other commands depending on your 

preference. 

 

To add commands to the Quick Access toolbar  

 

Click the drop-down arrow to the right of the Quick Access toolbar. 

Quick Access Toolbar 

The Ribbon 

Command Group 

Name Box Formula Bar 
Colum 

Cell 

Row 

Vertical and Horizontal Scroll Bars 

Worksheets 

Worksheet View Option Zoom Control 



 

 

 

 

Select the command you wish to add from the drop-down menu. To choose from more commands, select More 

Commands. 

 

 

 

 

The command will be added to the Quick Access toolbar. 

 

 

 

 

 

 

The Ribbon 

 

Excel 2013 uses a tabbed Ribbon system instead of traditional menus. The Ribbon contains multiple tabs, each 

with several groups of commands. You will use these tabs to perform the most common tasks in Excel. 



 

 

 

 

 

 
 

 

 

To minimize and maximize the Ribbon  

 

The Ribbon is designed to respond to your current task, but you can choose to minimize it if you find that it 

takes up too much screen space. 

 

Click the Ribbon Display Options arrow in the upper-right corner of the Ribbon. 

 

Click a tab to see 

more commands 

Each tab is divided 

into groups 



 

 

 

 

Select the desired minimizing option from the drop-down menu: 

 

Auto-hide Ribbon: Auto-hide displays your workbook in full-screen mode and completely hides the Ribbon. To 

show the Ribbon, click the Expand Ribbon command at the top of screen. 

 

 

Show Tabs: This option hides all command groups when not in use, but tabs will remain visible. To show the 

Ribbon, simply click a tab. 

 Show Tabs and Commands: This option maximizes the Ribbon. All of the tabs and commands will be visible. 

This option is selected by default when you open Excel for the first time. 

 

To Customize the Ribbon in Excel 2013  

 

You can customize the Ribbon by creating your own tabs with whichever commands you want. Commands are 

always housed within a group, and you can create as many groups as you want in order to keep your tab 

organized. If you want, you can even add commands to any of the default tabs, as long as you create a custom 

group in the tab. 

 

Right-click the Ribbon and then select Customize the Ribbon... from the drop-down menu. 

 

 

The Excel Options dialog box will appear. Locate and select New Tab. 

Ribbon is hidden and workbook 

appears in full screen 
Click the Expand Ribbon 

command to show the Ribbon 



 

 

 

 

 
 

Make sure the New Group is selected, select a command, and then click Add. You can also drag commands 

directly into a group. 

When you are done adding commands, click OK. The commands will be added to the Ribbon. 

 

 

Select 
commands and 

click Add 
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The Formula Bar 

 

In the formula bar, you can enter or edit data, a formula, or a function that will appear in a specific cell. 

 

In the image below, cell C1 is selected and 1984 is entered into the formula bar. Note how the data appears in 

both the formula bar and in cell C1. 

 

 

 

The Name Box 

 

The Name box displays the location, or "name" of a selected cell. 

 

In the image below, cell B4 is selected. Note that cell B4 is where column B and row 4 intersect. 

 

 

The Backstage View (The File Menu) 

 

Click the File tab on the Ribbon. Backstage view will appear. 

 

 



 

 

 

 

 

 

 
 

 

The Worksheet Views 

 

Excel 2013 has a variety of viewing options that change how your workbook is displayed. You can choose to 

view any workbook in Normal view, Page Layout view, or Page Break view. These views can be useful for 

various tasks, especially if you're planning to print the spreadsheet. 

 

To change worksheet views, locate and select the desired worksheet view command in the bottom-right corner 

of the Excel window. 

Return to Excel 
Info contains 

information about the 
current workbook. You 

can also inspect the 
workbook and set 

protection controls. 
New: you can create a new, blank 
workbook, or choose from a large 

selection of templates. 

Open: you can open 
recent workbooks, as 

well as workbooks saved 

to your OneDrive or on Use Save and Save As to save 

your computer. your workbook to your computer 
or to Office 365. 

From the Print pane, 

you can change the 

print settings and print 

your workbook. You 

can also see a preview 

of your workbook. 

Share: you can invite people to view and 
collaborate on your workbook. You can also share 

your workbook by emailing it as an attachment. 

Export: you can choose 
to export your 

workbook in another 
format, such as 

PDF/XPS or Excel 
1997-2003. 

Close the current workbook. 
 

From the Account pane, you can access your 
Microsoft account information, modify your theme 

and background, and sign out of your account. 

Options: you can change various Excel options. For 
example, you can control the Quick Analysis preferences, 

Auto Recover settings, or Language preferences. 



 

 

 

 

 
 

 

Zoom Control 

 

To use the Zoom control, click and drag the slider. The number to the right of the slider reflects the zoom 

percentage. 

 

 

Page Layout 

View 

Normal View Page Break 

View 



 

 

 

 

The Workbook Window 

 

In Excel 2013, when you open up a new workbook it now contains only 1 worksheet There can be a max of 

1,048,576 rows and 16,384 columns in an excel work sheet. 

 

The Worksheet 

 

Excel files are called workbooks. Each workbook holds one or more worksheets (also known as "spreadsheets"). 

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. A worksheet is a grid 

of columns and rows where columns are designated by letters running across the top of the worksheet and rows 

are designated by numbers running down the left side of the worksheet. 

 

 

 

When working with a large amount of data, you can create multiple worksheets to help organize your workbook 

and make it easier to find content. You can also group worksheets to quickly add information to multiple 

worksheets at the same time. 

 

To rename a worksheet  

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. You can rename a 

worksheet to better reflect its content. In our example, we will create a training log organized by month. 

 

Right-click the worksheet you wish to rename, then select Rename from the worksheet menu. 



 

 

 

 

 
 

Type the desired name for the worksheet. 

 

 

Click anywhere outside of the worksheet, or press Enter on your keyboard. The worksheet will be renamed. 

 

 

To insert a new worksheet  

 

Locate and select the New sheet button. 

 

 

Click to add a 

new worksheet 



 

 

 

 

A new, blank worksheet will appear. 

 

 TIP: To change the default number of worksheets, navigate to Backstage view, click Options, and then 

choose the desired number of worksheets to include in each new workbook. 

 

 

 

To delete a worksheet  

 

Right-click the worksheet you wish to delete, then select Delete from the worksheet menu. 

 

 

The worksheet will be deleted from your workbook. 



 

 

 

 

 
 

 

 

Alternatively, from the Home Tab in the Cells Group click on Delete and select Delete Sheet. Warning: The 

Undo button will not undo the deletion of a worksheet. 

To copy a worksheet  

 

If you need to duplicate the content of one worksheet to another, Excel allows you to copy an existing 

worksheet. 

 

Right-click the worksheet you want to copy, then select Move or Copy from the worksheet menu. 

 

 

 

 

The Move or Copy dialog box will appear. Choose where the sheet will appear in the Before sheet: field. In our 

example, we'll choose (move to end) to place the worksheet to the right of the existing worksheet. 

Check the box next to Create a copy, then click OK. 



 

 

 

 

 
 

The worksheet will be copied. It will have the same title as the original worksheet, as well as a version number. 

 

TIP: You can also copy a worksheet to an entirely different workbook. You can select any workbook that is 

currently open from the To book: drop-down menu. 

 

 

To move a worksheet  

 

Sometimes you may want to move a worksheet to rearrange your workbook. 

 

Select the worksheet you wish to move. The cursor will become a small worksheet icon . 

Hold and drag the mouse until a small black arrow appears above the desired location. 



 

 

 

 

 
 

Release the mouse. The worksheet will be moved. 

 

To change the worksheet color  

 

You can change a worksheet's color to help organize your worksheets and make your workbook easier to 

navigate. 

 

Right-click the desired worksheet, and hover the mouse over Tab Color. The Color menu will appear. 

Select the desired color. A live preview of the new worksheet color will appear as you hover the mouse over 

different options. In our example, we'll choose Red. 

The worksheet color will be changed. 



 

 

 

 

The worksheet color is considerably less noticeable when the worksheet is selected. Select another worksheet to 

see how the color will appear when the worksheet is not selected. 

 

 

 

 

 

. 

 



 

 

 

 

The Scroll Bars 

 

Your spreadsheet may frequently have more data than you can see on the screen at once. Click, hold and drag 

the vertical or horizontal scroll bar depending on what part of the page you want to see. 

 

 

 

 

 

Creating and Opening Workbooks 

 

Excel files are called workbooks. Whenever you start a new project in Excel, you'll need to create a new 

workbook. There are several ways to start working with a workbook in Excel 2013. You can choose to create a 

new workbook—either with a blank workbook or a predesigned template—or open an existing workbook. 

 

Create a new blank workbook 

 

Select the File tab. Backstage view will appear. 

 

Vertical 

scroll bar 

Horizontal 

scroll bar 



 

 

 

 

Select New, then click Blank workbook. 

A new blank workbook will appear. 

 

Open an existing workbook 

 

In addition to creating new workbooks, you'll often need to open a workbook that was previously saved. 

Navigate to Backstage view, then click Open. 

 

 

 

 

Select Computer, and then click Browse. 

 



 

 

 

 

The Open dialog box will appear. Locate and select your workbook, then click Open. 

 

 

 

 TIP: If you've opened the desired workbook recently, you can browse your Recent Workbooks rather than 

searching for the file. 

 



 

 

 

 

To pin a workbook  

If you frequently work with the same workbook, you can pin it to Backstage view for quick access. 

Navigate to Backstage view and then click Open. Your recently edited workbooks will appear. 

Hover the mouse over the workbook you wish to pin. A pushpin icon will appear next to the workbook. Click 

the pushpin icon. 

 

 

The workbook will stay in Recent Workbooks. To unpin a workbook, simply click the pushpin icon again. 

 

 TIP: You can also pin folders to Backstage view for quick access. From Backstage view, click Open, then 

locate the folder you wish to pin and click the pushpin icon. 

 

 

Compatibility mode 

 

Sometimes you may need to work with workbooks that were created in earlier versions of Microsoft Excel, such 

as Excel 2003 or Excel 2000. When you open these kinds of workbooks, they will appear in Compatibility 

mode. 

 



 

 

 

 

Compatibility mode disables certain features, so you'll only be able to access commands found in the program 

that was used to create the workbook. For example, if you open a workbook created in Excel 2003, you can only 

use tabs and commands found in Excel 2003. 

In order to exit Compatibility mode, you'll need to convert the workbook to the current version type. However, 

if you're collaborating with others who only have access to an earlier version of Excel, it's best to leave the 

workbook in Compatibility mode so the format will not change. 

To convert a workbook  

If you want access to all of the Excel 2013 features, you can convert the workbook to the 2013 file format. Note 

that converting a file may cause some changes to the original layout of the workbook. 

Click the File tab to access Backstage view. 

Locate and select Convert command. 

 

 

 

 

The Save As dialog box will appear. Select the location where you wish to save the workbook, enter a file name 

for the presentation, and click Save. 

The workbook will be converted to the newest file type. 

 

 



 

 

 

 

Saving and Sharing Workbooks 

 

Whenever you create a new workbook in Excel, you'll need to know how to save it in order to access and edit it 

later. As with previous versions of Excel, you can save files locally to your computer. But unlike older versions, 

Excel 2013 also lets you save a workbook to the cloud using OneDrive. You can also export and share 

workbooks with others directly from Excel. 

 

Save and Save As 

 

Excel offers two ways to save a file: Save and Save As. These options work in similar ways, with a few 

important differences: 

Save: When you create or edit a workbook, you'll use the Save command to save your changes. You'll use this 

command most of the time. When you save a file, you'll only need to choose a file name and location the first 

time. After that, you can just click the Save command to save it with the same name and location. 

Save As: You'll use this command to create a copy of a workbook while keeping the original. When you use 

Save As, you'll need to choose a different name and/or location for the copied version. 

 

To save a workbook  

  

It's important to save your workbook whenever you start a new project or make changes to an existing one. 

Saving early and often can prevent your work from being lost. You'll also need to pay close attention to where 

you save the workbook so it will be easy to find later. 

 

Locate and select the Save command on the Quick Access Toolbar. 

 

 

If you're saving the file for the first time, the Save As pane will appear in Backstage view. 

You'll then need to choose where to save the file and give it a file name. To save the workbook to your 

computer, select Computer, then click Browse. Alternatively, you can click OneDrive to save the file to your 

OneDrive. 

The Save As dialog box will appear. Select the location where you wish to save the workbook. 



 

 

 

 

Enter a file name for the workbook, then click Save. 

 

 

 

The workbook will be saved. You can click the Save command again to save your changes as you modify the 

workbook. 

 

Using Save As to make a copy  

  

If you want to save a different version of a workbook while keeping the original, you can create a copy. For 

example, if you have a file named "Sales Data" you could save it as "Sales Data 2" so you'll be able to edit the 

new file and still refer back to the original version. 

To do this, you'll click the Save As command in Backstage view. Just like when saving a file for the first time, 

you'll need to choose where to save the file and give it a new file name. 

 

AutoRecover 

 

Excel automatically saves your workbooks to a temporary folder while you are working on them. If you forget 

to save your changes, or if Excel crashes, you can restore the file using AutoRecover. 

 

To use Auto Recover  

  

Open Excel 2013. If auto-saved versions of a file are found, the Document Recovery pane will appear. 

Choose a location, and 

then type the file name. 



 

 

 

 

Click to open an available file. The workbook will be recovered. 

 

 

 

 

 

 TIP: By default, Excel autosaves every 10 minutes. If you are editing a workbook for less than 10 minutes, 

Excel may not create an autosaved version. 

If you don't see the file you need, you can browse all autosaved files from Backstage view. Just select the File 

tab, click Manage Versions, and then choose Recover Unsaved Workbooks. 

 

 

Exporting workbooks 

 

By default, Excel workbooks are saved in the .xlsx file type. However, there may be times when you need to use 

another file type, such as a PDF or Excel 97-2003 workbook. It's easy to export your workbook from Excel in a 

variety of file types. 

To export a workbook as a PDF file  

Exporting your workbook as an Adobe Acrobat document, commonly known as a PDF file, can be especially 

useful if sharing a workbook with someone who does not have Excel. A PDF will make it possible for recipients 

to view, but not edit, the content of your workbook. 

Click the File tab to access Backstage view. 

Click Export, then select Create PDF/XPS. 



 

 

 

 

 
 

 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Publish. 

 

 TIP: By default, Excel will only export the active worksheet. If you have multiple worksheets and want to 

save all of them in the same PDF file, click Options in the Save as dialog box. The Options dialog box will 

appear. Select Entire workbook, then click OK. 

 

 

 

 

To export a workbook in other file types  

  

You may also find it helpful to export your workbook in other file types, such as an Excel 97-2003 Workbook if 

you need to share with people using an older version of Excel, or a .CSV file if you need a plain-text version of 

your workbook. 



 

 

 

 

Click the File tab to access Backstage view. 

Click Export, then select Change File Type. 

Select a common file type, then click Save As. 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Save. 

 

 

Challenge! 

Create a new blank workbook. 

Use the Save command to save the workbook to your desktop. 

Save the workbook to OneDrive and invite someone else to view it. 

Export the workbook as a PDF file. 

 

 

Cell Basics 

 

Whenever you work with Excel, you'll enter information, or content, into cells. Cells are the basic building 

blocks of a worksheet. You'll need to learn the basics of cells and cell content to calculate, analyze, and organize 

data in Excel. 

 

 

Understanding Cells 

 

Every worksheet is made up of thousands of rectangles, which are called cells. A cell is the intersection of a row 

and a column. Columns are identified by letters (A, B, C), while rows are identified by numbers (1, 2, 3). 

 

Colum 

Row Cell 



 

 

 

 

Each cell has its own name, or cell address, based on its column and row. In this example, the selected cell 

intersects column C and row 5, so the cell address is C5. The cell address will also appear in the Name box. 

Note that a cell's column and row headings are highlighted when the cell is selected. 

 

 

 

 

You can also select multiple cells at the same time. A group of cells is known as a cell range. Rather than a 

single cell address, you will refer to a cell range using the cell addresses of the first and last cells in the cell 

range, separated by a colon. For example, a cell range that included cells A1, A2, A3, A4, and A5 would be 

written as A1:A5. 

 

In the images below, two different cell ranges are selected: 

 

Cell range A1:A8 

 

 

Cell range A1:B8 

Cell Address 



 

 

 

 

 
 

To select a cell range  

 

Sometimes you may want to select a larger group of cells, or a cell range. 

 

Click, hold, and drag the mouse until all of the adjoining cells you wish to select are highlighted. 

Release the mouse to select the desired cell range. The cells will remain selected until you click another cell in 

the worksheet. 

Cell Content 

 

Any information you enter into a spreadsheet will be stored in a cell. Each cell can contain several different 

kinds of content, including text, formatting, formulas, and functions. 

 

Text 

Cells can contain text, such as letters, numbers, and dates. 
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Formatting Attributes 

Cells can contain formatting attributes that change the way letters, numbers, and dates are displayed. For 

example, percentages can appear as 0.15 or 15%. You can even change a cell's background color. 

 

Formulas and Functions 

Cells can contain formulas and functions that calculate cell values. In our example, SUM(B4:B7) adds the value 

of each cell in cell range B4:B7 and displays the total in cell B8. 

 

 

To insert content  

Click a cell to select it. 

 

Type content into the selected cell, then press Enter on your keyboard. The content will appear in the cell and 

the formula bar. You can also input and edit cell content in the formula bar. 

 

 

 
 
 
 

Content appears in cell 

and formula bar 



 

 

 

 

To delete cell content  

Select the cell with content you wish to delete. 

Press the Delete or Backspace key on your keyboard. The cell's contents will be deleted. 

To delete cells  

There is an important difference between deleting the content of a cell and deleting the cell itself. If you delete 

the entire cell, the cells below it will shift up and replace the deleted cells. 

Select the cell(s) you wish to delete. 

Select the Delete command from the Home tab on the Ribbon. 

The cells below will shift up. 

 

 

 

 

To copy and paste cell content  

Excel allows you to copy content that is already entered into your spreadsheet and paste that content to other 

cells, which can save you time and effort. 

Select the cell(s) you wish to copy. 

Click the Copy command on the Home tab, or press Ctrl+C on your keyboard. 



 

 

 

 

 
 

 

Select the cell(s) where you wish to paste the content. The copied cells will now have a dashed box around 

them. 

Click the Paste command on the Home tab, or press Ctrl+V on your keyboard. 

The content will be pasted into the selected cells. 

 

 

To access more paste options  

You can also access additional paste options, which are especially convenient when working with cells that 

contain formulas or formatting. 

 To access more paste options, click the drop-down arrow on the Paste command. 

 



 

 

 

 

 TIP: Rather than choosing commands from the Ribbon, you can access commands quickly by right- clicking. 

Simply select the cell(s) you wish to format, then right-click the mouse. A drop-down menu will appear, where 

you'll find several commands that are also located on the Ribbon. 

 

 

To drag and drop cells  

Rather than cutting, copying, and pasting, you can drag and drop cells to move their contents. 

Select the cell(s) you wish to move. 

Hover the mouse over the border of the selected cell(s) until the cursor changes from a white cross to a black 

cross with four arrows. 

Click, hold, and drag the cells to the desired location. 

Release the mouse, and the cells will be dropped in the selected location. 

 

 

To use the fill handle  

There may be times when you need to copy the content of one cell to several other cells in your worksheet. You 

could copy and paste the content into each cell, but this method would be very time consuming. Instead, you can 

use the fill handle to quickly copy and paste content to adjacent cells in the same row or column. 

Select the cell(s) containing the content you wish to use. The fill handle will appear as a small square in the 

bottom-right corner of the selected cell(s). 



 

 

 

 

 
Click, hold, and drag the fill handle until all of the cells you wish to fill are selected. 

 

 

 

 

Release the mouse to fill the selected cells. 

 

To continue a series with the fill handle  

The fill handle can also be used to continue a series. Whenever the content of a row or column follows a 

sequential order, like numbers (1, 2, 3) or days (Monday, Tuesday, Wednesday), the fill handle can guess what 

should come next in the series. In many cases, you may need to select multiple cells before using the fill handle 

to help Excel determine the series order. In our example below, the fill handle is used to extend a series of dates 

in a column. 

The fill handle 



 

 

 

 

 

 

  
 

 

 

 

Find and Replace 

 

When working with a lot of data in Excel, it can be difficult and time consuming to locate specific information. 

You can easily search your workbook using the Find feature, which also allows you to modify content using the 

Replace feature. 

To find content  

From the Home tab, click the Find and Select command, then select Find... from the drop-down menu. 

 

 

 

 

 

 

 

 

 

 

The Find and Replace dialog box will appear. Enter the content you wish to find. 

Click Find Next. If the content is found, the cell containing that content will be selected. 



 

 

 

 

 
 

 

 

Click Find Next to find further instances or Find All to see every instance of the search term. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 TIP: You can also access the Find command by pressing Ctrl+F on your keyboard. 

 TIP: Click Options to see advanced search criteria in the Find and Replace dialog box. 

 

 

 

 

To replace cell content  

At times, you may discover that you've repeatedly made a mistake throughout your workbook (such as 

misspelling someone's name), or that you need to exchange a particular word or phrase for another. You can use 

Excel's Find and Replace feature to make quick revisions. 



 

 

 

 

From the Home tab, click the Find and Select command, then select Replace... from the drop- down menu. 

The Find and Replace dialog box will appear. Type the text you wish to find in the Find what: field. 

Type the text you wish to replace it with in the Replace with: field, then click Find Next. 

If the content is found, the cell containing that content will be selected. 

Review the text to make sure you want to replace it. 

If you wish to replace it, select one of the replace options: 

Replace will replace individual instances. 

Replace All will replace every instance of the text throughout the workbook. In our example, we'll choose this 

option to save time. 

A dialog box will appear, confirming the number of replacements made. Click OK to continue. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 

Formatting Cells 

 

All cell content uses the same formatting by default, which can make it difficult to read a workbook with a lot of 

information. Basic formatting can customize the look and feel of your workbook, allowing you to draw attention 

to specific sections and making your content easier to view and understand. You can also apply number 

formatting to tell Excel exactly what type of data you’re using in the workbook, such as percentages (%), 

currency ($), and so on. 



 

 

 

 

Font Formatting 

 

To change the font  

By default, the font of each new workbook is set to Calibri. However, Excel provides a variety of other fonts 

you can use to customize your cell text. In the example below, we'll format our title cell to help distinguish it 

from the rest of the worksheet. 

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font command on the Home tab. The Font drop-down menu will appear. 

Select the desired font. A live preview of the new font will appear as you hover the mouse over different 

options. 

 

 

 

The text will change to the selected font. 

 

 TIP: When creating a workbook in the workplace, you'll want to select a font that is easy to read. 

Along with Calibri, standard reading fonts include Cambria, Times New Roman, and Arial. 

To change the font size  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Size command on the Home tab. The Font Size drop- down menu 

will appear. 

Select the desired font size. A live preview of the new font size will appear as you hover the mouse over 

different options. 

The text will change to the selected font size. 

 TIP: You can also use the Increase Font Size and Decrease Font Size commands or enter a custom font size 

using your keyboard. 



 

 

 

 
 

To change the font color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Color command on the Home tab. The Color menu will appear. 

Select the desired font color. A live preview of the new font color will appear as you hover the mouse over 

different options. 

 

 

The text will change to the selected font color. 

 

 

To use the Bold, Italic, and Underline commands  

Select the cell(s) you wish to modify. 

Click the Bold (B), Italic (I), or Underline (U) command on the Home tab. In our example, we'll make the 

selected cells bold. 

Entering a custom 

font size 
Increase and 
Decrease Font 

Size commands 



 

 

 

 

 
 

 

The selected style will be applied to the text. 

 TIP: You can also press Ctrl+B on your keyboard to make selected text bold, Ctrl+I to apply italics, and 

Ctrl+U to apply an underline. 

 

Text Alignment 

 

By default, any text entered into your worksheet will be aligned to the bottom-left of a cell. Any numbers will 

be aligned to the bottom-right of a cell. Changing the alignment of your cell content allows you to choose how 

the content is displayed in any cell, which can make your cell content easier to read. 

To change horizontal text alignment  

Select the cell(s) you wish to modify. 

Select one of the three horizontal alignment commands on the Home tab. In our example, we'll choose Center 

Align. 

 

The text will realign. 

To change vertical text alignment  

Select the cell(s) you wish to modify. 

Select one of the three vertical alignment commands on the Home tab. In our example, we'll choose Middle 

Align. 



 

 

 

 

 
 

The text will realign. 

 

 

Cell borders and fill colors 

 

Cell borders and fill colors allow you to create clear and defined boundaries for different sections of your 

worksheet. 

To add a border  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Borders command on the Home tab. The Borders drop- down menu will 

appear. 

 

 

Select the border style you want to use. 

The selected border style will appear. 

 TIP: You can draw borders and change the line style and color of borders with the Draw Borders tools at the 

bottom of the Borders drop-down menu. 



 

 

 

 

 
 

 

To add a fill color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Fill Color command on the Home tab. The Fill Color menu will appear. 

Select the fill color you want to use. A live preview of the new fill color will appear as you hover the mouse 

over different options. In our example, we'll choose Light Green. 

 

 

The selected fill color will appear in the selected cells. 



 

 

 

 

Cell styles 

 

Rather than formatting cells manually, you can use Excel's predesigned cell styles. Cell styles are a quick way to 

include professional formatting for different parts of your workbook, such as titles and headers. 

To apply a cell style  

Select the cell(s) you wish to modify. 

Click the Cell Styles command on the Home tab, then choose the desired style from the drop-down menu. 

 

 

The selected cell style will appear. 

 TIP: Applying a cell style will replace any existing cell formatting except for text alignment. You may not 

want to use cell styles if you've already added a lot of formatting to your workbook. 

 

Formatting text and numbers 

 

One of the most powerful tools in Excel is the ability to apply specific formatting for text and numbers. Instead 

of displaying all cell content in exactly the same way, you can use formatting to change the appearance of dates, 

times, decimals, percentages (%), currency ($), and much more. 

To apply number formatting  

Select the cells(s) you wish to modify. 

Click the drop-down arrow next to the Number Format command on the Home tab. The Number Formatting 

drop-down menu will appear. 

Select the desired formatting option. 

The selected cells will change to the new formatting style. 



 

 

 

General is the default format for any cell. 
When you enter a number into the cell, 

Excel will guess the number format that is 

most appropriate. 
Number formats numbers 

with decimal places. 

Currency formats numbers as currency 

with a currency symbol. 

Short Date formats numbers 

as M/D/YYYY. 

Accounting formats numbers as monetary 

values like the Currency format, but it also 

aligns currency symbols and decimal 

places within columns. 

Long Date formats numbers as 

Weekday, Month DD, YYYY. 

Time formats numbers as HH/MM/SS 

and notes AM or PM. 

Percentage formats numbers with 
decimal places and the percent sign. 

Fraction formats numbers as fractions 

separated by the forward slash. 

Scientific formats numbers 

in scientific notation. 

Text formats numbers as text, meaning 

that what you enter into the cell will 

appear exactly as it was entered. 

You can easily customize any format in 

More Number Formats. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Challenge! 

Open an existing Excel 2013 workbook. 

Select a cell and change the font style, size, and color of the text. 

Apply bold, italics, or underline to a cell. 

Try changing the vertical and horizontal text alignment for some cells. 

Add a border to a cell range. 

Change the fill color of a cell range. 

Try changing the formatting of a number. 



 

 

 

 

Modifying Columns, Rows and Cells 

 

By default, every row and column of a new workbook is always set to the same height and width. Excel allows 

you to modify column width and row height in different ways, including wrapping text and merging cells. 

 

 

To modify column width  

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

 

Click, hold, and drag the mouse to increase or decrease the column width. 

Release the mouse. The column width will be changed. 

 TIP: If you see pound signs (#######) in a cell, it means that the column is not wide enough to display the 

cell content. Simply increase the column width to show the cell content. 

 

 

To AutoFit column width  

The AutoFit feature will allow you to set a column's width to fit its content automatically. 

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

Double-click the mouse. The column width will be changed automatically to fit the content. 

 TIP: You can also AutoFit the width for several columns at the same time. Simply select the columns you 

would like to AutoFit, then select the AutoFit Column Width command from the Format drop- down menu on 

the Home tab. This method can also be used for Row height. 



 

 

 

 

 

 
To modify row height  

Position the cursor over the row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse. The height of the selected row will be changed. 

 

 

To modify all rows or columns  

Rather than resizing rows and columns individually, you can modify the height and width of every row and 

column at the same time. This method allows you to set a uniform size for every row and column in your 

worksheet. 

Locate and click the Select All button just below the formula bar to select every cell in the worksheet. 

 

 

 

 

 

 

 

 

 

 

Position the mouse over a row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse when you are satisfied with the new row height for the worksheet. 



 

 

 

 

Inserting, deleting, moving, and hiding rows and columns 

 

After you've been working with a workbook for a while, you may find that you want to insert new columns or 

rows, delete certain rows or columns, move them to a different location in the worksheet, or even hide them. 

To insert rows  

Select the row heading below where you want the new row to appear. 

Click the Insert command on the Home tab. 

 

The new row will appear above the selected row. 

 

 TIP: When inserting new rows, columns, or cells, you will see the Insert Options button next to the 

inserted cells. This button allows you to choose how Excel formats these cells. By default, Excel formats 

inserted rows with the same formatting as the cells in the row above. To access more options, hover your mouse 

over the Insert Options button, then click the drop-down arrow. 

 

 



 

 

 

 

To insert columns  

Select the column heading to the right of where you want the new column to appear. 

Click the Insert command on the Home tab. 

 

The new column will appear to the left of the selected column. 

 

 TIP: When inserting rows and columns, make sure you select the entire row or column by clicking the 

heading. If you select only a cell in the row or column, the Insert command will only insert a new cell. 

 

To delete rows  

It's easy to delete any row that you no longer need in your workbook. 

Select the row(s) you want to delete. 

Click the Delete command on the Home tab. 

 



 

 

 

 

The selected row(s) will be deleted, and the rows below will shift up. 

To delete columns  

Select the columns(s) you want to delete. 

Click the Delete command on the Home tab. 

 

 

 

 

 

 

 

The selected columns(s) will be deleted, and the columns to the right will shift left. 

 TIP: It's important to understand the difference between deleting a row or column and simply clearing its 

contents. If you want to remove the content of a row or column without causing others to shift, right-click a 

heading, then select Clear Contents from the drop-down menu. 

 

 



 

 

 

 

To move a row or column  

Sometimes you may want to move a column or row to rearrange the content of your worksheet. 

Select the desired column heading for the column you wish to move, then click the Cut command on the Home 

tab or press Ctrl+X on your keyboard. 

Select the column heading to the right of where you want to move the column. For example, if you want to 

move a column between columns B and C, select column C. 

Click the Insert command on the Home tab, then select Insert Cut Cells from the drop-down menu. 

 

The column will be moved to the selected location, and the columns to the right will shift right. 

 

 TIP: You can also access the Cut and Insert commands by right-clicking the mouse and then selecting the 

desired commands from the drop-down menu. 

 

 

To hide and unhide a row or column  

At times, you may want to compare certain rows or columns without changing the organization of your 

worksheet. Excel allows you to hide rows and columns as needed. 

Select the column(s) you wish to hide, right-click the mouse, then select Hide from the formatting menu. 



 

 

 

 

The columns will be hidden. The green column line indicates the location of the hidden columns. 

 

 

 

 

To unhide the columns, select the columns to the left and right of the hidden columns (in other words, the 

columns on both sides of the hidden columns). 

Right-click the mouse, then select Unhide from the formatting menu. The hidden columns will reappear. 

 

 

Wrapping text and merging cells 

 

Whenever you have too much cell content to be displayed in a single cell, you may decide to wrap the text or 

merge the cell rather than resizing a column. Wrapping the text will automatically modify a cell's row height, 

allowing cell contents to be displayed on multiple lines. Merging allows you to combine a cell with adjacent, 

empty cells to create one large cell. 

Select the cells you wish to wrap. 

Select the Wrap Text command on the Home tab. 

 

Green 

column line 



 

 

 

 

The text in the selected cells will be wrapped. 

 TIP: Click the Wrap Text command again to unwrap the text. 

 

 

To merge cells using the Merge & Center command  

Select the cell range you want to merge together. 

Select the Merge & Center command on the Home tab. 

 

 

 

The selected cells will be merged, and the text will be centered. 

To access more merge options  

Click the drop-down arrow next to the Merge & Center command on the Home tab. The Merge drop-down 

menu will appear. From here, you can choose to: 

Merge & Center: Merges the selected cells into one cell and centers the text 

Merge Across: Merges the selected cells into larger cells while keeping each row separate 

Merge Cells: Merges the selected cells into one cell, but does not center the text 

Unmerge Cells: Unmerges selected cells 

 



 

 

 

 

 

Formulas and Functions 

 

One of the most powerful features in Excel is the ability to calculate numerical information using formulas. 

 

 

Simple Formulas 

 

Just like a calculator, Excel can add, subtract, multiply, and divide. In this lesson, we'll show you how to use 

cell references to create simple formulas. 

Mathematical operators  

Excel uses standard operators for formulas, such as a plus sign for addition (+), a minus sign for subtraction (-), 

an asterisk for multiplication (*), a forward slash for division (/), and a caret (^) for exponents. 

 

 

 

All formulas in Excel must begin with an equals sign (=). This is because the cell contains, or is equal to, the 

formula and the value it calculates. 



 

 

 

 

Understanding cell references  

While you can create simple formulas in Excel manually (for example, =2+2 or =5*5), most of the time you will 

use cell addresses to create a formula. This is known as making a cell reference. Using cell references will 

ensure that your formulas are always accurate because you can change the value of referenced cells without 

having to rewrite the formula. 

 

 

 

By combining a mathematical operator with cell references, you can create a variety of simple formulas in 

Excel. Formulas can also include a combination of cell references and numbers, as in the examples below: 

 

  

 
 
 

 
The formula in cell A3 

refers to the value in cell A1 

plus the value in cell A2 

 

The formula calculates 

and displays the answer  

to the equation A1 plus A2 



 

 

 

 

To create a formula  

Select the cell that will contain the formula. 

Type the equals sign (=). Notice how it appears in both the cell and the formula bar. 

 

 

 

 

Type the cell address of the cell you wish to reference first in the formula: cell D1 in our example. A blue 

border will appear around the referenced cell. 

Type the mathematical operator you wish to use. In our example, we'll type the addition sign (+). 

Type the cell address of the cell you wish to reference second in the formula: cell D2 in our example. A red 

border will appear around the referenced cell. 

 

 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell. 

 TIP: If the result of a formula is too  large to  be displayed  in  a  cell, it may appear as  pound  signs 

(#######) instead of a value. This means that the column is not wide enough to display the cell content. Simply 

increase the column width to show the cell content. 

 

 

Modifying values with cell references  

The true advantage of cell references is that they allow you to update data in your worksheet without having to 

rewrite formulas. 

 TIP: Excel will not always tell you if your formula contains an error, so it's up to you to check all of your 

formulas. 

 
 
 

 
Formula will appear in 

both the cell and the 

formula bar. 



 

 

 

 

To create a formula using the point-and-click method  

Rather than typing cell addresses manually, you can point and click on the cells you wish to include in your 

formula. This method can save a lot of time and effort when creating formulas. In our example below, we'll 

create a formula to calculate the cost of ordering several boxes of plastic silverware. 

Select the cell that will contain the formula. In our example, we'll select cell D3. 

 

 

 

Type the equals sign (=). 

Select the cell you wish to reference first in the formula: cell B3 in our example. The cell address will appear in 

the formula, and a dashed blue line will appear around the referenced cell. 

 

 

 

Type the mathematical operator you wish to use. In our example, we'll type the multiplication sign (*). 

Select the cell you wish to reference second in the formula: cell C3 in our example. The cell address will appear 

in the formula, and a dashed red line will appear around the referenced cell. 



 

 

 

 

 
 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell. 

 

 

 

Formulas can also be copied to adjacent cells with the fill handle, which can save a lot of time and effort if you 

need to perform the same calculation multiple times in a worksheet. 

To edit a formula  

Sometimes you may want to modify an existing formula. In the example below, we've entered an incorrect cell 

address in our formula, so we'll need to correct it. 

Select the cell containing the formula you wish to edit. 

Click the formula bar to edit the formula. You can also double-click the cell to view and edit the formula 

directly within the cell. 

A border will appear around any referenced cells. 

 

When finished, press Enter on your keyboard or select the Enter command in the formula bar. 

The formula will be updated, and the new value will be displayed in the cell. 

 TIP: If you change your mind, you can press the Esc key on your keyboard or click the Cancel command

 in the formula bar to avoid accidentally making changes to your formula. 



 

 

 

 

 TIP: To show all of the formulas in a spreadsheet, you can hold the Ctrl key and press ` (grave accent). The 

grave accent key is usually located in the upper-left corner of the keyboard. You can press Ctrl+` again to 

switch back to the normal view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

Unit-IV 

 

Complex Formulas 

 

A simple formula is a mathematical expression with one operator, such as 7+9. A complex formula has more 

than one mathematical operator, such as 5+2*8. When there is more than one operation in a formula, the order 

of operations tells Excel which operation to calculate first. In order to use Excel to calculate complex formulas, 

you will need to understand the order of operations. 

Order of operations  

Excel calculates formulas based on the following order of operations: 

Operations enclosed in parentheses 

Exponential calculations (3^2, for example) 

Multiplication and division, whichever comes first 

Addition and subtraction, whichever comes first 

 

 

Creating complex formulas  

In the example below, we will demonstrate how Excel solves a complex formula using the order of operations. 

Here, we want to calculate the cost of sales tax for an invoice. To do this, we'll write our formula as 

=(D2+D3)*0.075 in cell D4. This formula will add the prices of our items together and then multiply that value 

by the 7.5% tax rate (which is written as 0.075) to calculate the cost of sales tax. 



 

 

 

 

 
 

 

 TIP: It is especially important to enter complex formulas with the correct order of operations. Otherwise, 

Excel will not calculate the results accurately. In our example, if the parentheses are not included, the 

multiplication is calculated first and the result is incorrect. Parentheses are the best way to define which 

calculations will be performed first in Excel. 

 

 

Relative and Absolute Cell References 

 

There are two types of cell references: relative and absolute. Relative and absolute references behave differently 

when copied and filled to other cells. Relative references change when a formula is copied to another cell. 

Absolute references, on the other hand, remain constant, no matter where they are copied. 

 

 

Relative cell references 

 

By default, all cell references are relative references. When copied across multiple cells, they change based on 

the relative position of rows and columns. For example, if you copy the formula =A1+B1 from row 1 to row 2, 

the formula will become =A2+B2. Relative references are especially convenient whenever you need to repeat 

the same calculation across multiple rows or columns. 

 

 

To create and copy a formula using relative references  

In the following example, we want to create a formula that will multiply each item's price by the quantity. 

Rather than creating a new formula for each row, we can create a single formula in cell D2 and then copy 



 

 

 

 

it to the other rows. We'll use relative references so the formula correctly calculates the total for each item. 

Select the cell that will contain the formula. In our example, we'll select cell D2. 

Enter the formula to calculate the desired value. In our example, we'll type =B2*C2. 

 

 

 

 

 

Press Enter on your keyboard. The formula will be calculated, and the result will be displayed in the cell. 

Locate the fill handle in the lower-right corner of the desired cell. In our example, we'll locate the fill handle for 

cell D2. 

 

 

 

 

The fill handle 



 

 

 

 

 

 

Click, hold, and drag the fill handle over the cells you wish to fill. 

 

 

 

 

 

Release the mouse. The formula will be copied to the selected cells with relative references, and the values will 

be calculated in each cell. 

 

 

 TIP: You can double-click the filled cells to check their formulas for accuracy. The relative cell references 

should be different for each cell, depending on their rows. 

 

 

 

Click, hold and drag the fill handle to 

copy the formula to adjacent cells 



 

 

 

 

Absolute cell references 

 

There may be times when you do not want a cell reference to change when filling cells. Unlike relative 

references, absolute references do not change when copied or filled. You can use an absolute reference to keep a 

row and/or column constant. 

An absolute reference is designated in a formula by the addition of a dollar sign ($). It can precede the column 

reference, the row reference, or both. 

 

You will generally use the $A$2 format when creating formulas that contain absolute references. The other two 

formats are used much less frequently. 

 TIP: When writing a formula, you can press the F4 key on your keyboard to switch between relative and 

absolute cell references. This is an easy way to quickly insert an absolute reference. 

 

 

To create and copy a formula using absolute references  

In our example, we'll use the 7.5% sales tax rate in cell E1 to calculate the sales tax for all items in column 

D. We'll need to use the absolute cell reference $E$1 in our formula. Since each formula is using the same tax 

rate, we want that reference to remain constant when the formula is copied and filled to other cells in column D. 

Select the cell that will contain the formula. In our example, we'll select cell D3. 

Enter the formula to calculate the desired value. In our example, we'll type =(B3*C3)*$E$1. 

Press Enter on your keyboard. The formula will calculate, and the result will display in the cell. 



 

 

 

 

 

 
 

 

Locate the fill handle in the lower-right corner of the desired cell. 

Release the mouse. The formula will be copied to the selected cells with an absolute reference, and the values 

will be calculated in each cell. 

Challenge! 

Open an existing Excel workbook. 

Create a formula that uses a relative reference. Double-click a cell to see the copied formula and the relative cell 

references. 

Create a formula that uses an absolute reference. 

 

Functions 

 

A function is a predefined formula that performs calculations using specific values in a particular order. Excel 

includes many common functions that can be useful for quickly finding the sum, average, count, maximum 

value, and minimum value for a range of cells. In order to use functions correctly, you'll need to understand the 

different parts of a function and how to create arguments to calculate values and cell references. 

 

 

 

 

The parts of a function  

Formula =A1+A2+A3+A4+A5+A6+A7+A8 

Function =SUM(A1:A8) 

 

In order to work correctly, a function must be written a specific way, which is called the syntax. The basic 

syntax for a function is an equals sign (=), the function name (SUM, for example), and one or more arguments. 

Arguments contain the information you want to calculate. 



 

 

 

 

 

 

 
 

Working with arguments  

Arguments can refer to both individual cells and cell ranges and must be enclosed within parentheses. You can 

include one argument or multiple arguments, depending on the syntax required for the function. 

 

 

For example, the function =AVERAGE(B1:B9) would calculate the average of the values in the cell range 

B1:B9. This function contains only one argument. 

 

 

Multiple arguments must be separated by a comma. For example, the function =SUM(A1:A3, C1:C2, E2) will 

add the values of all the cells in the three arguments. 

=SUM(A1:A20) 

Equal sign Argument 

Function name 



 

 

 

 

 

 
 

Creating a function 

 

Excel has a variety of functions available. Here are some of the most common functions you'll use: 

SUM: This function adds all of the values of the cells in the argument. 

AVERAGE: This function determines the average of the values included in the argument. It calculates the sum 

of the cells and then divides that value by the number of cells in the argument. 

COUNT: This function counts the number of cells with numerical data in the argument. This function is useful 

for quickly counting items in a cell range. 

MAX: This function determines the highest cell value included in the argument. 

MIN: This function determines the lowest cell value included in the argument. 

 

 

To create a basic function  

In our example below, we'll create a basic function to calculate the average price per unit for a list of recently 

ordered items using the AVERAGE function. 

Select the cell that will contain the function. 

Type the equals sign (=) and enter the desired function name. You can also select the desired function from the 

list of suggested functions that will appear below the cell as you type. In our example, we'll type =AVERAGE. 



 

 

 

 

 
 

Enter the cell range for the argument inside parentheses. In our example, we'll type (D3:D12). 

Press Enter on your keyboard. The function will be calculated, and the result will appear in the cell. 

 

 

To create a function using the AutoSum command  

The AutoSum command allows you to automatically insert the most common functions into your formula, 

including SUM, AVERAGE, COUNT, MIN, and MAX. In our example below, we'll create a function to 

calculate the total cost for a list of recently ordered items using the SUM function. 

Select the cell that will contain the function. 

In the Editing group on the Home tab, locate and select the arrow next to the AutoSum command and then 

choose the desired function from the drop-down menu. In our example, we'll select Sum. 

 



 

 

 

 

The selected function will appear in the cell. If logically placed, the AutoSum command will automatically 

select a cell range for the argument. You can also manually enter the desired cell range into the argument. 

 

 

Press Enter on your keyboard. 

 

 

The Function Library 

 

While there are hundreds of functions in Excel, the ones you use most frequently will depend on the type of data 

your workbooks contains. There is no need to learn every single function, but exploring some of the different 

types of functions will be helpful as you create new projects. You can search for functions by category, such as 

Financial, Logical, Text, Date & Time, and more from the Function Library on the Formulas tab. 

 To access the Function Library, select the Formulas tab on the Ribbon. The Function Library will appear. 

 

 



 

 

 

 

 
 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. 

The AutoSum command allows you to automatically return results for common functions, like SUM, 

AVERAGE, and COUNT. 

The Recently Used command gives you access to functions that you have recently worked with. 

The Financial category contains functions for financial calculations like determining a payment (PMT) or 

interest rate for a loan (RATE). 

Functions in the Logical category check arguments for a value or condition. For example, if an order is over 

$50 add $4.99 for shipping, but if it is over $100, do not charge for shipping (IF). 

The Text category contains functions that work with the text in arguments to perform tasks, such as converting 

text to lowercase (LOWER) or replacing text (REPLACE). 

The Date & Time category contains functions for working with dates and time and will return results like the 

current date and time (NOW) or the seconds (SECOND). 

The Lookup & Reference category contains functions that will return results for finding and referencing 

information. For example, you can add a hyperlink (HYPERLINK) to a cell or return the value of a particular 

row and column intersection (INDEX). 

The Math & Trig category includes functions for numerical arguments. For example, you can round values 

(ROUND), find the value of Pi (PI) multiply (PRODUCT), subtotal (SUBTOTAL), and much more. 

More Functions contains additional functions under categories for Statistical, Engineering, Cube, Information, 

and Compatibility. 

 

To insert a function from the Function Library  

 

Select the cell that will contain the function. 

 

Click the Formulas tab on the Ribbon to access the Function Library. 

 

From the Function Library group, select the desired function category. 

 

Select the desired function from the drop-down menu. 



 

 

 

 

 
 

 

 

The Function Arguments dialog box will appear. From here, you'll be able to enter or select the cells that will 

make up the arguments in the function. 

 

 

 

When you're satisfied with the arguments, click OK. 

 

The function will be calculated, and the result will appear in the cell. 



 

 

 

 

Like formulas, functions can be copied to adjacent cells. Hover the mouse over the cell that contains the 

function, then click, hold, and drag the fill handle over the cells you wish to fill. The function will be copied, 

and values for those cells will be calculated relative to their rows or columns. 

 

 

 

 

 

 

The Insert Function command 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. While it can be extremely useful, this command is sometimes a little difficult to use. 

If you don't have much experience with functions, you may have more success browsing the Function Library 

instead. For more advanced users, however, the Insert Function command can be a powerful way to find a 

function quickly. 

 

 

To use the Insert Function command  

Select the cell that will contain the function. 

Click the Formulas tab on the Ribbon, then select the Insert Function command. 

The Insert Function dialog box will appear. 

Type a few keywords describing the calculation you want the function to perform, then click Go. 

Review the results to find the desired function, then click OK. 



 

 

 

 

 
 

 

The Function Arguments dialog box will appear. 

When you're satisfied, click OK. 

The function will be calculated, and the result will appear in the cell. 

 

 



 

 

 

Unit-V 

 

 

SUM 

Formula: =SUM(5, 5) or =SUM(A1, B1) or =SUM(A1:B5) 

The SUM formula does exactly what you would expect. It allows you to add 2 or more numbers together. You 

can use cell references as well in this formula. 

 

 

COUNT 

Formula: =COUNT(A1:A10) 

The count formula counts the number of cells in a range that have numbers in them. 

 

 

It only counts the cells where there are numbers. 

 

 

COUNTA 

Formula: =COUNTA(A1:A10) 

Counts the number of non-empty cells in a range. It will count cells that have numbers and/or any other 

characters in them. 

The COUNTA Formula works with all data types. 



 

 

 

 

 
 

 

It counts the number of non-empty cells no matter the data type. 

LEN 

Formula: =LEN(A1) 

The LEN formula counts the number of characters in a cell. This includes spaces! 

 

Notice the difference in the formula results: 10 characters without spaces in between the words, 12 with spaces 

between the words. 

VLOOKUP 

Formula: =VLOOKUP(lookup_value, table_array, col_index_num, range_lookup) 

Basically, VLOOKUP lets you search for specific information in your spreadsheet. For example, if you have a 

list of products with prices, you could search for the price of a specific item. 

We’re going to use VLOOKUP to find the price of the Photo frame. You can probably already see that the price 

is $9.99, but that’s because this is a simple example. Once you learn how to use VLOOKUP, you’ll be able to 

use it with larger, more complex spreadsheets, and that’s when it will become truly useful. 



 

 

 

 

 
 

As with any formula, you’ll start with an equal sign (=). Then, type the formula name. 

=VLOOKUP(“Photo frame” 

The second argument is the cell range that contains the data. In this example, our data is in A2:B16. As with any 

function, you’ll need to use a comma to separate each argument: 

=VLOOKUP(“Photo frame”, A2:B16 

Note: It’s important to know that VLOOKUP will always search the first column in this range. In this example, 

it will search column A for “Photo frame”. In some cases, you may need to move the columns around so that the 

first column contains the correct data. 

The third argument is the column index number. It’s simpler than it sounds: The first column in the range is 1, 

the second column is 2, etc. In this case, we are trying to find the price of the item, and the prices are contained 

in the second column. That means our third argument will be 2: 

=VLOOKUP(“Photo frame”, A2:B16, 2 

The fourth argument tells VLOOKUP whether to look for approximate matches, and it can be either TRUE or 

FALSE. If it is TRUE, it will look for approximate matches. Generally, this is only useful if the first column has 

numerical values that have been sorted. Since we’re only looking for exact matches, the fourth argument should 

be FALSE. This is our last argument, so go ahead and close the parentheses: 

=VLOOKUP(“Photo frame”, A2:B16, 2, FALSE) 

And that’s it! When you press enter, it should give you the answer, which is 9.99. 



 

 

 

 

 
 

 

IF Statements 

Formula: =IF(logical_statement, return this if logical statement is true, return this if logical statement is false). 

Example 

Let’s say a salesperson has a quota to meet. You used VLOOKUP to put the revenue next to the name. Now you 

can use an IF statement that says: “IF the salesperson met their quota, say “Met quota”, if not say “Did not meet 

quota” 

=IF(C3>D3, “Met Quota”, “Did Not Meet Quota”) 

This IF statement will tell us if the first salesperson met their quota or not. We would then copy and paste this 

formula along all the entries in the list. It would change for each sales person. 

 

 



 

 

 

 

Working with Data 

 

Whenever you're working with a lot of data, it can be difficult to compare information in your workbook. 

Freezing Panes and View Options 

 

Excel includes several tools that make it easier to view content from different parts of your workbook at the 

same time, such as the ability to freeze panes and split your worksheet. 

To freeze rows  

You may want to see certain rows or columns all the time in your worksheet, especially header cells. By 

freezing rows or columns in place, you'll be able to scroll through your content while continuing to view the 

frozen cells. 

Select the row below the row(s) you wish to freeze. 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

 

 

 

The rows will be frozen in place, as indicated by the gray line. You can scroll down the worksheet while 

continuing to view the frozen rows at the top. 

To freeze columns  

Select the column to the right of the column(s) you wish to freeze. 



 

 

 

 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

The column will be frozen in place, as indicated by the gray line. You can scroll across the worksheet while 

continuing to view the frozen column on the left. 

To unfreeze rows or columns, click the Freeze Panes command, then select Unfreeze Panes from the drop-down 

menu. 

 

 

To split a worksheet  

Sometimes you may want to compare different sections of the same workbook without creating a new window. 

The Split command allows you to divide the worksheet into multiple panes that scroll separately. 

Select the cell where you wish to split the worksheet. 

Click the View tab on the Ribbon, then select the Split command. 

 

The workbook will be split into different panes. You can scroll through each pane separately using the scroll 

bars, allowing you to compare different sections of the workbook. 

To remove the split, click the Split command again. 

 

 

. 

 

Sorting Data 

 

As you add more content to a worksheet, organizing that information becomes especially important. You can 

quickly reorganize a worksheet by sorting your data. For example, you could organize a list of contact 

information by last name. Content can be sorted alphabetically, numerically, and in many other ways. 



 

 

 

 

When sorting data, it's important to first decide if you would like the sort to apply to the entire worksheet or just 

a cell range. 

Sort sheet organizes all of the data in your worksheet by one column. 

Sort range sorts the data in a range of cells, which can be helpful when working with a sheet that contains 

several tables. Sorting a range will not affect other content on the worksheet. 

 

To sort a sheet  

In our example, we'll sort a T-shirt order form alphabetically by Last Name (column C). 

Select a cell in the column you wish to sort by. In our example, we'll select cell C2. 

 

 

 

Select the Data tab on the Ribbon, then click the Ascending command  to Sort A to Z, or the Descending 

command  to Sort Z to A. In our example, we'll click the Ascending command. 

 

 

The worksheet will be sorted by the selected column. In our example, the worksheet is now sorted by last name. 



 

 

 

 

 
 

 

Filtering Data 

 

If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters can be used to 

narrow down the data in your worksheet, allowing you to view only the information you need. 

To filter data  

In order for filtering to work correctly, your worksheet should include a header row, which is used to identify 

the name of each column. 

Select the Data tab, then click the Filter command. 

 

 

A drop-down arrow will appear in the header cell for each column. 

Click the drop-down arrow for the column you wish to filter. 



 

 

 

 

The Filter menu will appear. 

Uncheck the box next to Select All to quickly deselect all data. 

Check the boxes next to the data you wish to filter, then click OK. 

To remove all filters from your worksheet, click the Filter command on the Data tab. 

 

 

Working with Charts 

 

Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart types that you can 

choose from when you create a chart. Excel offers Pie, Line, Bar, and Column charts to name but a few. 

Showing data in a chart can make it clearer, more interesting and easier to read. Charts can also help you 

evaluate your data and make comparisons between different values. 

 

 

Understanding charts 

 

Excel has several different types of charts, allowing you to choose the one that best fits your data. In order to 

use charts effectively, you'll need to understand how different charts are used. 

Types of Charts: 

Column charts use vertical bars to represent data. They can work with many different types of data, but they're 

most frequently used for comparing information. 

Line charts are ideal for showing trends. The data points are connected with lines, making it easy to see whether 

values are increasing or decreasing over time. 

Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so it's easy to see 

which values make up the percentage of a whole. 

Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars. 

Area charts are similar to line charts, except that the areas under the lines are filled in. 

Surface charts allow you to display data across a 3D landscape. They work best with large data sets, allowing 

you to see a variety of information at the same time. 

 

 

To insert a chart  

  

Select the cells you want to chart, including the column titles and row labels. These cells will be the source data 

for the chart. 



 

 

 

 

From the Insert tab, click the desired Chart command. 

Choose the desired chart type from the drop-down menu. 

 

 

 

 

The selected chart will be inserted in the worksheet. 

 TIP: If you're not sure which type of chart to use, the Recommended Charts command will suggest several 

different charts based on the source data. 

 

 

 

Chart layout and style 

 

After inserting a chart, there are several things you may want to change about the way your data is displayed. 

It's easy to edit a chart's layout and style from the Design tab. 

Excel allows you to add chart elements—such as chart titles, legends, and data labels—to make your chart 

easier to read. To add a chart element, click the Add Chart Element command on the Design tab, then choose 

the desired element from the drop-down menu. 



 

 

 

 

 
 

 

To edit a chart element, like a chart title, simply double-click the placeholder and begin typing. 

 

 

If you don't want to add chart elements individually, you can use one of Excel's predefined layouts. Simply click 

the Quick Layout command, then choose the desired layout from the drop-down menu. 

Excel also includes several different chart styles, which allow you to quickly modify the look and feel of your 

chart. To change the chart style, select the desired style from the Chart styles group. 



 

 

 

 

 
 

 TIP: You can also use the chart formatting shortcut buttons to quickly add chart elements, change the chart 

style, and filter the chart data. 

 

 

 

 

Other chart options 

 

There are lots of other ways to customize and organize your charts. For example, Excel allows you to rearrange 

a chart's data, change the chart type, and even move the chart to a different location in the workbook. 

To switch row and column data  

Sometimes you may want to change the way charts group your data. For example, in the chart below, the Book 

Sales data are grouped by year, with columns for each genre. However, we could switch the rows and columns 

so the chart will group the data by genre, with columns for each year. In both cases, the chart contains the same 

data—it's just organized differently. 

Select the chart you wish to modify. 



 

 

 

 

From the Design tab, select the Switch Row/Column command. 

 

The rows and columns will be switched. 

 

 

To change the chart type  

If you find that your data isn't well suited to a certain chart, it's easy to switch to a new chart type. In our 

example, we'll change our chart from a Column chart to a Line chart. 

From the Design tab, click the Change Chart Type command. 

 

The Change Chart Type dialog box will appear. 

The selected chart type will appear. 

 

 

To move a chart  

Whenever you insert a new chart, it will appear as an object on the same worksheet that contains its source data. 

Alternatively, you can move the chart to a new worksheet to help keep your data organized. 

Select the chart you wish to move. 

Click the Design tab, then select the Move Chart command. 

 



 

 

 

 

The Move Chart dialog box will appear. Select the desired location for the chart. 

Click OK. 

The chart will appear in the selected location. 

 

 

Challenge! 

Open an existing Excel workbook. 

Use worksheet data to create a chart. 

Change the chart layout. 

Apply a chart style. 

Move the chart. 

 

 

Printing Workbooks 

 

There may be times when you want to print a workbook to view and share your data offline. Once you've 

chosen your page layout settings, it's easy to preview and print a workbook from Excel using the Print pane. 

 

 

To access the Print pane  

Select the File tab. Backstage view will appear. 

 

 

 

 

 

Select Print. The Print pane will appear. 



 

 

 

 

 

 

Here you can choose how many copies of the workbook you wish to print. 

 

 

When you are ready to print the workbook, click the Print button. 

 

You may need to select the printer you want to use if your computer is connected to multiple printers. 

 

 

 

 

 

Here you can choose to print the active sheets, the entire workbook, or a selection of 

 

 

 

 

If you are printing multiple copies, you 

can choose whether you want the 

copies collated or uncollated. 

Here you can choose whether to print on 

one side or both sides of the paper. 

 

 

 

If your printer uses different paper sizes, 

you can choose the paper size you wish 

to use. 

 

 

Here you can choose how to scale your 

worksheets for the printed page. You can 

scale worksheets at their actual size, fit 

the entire worksheet on one page, fit all 

columns on one page, or fit all rows on 

one page. 

Here you can choose Portrait 

or Landscape orientation. 

 

 

 

Here you can adjust the page 

margins, which can help your data 

fit more comfortably on the page. 

 

 

 

Choosing a print area 

 

Before you print an Excel workbook, it's important to decide exactly what information you want to print. For 

example, if you have multiple worksheets in your workbook, you will need to decide if you want to print the 

entire workbook or only active worksheets. There may also be times when you want to print only a selection of 

content from your workbook. 



 

 

 

 

To print active sheets  

Worksheets are considered active when selected. 

Select the worksheet you want to print. To print multiple worksheets, click the first worksheet, hold the Ctrl key 

on your keyboard, then click any other worksheets you want to select. 

 

Navigate to the Print pane. 

Select Print Active Sheets from the Print Range drop-down menu. 

 

Click the Print button. 

 

 

 

 

 

To print the entire workbook  

Navigate to the Print pane. 

Select Print Entire Workbook from the Print Range drop-down menu. 



 

 

 

 

 
 

Click the Print button. 

 

 

 

To print a selection  

Select the cells you wish to print. 

Navigate to the Print pane. 

Select Print Selection from the Print Range drop-down menu. 

 

A preview of your selection will appear in the Preview pane. 

Click the Print button to print the selection. 



 

 

 

 

 
 

 TIP: If you prefer, you can also set the print area in advance so you'll be able to visualize which cells will be 

printed as you work in Excel. Simply select the cells you want to print, click the Page Layout tab, select the 

Print Area command, then choose Set Print Area. 

 

 

 

 

 

 

Fitting and scaling content 

 

On occasion, you may need to make small adjustments from the Print pane to fit your workbook content neatly 

onto a printed page. The Print pane includes several tools to help fit and scale your content, such as scaling and 

page margins. 

  



 

 

 

 

To fit content before printing  

If some of your content is being cut off by the printer, you can use scaling to fit your workbook to the page 

automatically. 

Navigate to the Print pane. 

Select the desired option from the Scaling drop-down menu. In our example, we'll select Fit Sheet on One Page. 

 

The worksheet will be condensed to fit onto a single page. 

When you're satisfied with the scaling, click Print. 

 

 

To modify margins in the Preview pane  

Sometimes you may only need to adjust a single margin to make your data fit more comfortably. You can 

modify individual page margins from the Preview pane. 

Navigate to the Print pane, then click the Show Margins button in the lower-right corner. 



 

 

 

 

 
The page margins will appear in the Preview pane. Hover the mouse over one of the margin 

markers until the cursor becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the margin width. 

Release the mouse. The margin will be modified. In our example, we were able to fit an additional column on 

the page. 

 

 

Show Margins 

button. 



 

 

 

Unit-1 

 

Opening Excel 

 

Using Windows 7  

 

Click on the Start Button. 

In the Search Program and Files box type Excel. 

Click on Excel 2013 from the Program results. 

The Microsoft Excel 2013 program will open. 

 

 

Using Windows 8   

 

Press the Windows key on the keyboard. 

Type Excel. 

Click on Excel 2013 under the Apps results. 

 

 

Using iOS 7  

 

Click on Launchpad. 

Select Microsoft Excel. 

 

 

Getting Started 

 

When you open Excel 2013 for the first time, the Excel Start Screen will appear. From here, you'll be able to 

create a new workbook, choose a template, and access your recently edited workbooks. 

 

From the Excel Start Screen, locate and select Blank workbook to access the Excel interface.  

Click Open Other Workbooks to work on an existing workbook. 



 

 

 

 

 
 

 

 

To set up Excel so it automatically opens a new workbook   

 

Click File then Options. 

On the General tab, under Start up options, uncheck the Show the Start screen when this application starts box.  

The next time you start Excel, it opens a blank workbook automatically similar to older versions of Excel. 

 

The Excel Interface 

 

After starting Excel, you will see two windows - one within the other. The outer window is the Application 

Window and the inner window is the Workbook Window. When maximized, the Excel Workbook Window 

blends in with the Application Window. 

 

After completing this module, you should be able to: 

 

Identify the components of the Application Window. 

Identify the components of the Workbook Window. 

Create a new workbook 

Open an existing workbook 



 

 

 

 

 
 

 

The Application Window 

 

The Application Window provides the space for your worksheets and workbook elements such as charts. The 

components of the Application Window are described below. 

 

The Quick Access Toolbar 

 

The Quick Access Toolbar lets you access common commands no matter which tab is selected.  

 

By default, it includes the Save, Undo, and Repeat commands. You can add other commands depending on your 

preference. 

 

To add commands to the Quick Access toolbar  

 

Click the drop-down arrow to the right of the Quick Access toolbar. 

Quick Access Toolbar 

The Ribbon 

Command Group 

Name Box Formula Bar 
Colum 

Cell 

Row 

Vertical and Horizontal Scroll Bars 

Worksheets 

Worksheet View Option Zoom Control 



 

 

 

 

Select the command you wish to add from the drop-down menu. To choose from more commands, select More 

Commands. 

 

 

 

 

The command will be added to the Quick Access toolbar. 

 

 

 

 

 

 

The Ribbon 

 

Excel 2013 uses a tabbed Ribbon system instead of traditional menus. The Ribbon contains multiple tabs, each 

with several groups of commands. You will use these tabs to perform the most common tasks in Excel.  



 

 

 

 

 

 
 

 

 

To minimize and maximize the Ribbon  

 

The Ribbon is designed to respond to your current task, but you can choose to minimize it if you find that it 

takes up too much screen space. 

 

Click the Ribbon Display Options arrow in the upper-right corner of the Ribbon. 

 

Click a tab to see 

more commands 

Each tab is divided 
into groups 



 

 

 

 

Select the desired minimizing option from the drop-down menu: 

 

Auto-hide Ribbon: Auto-hide displays your workbook in full-screen mode and completely hides the Ribbon. To 

show the Ribbon, click the Expand Ribbon command at the top of screen. 

 

 

Show Tabs: This option hides all command groups when not in use, but tabs will remain visible. To show the 

Ribbon, simply click a tab. 

 Show Tabs and Commands: This option maximizes the Ribbon. All of the tabs and commands will be visible. 

This option is selected by default when you open Excel for the first time. 

 

To Customize the Ribbon in Excel 2013  

 

You can customize the Ribbon by creating your own tabs with whichever commands you want. Commands are 

always housed within a group, and you can create as many groups as you want in order to keep your tab 

organized. If you want, you can even add commands to any of the default tabs, as long as you create a custom 

group in the tab. 

 

Right-click the Ribbon and then select Customize the Ribbon... from the drop-down menu. 

 

 

The Excel Options dialog box will appear. Locate and select New Tab. 

Ribbon is hidden and workbook 

appears in full screen 
Click the Expand Ribbon 

command to show the Ribbon 



 

 

 

 

 
 

Make sure the New Group is selected, select a command, and then click Add. You can also drag commands 

directly into a group. 

When you are done adding commands, click OK. The commands will be added to the Ribbon. 

 

 

Select 
commands and 

click Add 



 

 

 

Unit-II 

 

 

The Formula Bar 

 

In the formula bar, you can enter or edit data, a formula, or a function that will appear in a specific cell. 

 

In the image below, cell C1 is selected and 1984 is entered into the formula bar. Note how the data appears in 

both the formula bar and in cell C1. 

 

 

 

The Name Box 

 

The Name box displays the location, or "name" of a selected cell. 

 

In the image below, cell B4 is selected. Note that cell B4 is where column B and row 4 intersect.  

 

 

The Backstage View (The File Menu) 

 

Click the File tab on the Ribbon. Backstage view will appear. 

 

 



 

 

 

 

 

 

 
 

 

The Worksheet Views 

 

Excel 2013 has a variety of viewing options that change how your workbook is displayed. You can choose to 

view any workbook in Normal view, Page Layout view, or Page Break view. These views can be useful for 

various tasks, especially if you're planning to print the spreadsheet. 

 

To change worksheet views, locate and select the desired worksheet view command in the bottom-right corner 

of the Excel window. 

Return to Excel 
Info contains 

information about the 
current workbook. You 

can also inspect the 
workbook and set 

protection controls. 
New: you can create a new, blank 
workbook, or choose from a large 

selection of templates. 

Open: you can open 
recent workbooks, as 

well as workbooks saved 

to your OneDrive or on Use Save and Save As to save 

your computer. your workbook to your computer 

or to Office 365. 

From the Print pane, 
you can change the 

print settings and print 

your workbook. You 

can also see a preview 

of your workbook. 

Share: you can invite people to view and 
collaborate on your workbook. You can also share 

your workbook by emailing it as an attachment. 

Export: you can choose 
to export your 

workbook in another 
format, such as 

PDF/XPS or Excel 
1997-2003. 

Close the current workbook. 
 

From the Account pane, you can access your 
Microsoft account information, modify your theme 

and background, and sign out of your account. 

Options: you can change various Excel options. For 
example, you can control the Quick Analysis preferences, 

Auto Recover settings, or Language preferences. 



 

 

 

 

 
 

 

Zoom Control 

 

To use the Zoom control, click and drag the slider. The number to the right of the slider reflects the zoom 

percentage. 

 

 

Page Layout 

View 

Normal View Page Break 

View 



 

 

 

 

The Workbook Window 

 

In Excel 2013, when you open up a new workbook it now contains only 1 worksheet There can be a max of 

1,048,576 rows and 16,384 columns in an excel work sheet. 

 

The Worksheet 

 

Excel files are called workbooks. Each workbook holds one or more worksheets (also known as "spreadsheets").  

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. A worksheet is a grid 

of columns and rows where columns are designated by letters running across the top of the worksheet and rows 

are designated by numbers running down the left side of the worksheet. 

 

 

 

When working with a large amount of data, you can create multiple worksheets to help organize your workbook 

and make it easier to find content. You can also group worksheets to quickly add information to multiple 

worksheets at the same time. 

 

To rename a worksheet  

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. You can rename a 

worksheet to better reflect its content. In our example, we will create a training log organized by month.  

 

Right-click the worksheet you wish to rename, then select Rename from the worksheet menu. 



 

 

 

 

 
 

Type the desired name for the worksheet. 

 

 

Click anywhere outside of the worksheet, or press Enter on your keyboard. The worksheet will be renamed.  

 

 

To insert a new worksheet  

 

Locate and select the New sheet button. 

 

 

Click to add a 

new worksheet 



 

 

 

 

A new, blank worksheet will appear. 

 

 TIP: To change the default number of worksheets, navigate to Backstage view, click Options, and then 

choose the desired number of worksheets to include in each new workbook. 

 

 

 

To delete a worksheet  

 

Right-click the worksheet you wish to delete, then select Delete from the worksheet menu. 

 

 

The worksheet will be deleted from your workbook. 



 

 

 

 

 
 

 

 

Alternatively, from the Home Tab in the Cells Group click on Delete and select Delete Sheet. Warning: The 

Undo button will not undo the deletion of a worksheet. 

To copy a worksheet  

 

If you need to duplicate the content of one worksheet to another, Excel allows you to copy an existing 

worksheet. 

 

Right-click the worksheet you want to copy, then select Move or Copy from the worksheet menu. 

 

 

 

 

The Move or Copy dialog box will appear. Choose where the sheet will appear in the Before sheet: field. In our 

example, we'll choose (move to end) to place the worksheet to the right of the existing worksheet.  

Check the box next to Create a copy, then click OK. 



 

 

 

 

 
 

The worksheet will be copied. It will have the same title as the original worksheet, as well as a version number.  

 

TIP: You can also copy a worksheet to an entirely different workbook. You can select any workbook that is 

currently open from the To book: drop-down menu. 

 

 

To move a worksheet  

 

Sometimes you may want to move a worksheet to rearrange your workbook. 

 

Select the worksheet you wish to move. The cursor will become a small worksheet icon . 

Hold and drag the mouse until a small black arrow appears above the desired location. 



 

 

 

 

 
 

Release the mouse. The worksheet will be moved. 

 

To change the worksheet color  

 

You can change a worksheet's color to help organize your worksheets and make your workbook easier to 

navigate. 

 

Right-click the desired worksheet, and hover the mouse over Tab Color. The Color menu will appear.  

Select the desired color. A live preview of the new worksheet color will appear as you hover the mouse over 

different options. In our example, we'll choose Red. 

The worksheet color will be changed. 



 

 

 

 

The worksheet color is considerably less noticeable when the worksheet is selected. Select another worksheet to 

see how the color will appear when the worksheet is not selected. 

 

 

 

 

 

. 

 



 

 

 

 

The Scroll Bars 

 

Your spreadsheet may frequently have more data than you can see on the screen at once. Click, hold and drag 

the vertical or horizontal scroll bar depending on what part of the page you want to see. 

 

 

 

 

 

Creating and Opening Workbooks 

 

Excel files are called workbooks. Whenever you start a new project in Excel, you'll need to create a new 

workbook. There are several ways to start working with a workbook in Excel 2013. You can choose to create a 

new workbook—either with a blank workbook or a predesigned template—or open an existing workbook. 

 

Create a new blank workbook 

 

Select the File tab. Backstage view will appear. 

 

Vertical 

scroll bar 

Horizontal 

scroll bar 



 

 

 

 

Select New, then click Blank workbook. 

A new blank workbook will appear. 

 

Open an existing workbook 

 

In addition to creating new workbooks, you'll often need to open a workbook that was previously saved.  

Navigate to Backstage view, then click Open. 

 

 

 

 

Select Computer, and then click Browse. 

 



 

 

 

 

The Open dialog box will appear. Locate and select your workbook, then click Open. 

 

 

 

 TIP: If you've opened the desired workbook recently, you can browse your Recent Workbooks rather than 

searching for the file. 

 



 

 

 

 

To pin a workbook  

If you frequently work with the same workbook, you can pin it to Backstage view for quick access.  

Navigate to Backstage view and then click Open. Your recently edited workbooks will appear. 

Hover the mouse over the workbook you wish to pin. A pushpin icon will appear next to the workbook. Click 

the pushpin icon. 

 

 

The workbook will stay in Recent Workbooks. To unpin a workbook, simply click the pushpin icon again.  

 

 TIP: You can also pin folders to Backstage view for quick access. From Backstage view, click Open, then 

locate the folder you wish to pin and click the pushpin icon. 

 

 

Compatibility mode 

 

Sometimes you may need to work with workbooks that were created in earlier versions of Microsoft Excel, such 

as Excel 2003 or Excel 2000. When you open these kinds of workbooks, they will appear in Compatibility 

mode. 

 



 

 

 

 

Compatibility mode disables certain features, so you'll only be able to access commands found in the program 

that was used to create the workbook. For example, if you open a workbook created in Excel 2003, you can only 

use tabs and commands found in Excel 2003. 

In order to exit Compatibility mode, you'll need to convert the workbook to the current version type. However, 

if you're collaborating with others who only have access to an earlier version of Excel, it's best to leave the 

workbook in Compatibility mode so the format will not change. 

To convert a workbook  

If you want access to all of the Excel 2013 features, you can convert the workbook to the 2013 file format. Note 

that converting a file may cause some changes to the original layout of the workbook. 

Click the File tab to access Backstage view. 

Locate and select Convert command. 

 

 

 

 

The Save As dialog box will appear. Select the location where you wish to save the workbook, enter a file name 

for the presentation, and click Save. 

The workbook will be converted to the newest file type. 

 

 



 

 

 

 

Saving and Sharing Workbooks 

 

Whenever you create a new workbook in Excel, you'll need to know how to save it in order to access and edit it 

later. As with previous versions of Excel, you can save files locally to your computer. But unlike older versions, 

Excel 2013 also lets you save a workbook to the cloud using OneDrive. You can also export and share 

workbooks with others directly from Excel. 

 

Save and Save As 

 

Excel offers two ways to save a file: Save and Save As. These options work in similar ways, with a few 

important differences: 

Save: When you create or edit a workbook, you'll use the Save command to save your changes. You'll use this 

command most of the time. When you save a file, you'll only need to choose a file name and location the first 

time. After that, you can just click the Save command to save it with the same name and location. 

Save As: You'll use this command to create a copy of a workbook while keeping the original. When you use 

Save As, you'll need to choose a different name and/or location for the copied version. 

 

To save a workbook  

  

It's important to save your workbook whenever you start a new project or make changes to an existing one. 

Saving early and often can prevent your work from being lost. You'll also need to pay close attention to where 

you save the workbook so it will be easy to find later. 

 

Locate and select the Save command on the Quick Access Toolbar. 

 

 

If you're saving the file for the first time, the Save As pane will appear in Backstage view. 

You'll then need to choose where to save the file and give it a file name. To save the workbook to your 

computer, select Computer, then click Browse. Alternatively, you can click OneDrive to save the file to your 

OneDrive. 

The Save As dialog box will appear. Select the location where you wish to save the workbook. 



 

 

 

 

Enter a file name for the workbook, then click Save. 

 

 

 

The workbook will be saved. You can click the Save command again to save your changes as you modify the 

workbook. 

 

Using Save As to make a copy  

  

If you want to save a different version of a workbook while keeping the original, you can create a copy. For 

example, if you have a file named "Sales Data" you could save it as "Sales Data 2" so you'll be able to edit the 

new file and still refer back to the original version. 

To do this, you'll click the Save As command in Backstage view. Just like when saving a file for the first time, 

you'll need to choose where to save the file and give it a new file name. 

 

AutoRecover 

 

Excel automatically saves your workbooks to a temporary folder while you are working on them. If you forget 

to save your changes, or if Excel crashes, you can restore the file using AutoRecover.  

 

To use Auto Recover  

  

Open Excel 2013. If auto-saved versions of a file are found, the Document Recovery pane will appear. 

Choose a location, and 

then type the file name. 



 

 

 

 

Click to open an available file. The workbook will be recovered. 

 

 

 

 

 

 TIP: By default, Excel autosaves every 10 minutes. If you are editing a workbook for less than 10 minutes,  

Excel may not create an autosaved version. 

If you don't see the file you need, you can browse all autosaved files from Backstage view. Just select the File 

tab, click Manage Versions, and then choose Recover Unsaved Workbooks. 

 

 

Exporting workbooks 

 

By default, Excel workbooks are saved in the .xlsx file type. However, there may be times when you need to use 

another file type, such as a PDF or Excel 97-2003 workbook. It's easy to export your workbook from Excel in a 

variety of file types. 

To export a workbook as a PDF file  

Exporting your workbook as an Adobe Acrobat document, commonly known as a PDF file, can be especially 

useful if sharing a workbook with someone who does not have Excel. A PDF will make it possible for recipients 

to view, but not edit, the content of your workbook. 

Click the File tab to access Backstage view. 

Click Export, then select Create PDF/XPS. 



 

 

 

 

 
 

 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Publish. 

 

 TIP: By default, Excel will only export the active worksheet. If you have multiple worksheets and want to 

save all of them in the same PDF file, click Options in the Save as dialog box. The Options dialog box will 

appear. Select Entire workbook, then click OK. 

 

 

 

 

To export a workbook in other file types  

  

You may also find it helpful to export your workbook in other file types, such as an Excel 97-2003 Workbook if 

you need to share with people using an older version of Excel, or a .CSV file if you need a plain-text version of 

your workbook. 



 

 

 

 

Click the File tab to access Backstage view. 

Click Export, then select Change File Type. 

Select a common file type, then click Save As. 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Save. 

 

 

Challenge! 

Create a new blank workbook. 

Use the Save command to save the workbook to your desktop. 

Save the workbook to OneDrive and invite someone else to view it. 

Export the workbook as a PDF file. 

 

 

Cell Basics 

 

Whenever you work with Excel, you'll enter information, or content, into cells. Cells are the basic building 

blocks of a worksheet. You'll need to learn the basics of cells and cell content to calculate,  analyze, and organize 

data in Excel. 

 

 

Understanding Cells 

 

Every worksheet is made up of thousands of rectangles, which are called cells. A cell is the intersection of a row 

and a column. Columns are identified by letters (A, B, C), while rows are identified by numbers (1, 2, 3). 

 

Colum 

Row Cell 



 

 

 

 

Each cell has its own name, or cell address, based on its column and row. In this example, the selected cell 

intersects column C and row 5, so the cell address is C5. The cell address will also appear in the Name box. 

Note that a cell's column and row headings are highlighted when the cell is selected. 

 

 

 

 

You can also select multiple cells at the same time. A group of cells is known as a cell range. Rather than a 

single cell address, you will refer to a cell range using the cell addresses of the first and last cells in the cell 

range, separated by a colon. For example, a cell range that included cells A1, A2, A3, A4, and A5 would be 

written as A1:A5. 

 

In the images below, two different cell ranges are selected: 

 

Cell range A1:A8 

 

 

Cell range A1:B8 

Cell Address 



 

 

 

 

 
 

To select a cell range  

 

Sometimes you may want to select a larger group of cells, or a cell range. 

 

Click, hold, and drag the mouse until all of the adjoining cells you wish to select are highlighted. 

Release the mouse to select the desired cell range. The cells will remain selected until you click another cell in 

the worksheet. 

Cell Content 

 

Any information you enter into a spreadsheet will be stored in a cell. Each cell can contain several different 

kinds of content, including text, formatting, formulas, and functions. 

 

Text 

Cells can contain text, such as letters, numbers, and dates. 
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Formatting Attributes 

Cells can contain formatting attributes that change the way letters, numbers, and dates are displayed. For 

example, percentages can appear as 0.15 or 15%. You can even change a cell's background color.  

 

Formulas and Functions 

Cells can contain formulas and functions that calculate cell values. In our example, SUM(B4:B7) adds the value 

of each cell in cell range B4:B7 and displays the total in cell B8. 

 

 

To insert content  

Click a cell to select it. 

 

Type content into the selected cell, then press Enter on your keyboard. The content will appear in the cell and 

the formula bar. You can also input and edit cell content in the formula bar. 

 

 

 
 
 
 

Content appears in cell 

and formula bar 



 

 

 

 

To delete cell content  

Select the cell with content you wish to delete. 

Press the Delete or Backspace key on your keyboard. The cell's contents will be deleted. 

To delete cells  

There is an important difference between deleting the content of a cell and deleting the cell itself. If you delete 

the entire cell, the cells below it will shift up and replace the deleted cells. 

Select the cell(s) you wish to delete. 

Select the Delete command from the Home tab on the Ribbon. 

The cells below will shift up. 

 

 

 

 

To copy and paste cell content  

Excel allows you to copy content that is already entered into your spreadsheet and paste that content to other 

cells, which can save you time and effort. 

Select the cell(s) you wish to copy. 

Click the Copy command on the Home tab, or press Ctrl+C on your keyboard. 



 

 

 

 

 
 

 

Select the cell(s) where you wish to paste the content. The copied cells will now have a dashed box around 

them. 

Click the Paste command on the Home tab, or press Ctrl+V on your keyboard. 

The content will be pasted into the selected cells. 

 

 

To access more paste options  

You can also access additional paste options, which are especially convenient when working with cells that 

contain formulas or formatting. 

 To access more paste options, click the drop-down arrow on the Paste command. 

 



 

 

 

 

 TIP: Rather than choosing commands from the Ribbon, you can access commands quickly by right- clicking. 

Simply select the cell(s) you wish to format, then right-click the mouse. A drop-down menu will appear, where 

you'll find several commands that are also located on the Ribbon. 

 

 

To drag and drop cells  

Rather than cutting, copying, and pasting, you can drag and drop cells to move their contents.  

Select the cell(s) you wish to move. 

Hover the mouse over the border of the selected cell(s) until the cursor changes from a white cross to a black 

cross with four arrows. 

Click, hold, and drag the cells to the desired location. 

Release the mouse, and the cells will be dropped in the selected location. 

 

 

To use the fill handle  

There may be times when you need to copy the content of one cell to several other cells in your worksheet. You 

could copy and paste the content into each cell, but this method would be very time consuming. Instead, you can 

use the fill handle to quickly copy and paste content to adjacent cells in the same row or column. 

Select the cell(s) containing the content you wish to use. The fill handle will appear as a small square in the 

bottom-right corner of the selected cell(s). 



 

 

 

 

 
Click, hold, and drag the fill handle until all of the cells you wish to fill are selected. 

 

 

 

 

Release the mouse to fill the selected cells. 

 

To continue a series with the fill handle  

The fill handle can also be used to continue a series. Whenever the content of a row or column follows a 

sequential order, like numbers (1, 2, 3) or days (Monday, Tuesday, Wednesday), the fill handle can guess what 

should come next in the series. In many cases, you may need to select multiple cells before using the fill handle 

to help Excel determine the series order. In our example below, the fill handle is used to extend a series of dates 

in a column. 

The fill handle 



 

 

 

 

 

 

  
 

 

 

 

Find and Replace 

 

When working with a lot of data in Excel, it can be difficult and time consuming to locate specific information. 

You can easily search your workbook using the Find feature, which also allows you to modify content using the 

Replace feature. 

To find content  

From the Home tab, click the Find and Select command, then select Find... from the drop-down menu. 

 

 

 

 

 

 

 

 

 

 

The Find and Replace dialog box will appear. Enter the content you wish to find. 

Click Find Next. If the content is found, the cell containing that content will be selected. 



 

 

 

 

 
 

 

 

Click Find Next to find further instances or Find All to see every instance of the search term. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 TIP: You can also access the Find command by pressing Ctrl+F on your keyboard. 

 TIP: Click Options to see advanced search criteria in the Find and Replace dialog box. 

 

 

 

 

To replace cell content  

At times, you may discover that you've repeatedly made a mistake throughout your workbook (such as 

misspelling someone's name), or that you need to exchange a particular word or phrase for another. You can use 

Excel's Find and Replace feature to make quick revisions. 



 

 

 

 

From the Home tab, click the Find and Select command, then select Replace... from the drop- down menu. 

The Find and Replace dialog box will appear. Type the text you wish to find in the Find what: field.  

Type the text you wish to replace it with in the Replace with: field, then click Find Next. 

If the content is found, the cell containing that content will be selected. 

Review the text to make sure you want to replace it. 

If you wish to replace it, select one of the replace options: 

Replace will replace individual instances. 

Replace All will replace every instance of the text throughout the workbook. In our example, we'll choose this 

option to save time. 

A dialog box will appear, confirming the number of replacements made. Click OK to continue. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 

Formatting Cells 

 

All cell content uses the same formatting by default, which can make it difficult to read a workbook with a lot of 

information. Basic formatting can customize the look and feel of your workbook, allowing you to draw attention 

to specific sections and making your content easier to view and understand. You can also apply number 

formatting to tell Excel exactly what type of data you’re using in the workbook, such as percentages (%),  

currency ($), and so on. 



 

 

 

 

Font Formatting 

 

To change the font  

By default, the font of each new workbook is set to Calibri. However, Excel provides a variety of other fonts 

you can use to customize your cell text. In the example below, we'll format our title cell to help distinguish it 

from the rest of the worksheet. 

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font command on the Home tab. The Font drop-down menu will appear. 

Select the desired font. A live preview of the new font will appear as you hover the mouse over different 

options. 

 

 

 

The text will change to the selected font. 

 

 TIP: When creating a workbook in the workplace, you'll want to select a font that is easy to read. 

Along with Calibri, standard reading fonts include Cambria, Times New Roman, and Arial. 

To change the font size  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Size command on the Home tab. The Font Size drop- down menu 

will appear. 

Select the desired font size. A live preview of the new font size will appear as you hover the mouse over 

different options. 

The text will change to the selected font size. 

 TIP: You can also use the Increase Font Size and Decrease Font Size commands or enter a custom font size 

using your keyboard. 



 

 

 

 
 

To change the font color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Color command on the Home tab. The Color menu will appear.  

Select the desired font color. A live preview of the new font color will appear as you hover the mouse over 

different options. 

 

 

The text will change to the selected font color. 

 

 

To use the Bold, Italic, and Underline commands  

Select the cell(s) you wish to modify. 

Click the Bold (B), Italic (I), or Underline (U) command on the Home tab. In our example, we'll make the 

selected cells bold. 

Entering a custom 

font size 
Increase and 
Decrease Font 

Size commands 



 

 

 

 

 
 

 

The selected style will be applied to the text. 

 TIP: You can also press Ctrl+B on your keyboard to make selected text bold, Ctrl+I to apply italics,  and 

Ctrl+U to apply an underline. 

 

Text Alignment 

 

By default, any text entered into your worksheet will be aligned to the bottom-left of a cell. Any numbers will 

be aligned to the bottom-right of a cell. Changing the alignment of your cell content allows you to choose how 

the content is displayed in any cell, which can make your cell content easier to read. 

To change horizontal text alignment  

Select the cell(s) you wish to modify. 

Select one of the three horizontal alignment commands on the Home tab. In our example, we'll choose Center 

Align. 

 

The text will realign. 

To change vertical text alignment  

Select the cell(s) you wish to modify. 

Select one of the three vertical alignment commands on the Home tab. In our example, we'll choose Middle 

Align. 



 

 

 

 

 
 

The text will realign. 

 

 

Cell borders and fill colors 

 

Cell borders and fill colors allow you to create clear and defined boundaries for different sections of your 

worksheet. 

To add a border  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Borders command on the Home tab. The Borders drop- down menu will 

appear. 

 

 

Select the border style you want to use. 

The selected border style will appear. 

 TIP: You can draw borders and change the line style and color of borders with the Draw Borders tools at the 

bottom of the Borders drop-down menu. 



 

 

 

 

 
 

 

To add a fill color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Fill Color command on the Home tab. The Fill Color menu will appear. 

Select the fill color you want to use. A live preview of the new fill color will appear as you hover the mouse 

over different options. In our example, we'll choose Light Green. 

 

 

The selected fill color will appear in the selected cells. 



 

 

 

 

Cell styles 

 

Rather than formatting cells manually, you can use Excel's predesigned cell styles. Cell styles are a quick way to 

include professional formatting for different parts of your workbook, such as titles and headers.  

To apply a cell style  

Select the cell(s) you wish to modify. 

Click the Cell Styles command on the Home tab, then choose the desired style from the drop-down menu. 

 

 

The selected cell style will appear. 

 TIP: Applying a cell style will replace any existing cell formatting except for text alignment. You may not 

want to use cell styles if you've already added a lot of formatting to your workbook. 

 

Formatting text and numbers 

 

One of the most powerful tools in Excel is the ability to apply specific formatting for text and numbers. Instead 

of displaying all cell content in exactly the same way, you can use formatting to change the appearance of dates, 

times, decimals, percentages (%), currency ($), and much more. 

To apply number formatting  

Select the cells(s) you wish to modify. 

Click the drop-down arrow next to the Number Format command on the Home tab. The Number Formatting 

drop-down menu will appear. 

Select the desired formatting option. 

The selected cells will change to the new formatting style. 



 

 

 

General is the default format for any cell. 
When you enter a number into the cell, 

Excel will guess the number format that is 

most appropriate. 
Number formats numbers 

with decimal places. 

Currency formats numbers as currency 

with a currency symbol. 

Short Date formats numbers 

as M/D/YYYY. 

Accounting formats numbers as monetary 
values like the Currency format, but it also 

aligns currency symbols and decimal 

places within columns. 

Long Date formats numbers as 

Weekday, Month DD, YYYY. 

Time formats numbers as HH/MM/SS 
and notes AM or PM. 

Percentage formats numbers with 
decimal places and the percent sign. 

Fraction formats numbers as fractions 

separated by the forward slash. 

Scientific formats numbers 

in scientific notation. 

Text formats numbers as text, meaning 
that what you enter into the cell will 

appear exactly as it was entered. 

You can easily customize any format in 

More Number Formats. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Challenge! 

Open an existing Excel 2013 workbook. 

Select a cell and change the font style, size, and color of the text. 

Apply bold, italics, or underline to a cell. 

Try changing the vertical and horizontal text alignment for some cells. 

Add a border to a cell range. 

Change the fill color of a cell range. 

Try changing the formatting of a number. 



 

 

 

 

Modifying Columns, Rows and Cells 

 

By default, every row and column of a new workbook is always set to the same height and width. Excel allows 

you to modify column width and row height in different ways, including wrapping text and merging cells.  

 

 

To modify column width  

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

 

Click, hold, and drag the mouse to increase or decrease the column width. 

Release the mouse. The column width will be changed. 

 TIP: If you see pound signs (#######) in a cell, it means that the column is not wide enough to display the 

cell content. Simply increase the column width to show the cell content. 

 

 

To AutoFit column width  

The AutoFit feature will allow you to set a column's width to fit its content automatically. 

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

Double-click the mouse. The column width will be changed automatically to fit the content. 

 TIP: You can also AutoFit the width for several columns at the same time. Simply select the columns you 

would like to AutoFit, then select the AutoFit Column Width command from the Format drop- down menu on 

the Home tab. This method can also be used for Row height. 



 

 

 

 

 

 
To modify row height  

Position the cursor over the row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse. The height of the selected row will be changed. 

 

 

To modify all rows or columns  

Rather than resizing rows and columns individually, you can modify the height and width of every row and 

column at the same time. This method allows you to set a uniform size for every row and column in your 

worksheet. 

Locate and click the Select All button just below the formula bar to select every cell in the worksheet. 

 

 

 

 

 

 

 

 

 

 

Position the mouse over a row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse when you are satisfied with the new row height for the worksheet.  



 

 

 

 

Inserting, deleting, moving, and hiding rows and columns 

 

After you've been working with a workbook for a while, you may find that you want to insert new columns or 

rows, delete certain rows or columns, move them to a different location in the worksheet, or even hide them.  

To insert rows  

Select the row heading below where you want the new row to appear. 

Click the Insert command on the Home tab. 

 

The new row will appear above the selected row. 

 

 TIP: When inserting new rows, columns, or cells, you will see the Insert Options button next to the 

inserted cells. This button allows you to choose how Excel formats these cells. By default, Excel formats 

inserted rows with the same formatting as the cells in the row above. To access more options, hover your mouse 

over the Insert Options button, then click the drop-down arrow. 

 

 



 

 

 

 

To insert columns  

Select the column heading to the right of where you want the new column to appear.  

Click the Insert command on the Home tab. 

 

The new column will appear to the left of the selected column. 

 

 TIP: When inserting rows and columns, make sure you select the entire row or column by clicking the 

heading. If you select only a cell in the row or column, the Insert command will only insert a new cell.  

 

To delete rows  

It's easy to delete any row that you no longer need in your workbook. 

Select the row(s) you want to delete. 

Click the Delete command on the Home tab. 

 



 

 

 

 

The selected row(s) will be deleted, and the rows below will shift up. 

To delete columns  

Select the columns(s) you want to delete. 

Click the Delete command on the Home tab. 

 

 

 

 

 

 

 

The selected columns(s) will be deleted, and the columns to the right will shift left.  

 TIP: It's important to understand the difference between deleting a row or column and simply clearing its 

contents. If you want to remove the content of a row or column without causing others to shift, right-click a 

heading, then select Clear Contents from the drop-down menu. 

 

 



 

 

 

 

To move a row or column  

Sometimes you may want to move a column or row to rearrange the content of your worksheet. 

Select the desired column heading for the column you wish to move, then click the Cut command on the Home 

tab or press Ctrl+X on your keyboard. 

Select the column heading to the right of where you want to move the column. For example, if you want to 

move a column between columns B and C, select column C. 

Click the Insert command on the Home tab, then select Insert Cut Cells from the drop-down menu. 

 

The column will be moved to the selected location, and the columns to the right will shift right. 

 

 TIP: You can also access the Cut and Insert commands by right-clicking the mouse and then selecting the 

desired commands from the drop-down menu. 

 

 

To hide and unhide a row or column  

At times, you may want to compare certain rows or columns without changing the organization of your 

worksheet. Excel allows you to hide rows and columns as needed. 

Select the column(s) you wish to hide, right-click the mouse, then select Hide from the formatting menu. 



 

 

 

 

The columns will be hidden. The green column line indicates the location of the hidden columns. 

 

 

 

 

To unhide the columns, select the columns to the left and right of the hidden columns (in other words, the 

columns on both sides of the hidden columns). 

Right-click the mouse, then select Unhide from the formatting menu. The hidden columns will reappear.  

 

 

Wrapping text and merging cells 

 

Whenever you have too much cell content to be displayed in a single cell, you may decide to wrap the text or 

merge the cell rather than resizing a column. Wrapping the text will automatically modify a cell's row height, 

allowing cell contents to be displayed on multiple lines. Merging allows you to combine a cell with adjacent, 

empty cells to create one large cell. 

Select the cells you wish to wrap. 

Select the Wrap Text command on the Home tab. 

 

Green 

column line 



 

 

 

 

The text in the selected cells will be wrapped. 

 TIP: Click the Wrap Text command again to unwrap the text. 

 

 

To merge cells using the Merge & Center command  

Select the cell range you want to merge together. 

Select the Merge & Center command on the Home tab. 

 

 

 

The selected cells will be merged, and the text will be centered. 

To access more merge options  

Click the drop-down arrow next to the Merge & Center command on the Home tab. The Merge drop-down 

menu will appear. From here, you can choose to: 

Merge & Center: Merges the selected cells into one cell and centers the text 

Merge Across: Merges the selected cells into larger cells while keeping each row separate 

Merge Cells: Merges the selected cells into one cell, but does not center the text 

Unmerge Cells: Unmerges selected cells 

 



 

 

 

 

 

Formulas and Functions 

 

One of the most powerful features in Excel is the ability to calculate numerical information using formulas. 

 

 

Simple Formulas 

 

Just like a calculator, Excel can add, subtract, multiply, and divide. In this lesson, we'll show you how to use 

cell references to create simple formulas. 

Mathematical operators  

Excel uses standard operators for formulas, such as a plus sign for addition (+), a minus sign for subtraction ( -), 

an asterisk for multiplication (*), a forward slash for division (/), and a caret (^) for exponents. 

 

 

 

All formulas in Excel must begin with an equals sign (=). This is because the cell contains, or is equal to, the 

formula and the value it calculates. 



 

 

 

 

Understanding cell references  

While you can create simple formulas in Excel manually (for example, =2+2 or =5*5), most of the time you will 

use cell addresses to create a formula. This is known as making a cell reference. Using cell references will 

ensure that your formulas are always accurate because you can change the value of referenced cells without 

having to rewrite the formula. 

 

 

 

By combining a mathematical operator with cell references, you can create a variety of simple formulas in 

Excel. Formulas can also include a combination of cell references and numbers, as in the examples below: 

 

  

 
 
 

 
The formula in cell A3 

refers to the value in cell A1 

plus the value in cell A2 

 

The formula calculates 

and displays the answer  

to the equation A1 plus A2 



 

 

 

 

To create a formula  

Select the cell that will contain the formula. 

Type the equals sign (=). Notice how it appears in both the cell and the formula bar. 

 

 

 

 

Type the cell address of the cell you wish to reference first in the formula: cell D1 in our example.  A blue 

border will appear around the referenced cell. 

Type the mathematical operator you wish to use. In our example, we'll type the addition sign (+).  

Type the cell address of the cell you wish to reference second in the formula: cell D2 in our example. A red 

border will appear around the referenced cell. 

 

 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell.  

 TIP: If the result of a formula is too  large to  be displayed  in  a  cell, it may appear as  pound  signs 

(#######) instead of a value. This means that the column is not wide enough to display the cell content. Simply 

increase the column width to show the cell content. 

 

 

Modifying values with cell references  

The true advantage of cell references is that they allow you to update data in your worksheet without having to 

rewrite formulas. 

 TIP: Excel will not always tell you if your formula contains an error, so it's up to you to check all of your 

formulas. 

 
 
 

 
Formula will appear in 

both the cell and the 

formula bar. 



 

 

 

 

To create a formula using the point-and-click method  

Rather than typing cell addresses manually, you can point and click on the cells you wish to include in your 

formula. This method can save a lot of time and effort when creating formulas. In our example below, we'll 

create a formula to calculate the cost of ordering several boxes of plastic silverware. 

Select the cell that will contain the formula. In our example, we'll select cell D3. 

 

 

 

Type the equals sign (=). 

Select the cell you wish to reference first in the formula: cell B3 in our example. The cell address will appear in 

the formula, and a dashed blue line will appear around the referenced cell. 

 

 

 

Type the mathematical operator you wish to use. In our example, we'll type the multiplication sign (*).  

Select the cell you wish to reference second in the formula: cell C3 in our example. The cell address will appear 

in the formula, and a dashed red line will appear around the referenced cell. 



 

 

 

 

 
 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell. 

 

 

 

Formulas can also be copied to adjacent cells with the fill handle, which can save a lot of time and effort if you 

need to perform the same calculation multiple times in a worksheet. 

To edit a formula  

Sometimes you may want to modify an existing formula. In the example below, we've entered an incorrect cell 

address in our formula, so we'll need to correct it. 

Select the cell containing the formula you wish to edit. 

Click the formula bar to edit the formula. You can also double-click the cell to view and edit the formula 

directly within the cell. 

A border will appear around any referenced cells. 

 

When finished, press Enter on your keyboard or select the Enter command in the formula bar. 

The formula will be updated, and the new value will be displayed in the cell. 

 TIP: If you change your mind, you can press the Esc key on your keyboard or click the Cancel command

 in the formula bar to avoid accidentally making changes to your formula. 



 

 

 

 

 TIP: To show all of the formulas in a spreadsheet, you can hold the Ctrl key and press ` (grave accent). The 

grave accent key is usually located in the upper-left corner of the keyboard. You can press Ctrl+` again to 

switch back to the normal view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

Unit-IV 

 

Complex Formulas 

 

A simple formula is a mathematical expression with one operator, such as 7+9. A complex formula has more 

than one mathematical operator, such as 5+2*8. When there is more than one operation in a formula, the order 

of operations tells Excel which operation to calculate first. In order to use Excel to calculate complex formulas, 

you will need to understand the order of operations. 

Order of operations  

Excel calculates formulas based on the following order of operations: 

Operations enclosed in parentheses 

Exponential calculations (3^2, for example) 

Multiplication and division, whichever comes first 

Addition and subtraction, whichever comes first 

 

 

Creating complex formulas  

In the example below, we will demonstrate how Excel solves a complex formula using the order of operations. 

Here, we want to calculate the cost of sales tax for an invoice. To do this, we'll write our formula as 

=(D2+D3)*0.075 in cell D4. This formula will add the prices of our items together and then multiply that value 

by the 7.5% tax rate (which is written as 0.075) to calculate the cost of sales tax. 



 

 

 

 

 
 

 

 TIP: It is especially important to enter complex formulas with the correct order of operations. Otherwise, 

Excel will not calculate the results accurately. In our example, if the parentheses are not included, the 

multiplication is calculated first and the result is incorrect. Parentheses are the best way to define which 

calculations will be performed first in Excel. 

 

 

Relative and Absolute Cell References 

 

There are two types of cell references: relative and absolute. Relative and absolute references behave differently 

when copied and filled to other cells. Relative references change when a formula is copied to another cell. 

Absolute references, on the other hand, remain constant, no matter where they are copied. 

 

 

Relative cell references 

 

By default, all cell references are relative references. When copied across multiple cells, they change based on 

the relative position of rows and columns. For example, if you copy the formula =A1+B1 from row 1 to row 2, 

the formula will become =A2+B2. Relative references are especially convenient whenever you need to repeat 

the same calculation across multiple rows or columns. 

 

 

To create and copy a formula using relative references  

In the following example, we want to create a formula that will multiply each item's price by the quantity. 

Rather than creating a new formula for each row, we can create a single formula in cell D2 and then copy 



 

 

 

 

it to the other rows. We'll use relative references so the formula correctly calculates the total for each item. 

Select the cell that will contain the formula. In our example, we'll select cell D2. 

Enter the formula to calculate the desired value. In our example, we'll type =B2*C2. 

 

 

 

 

 

Press Enter on your keyboard. The formula will be calculated, and the result will be displayed in the cell.  

Locate the fill handle in the lower-right corner of the desired cell. In our example, we'll locate the fill handle for 

cell D2. 

 

 

 

 

The fill handle 



 

 

 

 

 

 

Click, hold, and drag the fill handle over the cells you wish to fill. 

 

 

 

 

 

Release the mouse. The formula will be copied to the selected cells with relative references, and the values will 

be calculated in each cell. 

 

 

 TIP: You can double-click the filled cells to check their formulas for accuracy. The relative cell references 

should be different for each cell, depending on their rows. 

 

 

 

Click, hold and drag the fill handle to 

copy the formula to adjacent cells 



 

 

 

 

Absolute cell references 

 

There may be times when you do not want a cell reference to change when filling cells. Unlike relative 

references, absolute references do not change when copied or filled. You can use an absolute reference to keep a 

row and/or column constant. 

An absolute reference is designated in a formula by the addition of a dollar sign ($). It can precede the column 

reference, the row reference, or both. 

 

You will generally use the $A$2 format when creating formulas that contain absolute references. The other two 

formats are used much less frequently. 

 TIP: When writing a formula, you can press the F4 key on your keyboard to switch between relative and 

absolute cell references. This is an easy way to quickly insert an absolute reference. 

 

 

To create and copy a formula using absolute references  

In our example, we'll use the 7.5% sales tax rate in cell E1 to calculate the sales tax for all items in column 

D. We'll need to use the absolute cell reference $E$1 in our formula. Since each formula is using the same tax 

rate, we want that reference to remain constant when the formula is copied and filled to other cells in column D.  

Select the cell that will contain the formula. In our example, we'll select cell D3. 

Enter the formula to calculate the desired value. In our example, we'll type =(B3*C3)*$E$1. 

Press Enter on your keyboard. The formula will calculate, and the result will display in the cell.  



 

 

 

 

 

 
 

 

Locate the fill handle in the lower-right corner of the desired cell. 

Release the mouse. The formula will be copied to the selected cells with an absolute reference, and the values 

will be calculated in each cell. 

Challenge! 

Open an existing Excel workbook. 

Create a formula that uses a relative reference. Double-click a cell to see the copied formula and the relative cell 

references. 

Create a formula that uses an absolute reference. 

 

Functions 

 

A function is a predefined formula that performs calculations using specific values in a particular order. Excel 

includes many common functions that can be useful for quickly finding the sum, average, count, maximum 

value, and minimum value for a range of cells. In order to use functions correctly, you'll need to understand the 

different parts of a function and how to create arguments to calculate values and cell references.  

 

 

 

 

The parts of a function  

Formula =A1+A2+A3+A4+A5+A6+A7+A8 

Function =SUM(A1:A8) 

 

In order to work correctly, a function must be written a specific way, which is called the syntax. The basic 

syntax for a function is an equals sign (=), the function name (SUM, for example), and one or more arguments. 

Arguments contain the information you want to calculate. 



 

 

 

 

 

 

 
 

Working with arguments  

Arguments can refer to both individual cells and cell ranges and must be enclosed within parentheses. You can 

include one argument or multiple arguments, depending on the syntax required for the function. 

 

 

For example, the function =AVERAGE(B1:B9) would calculate the average of the values in the cell range 

B1:B9. This function contains only one argument. 

 

 

Multiple arguments must be separated by a comma. For example, the function =SUM(A1:A3, C1:C2, E2) will 

add the values of all the cells in the three arguments. 

=SUM(A1:A20) 

Equal sign Argument 

Function name 



 

 

 

 

 

 
 

Creating a function 

 

Excel has a variety of functions available. Here are some of the most common functions you'll use:  

SUM: This function adds all of the values of the cells in the argument. 

AVERAGE: This function determines the average of the values included in the argument. It calculates the sum 

of the cells and then divides that value by the number of cells in the argument. 

COUNT: This function counts the number of cells with numerical data in the argument. This function is useful 

for quickly counting items in a cell range. 

MAX: This function determines the highest cell value included in the argument. 

MIN: This function determines the lowest cell value included in the argument. 

 

 

To create a basic function  

In our example below, we'll create a basic function to calculate the average price per unit for a list of recently 

ordered items using the AVERAGE function. 

Select the cell that will contain the function. 

Type the equals sign (=) and enter the desired function name. You can also select the desired function from the 

list of suggested functions that will appear below the cell as you type. In our example, we'll type =AVERAGE. 



 

 

 

 

 
 

Enter the cell range for the argument inside parentheses. In our example, we'll type (D3:D12). 

Press Enter on your keyboard. The function will be calculated, and the result will appear in the cell.  

 

 

To create a function using the AutoSum command  

The AutoSum command allows you to automatically insert the most common functions into your formula, 

including SUM, AVERAGE, COUNT, MIN, and MAX. In our example below, we'll create a function to 

calculate the total cost for a list of recently ordered items using the SUM function. 

Select the cell that will contain the function. 

In the Editing group on the Home tab, locate and select the arrow next to the AutoSum command and then 

choose the desired function from the drop-down menu. In our example, we'll select Sum. 

 



 

 

 

 

The selected function will appear in the cell. If logically placed, the AutoSum command will automatically 

select a cell range for the argument. You can also manually enter the desired cell range into the argument.  

 

 

Press Enter on your keyboard. 

 

 

The Function Library 

 

While there are hundreds of functions in Excel, the ones you use most frequently will depend on the type of data 

your workbooks contains. There is no need to learn every single function, but exploring some of the different 

types of functions will be helpful as you create new projects. You can search for functions by category, such as 

Financial, Logical, Text, Date & Time, and more from the Function Library on the Formulas tab.  

 To access the Function Library, select the Formulas tab on the Ribbon. The Function Library will appear. 

 

 



 

 

 

 

 
 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. 

The AutoSum command allows you to automatically return results for common functions, like SUM, 

AVERAGE, and COUNT. 

The Recently Used command gives you access to functions that you have recently worked with.  

The Financial category contains functions for financial calculations like determining a payment (PMT) or 

interest rate for a loan (RATE). 

Functions in the Logical category check arguments for a value or condition. For example, if an order is over  

$50 add $4.99 for shipping, but if it is over $100, do not charge for shipping (IF). 

The Text category contains functions that work with the text in arguments to perform tasks, such as converting 

text to lowercase (LOWER) or replacing text (REPLACE). 

The Date & Time category contains functions for working with dates and time and will return results like the 

current date and time (NOW) or the seconds (SECOND). 

The Lookup & Reference category contains functions that will return results for finding and referencing 

information. For example, you can add a hyperlink (HYPERLINK) to a cell or return the value of a particular 

row and column intersection (INDEX). 

The Math & Trig category includes functions for numerical arguments. For example, you can round values 

(ROUND), find the value of Pi (PI) multiply (PRODUCT), subtotal (SUBTOTAL), and much more. 

More Functions contains additional functions under categories for Statistical, Engineering, Cube, Information, 

and Compatibility. 

 

To insert a function from the Function Library  

 

Select the cell that will contain the function. 

 

Click the Formulas tab on the Ribbon to access the Function Library. 

 

From the Function Library group, select the desired function category. 

 

Select the desired function from the drop-down menu. 



 

 

 

 

 
 

 

 

The Function Arguments dialog box will appear. From here, you'll be able to enter or select the cells  that will 

make up the arguments in the function. 

 

 

 

When you're satisfied with the arguments, click OK. 

 

The function will be calculated, and the result will appear in the cell. 



 

 

 

 

Like formulas, functions can be copied to adjacent cells. Hover the mouse over the cell that contains the 

function, then click, hold, and drag the fill handle over the cells you wish to fill. The function will be copied, 

and values for those cells will be calculated relative to their rows or columns. 

 

 

 

 

 

 

The Insert Function command 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. While it can be extremely useful, this command is sometimes a little difficult to use. 

If you don't have much experience with functions, you may have more success browsing the Function Library 

instead. For more advanced users, however, the Insert Function command can be a powerful way to find a 

function quickly. 

 

 

To use the Insert Function command  

Select the cell that will contain the function. 

Click the Formulas tab on the Ribbon, then select the Insert Function command. 

The Insert Function dialog box will appear. 

Type a few keywords describing the calculation you want the function to perform, then click Go. 

Review the results to find the desired function, then click OK. 



 

 

 

 

 
 

 

The Function Arguments dialog box will appear. 

When you're satisfied, click OK. 

The function will be calculated, and the result will appear in the cell. 

 

 



 

 

 

Unit-V 

 

 

SUM 

Formula: =SUM(5, 5) or =SUM(A1, B1) or =SUM(A1:B5) 

The SUM formula does exactly what you would expect. It allows you to add 2 or more numbers together. You 

can use cell references as well in this formula. 

 

 

COUNT 

Formula: =COUNT(A1:A10) 

The count formula counts the number of cells in a range that have numbers in them. 

 

 

It only counts the cells where there are numbers. 

 

 

COUNTA 

Formula: =COUNTA(A1:A10) 

Counts the number of non-empty cells in a range. It will count cells that have numbers and/or any other 

characters in them. 

The COUNTA Formula works with all data types. 



 

 

 

 

 
 

 

It counts the number of non-empty cells no matter the data type. 

LEN 

Formula: =LEN(A1) 

The LEN formula counts the number of characters in a cell. This includes spaces! 

 

Notice the difference in the formula results: 10 characters without spaces in between the words, 12 with spaces 

between the words. 

VLOOKUP 

Formula: =VLOOKUP(lookup_value, table_array, col_index_num, range_lookup) 

Basically, VLOOKUP lets you search for specific information in your spreadsheet. For example, if you have a 

list of products with prices, you could search for the price of a specific item. 

We’re going to use VLOOKUP to find the price of the Photo frame. You can probably already see that the price 

is $9.99, but that’s because this is a simple example. Once you learn how to use VLOOKUP, you’ll be able to 

use it with larger, more complex spreadsheets, and that’s when it will become truly useful.  



 

 

 

 

 
 

As with any formula, you’ll start with an equal sign (=). Then, type the formula name.  

=VLOOKUP(“Photo frame” 

The second argument is the cell range that contains the data. In this example, our data is in A2:B16. As with any 

function, you’ll need to use a comma to separate each argument: 

=VLOOKUP(“Photo frame”, A2:B16 

Note: It’s important to know that VLOOKUP will always search the first column in this range. In this example, 

it will search column A for “Photo frame”. In some cases, you may need to move the columns around so that the 

first column contains the correct data. 

The third argument is the column index number. It’s simpler than it sounds: The first column in the range is 1, 

the second column is 2, etc. In this case, we are trying to find the price of the item, and the prices are contained 

in the second column. That means our third argument will be 2: 

=VLOOKUP(“Photo frame”, A2:B16, 2 

The fourth argument tells VLOOKUP whether to look for approximate matches, and it can be either TRUE or 

FALSE. If it is TRUE, it will look for approximate matches. Generally, this is only useful if the first column has 

numerical values that have been sorted. Since we’re only looking for exact matches, the fourth argument should 

be FALSE. This is our last argument, so go ahead and close the parentheses: 

=VLOOKUP(“Photo frame”, A2:B16, 2, FALSE) 

And that’s it! When you press enter, it should give you the answer, which is 9.99. 



 

 

 

 

 
 

 

IF Statements 

Formula: =IF(logical_statement, return this if logical statement is true, return this if logical statement is false). 

Example 

Let’s say a salesperson has a quota to meet. You used VLOOKUP to put the revenue next to the name. Now you 

can use an IF statement that says: “IF the salesperson met their quota, say “Met quota”, if not say “Did not meet 

quota” 

=IF(C3>D3, “Met Quota”, “Did Not Meet Quota”) 

This IF statement will tell us if the first salesperson met their quota or not. We would then copy and paste this 

formula along all the entries in the list. It would change for each sales person. 

 

 



 

 

 

 

Working with Data 

 

Whenever you're working with a lot of data, it can be difficult to compare information in your workbook.  

Freezing Panes and View Options 

 

Excel includes several tools that make it easier to view content from different parts of your workbook at the 

same time, such as the ability to freeze panes and split your worksheet. 

To freeze rows  

You may want to see certain rows or columns all the time in your worksheet, especially header cells. By 

freezing rows or columns in place, you'll be able to scroll through your content while continuing to view the 

frozen cells. 

Select the row below the row(s) you wish to freeze. 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

 

 

 

The rows will be frozen in place, as indicated by the gray line. You can scroll down the worksheet while 

continuing to view the frozen rows at the top. 

To freeze columns  

Select the column to the right of the column(s) you wish to freeze. 



 

 

 

 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

The column will be frozen in place, as indicated by the gray line. You can scroll across the worksheet while 

continuing to view the frozen column on the left. 

To unfreeze rows or columns, click the Freeze Panes command, then select Unfreeze Panes from the drop-down 

menu. 

 

 

To split a worksheet  

Sometimes you may want to compare different sections of the same workbook without creating a new window. 

The Split command allows you to divide the worksheet into multiple panes that scroll separately.  

Select the cell where you wish to split the worksheet. 

Click the View tab on the Ribbon, then select the Split command. 

 

The workbook will be split into different panes. You can scroll through each pane separately using the scroll 

bars, allowing you to compare different sections of the workbook. 

To remove the split, click the Split command again. 

 

 

. 

 

Sorting Data 

 

As you add more content to a worksheet, organizing that information becomes especially important. You can 

quickly reorganize a worksheet by sorting your data. For example, you could organize a list of contact 

information by last name. Content can be sorted alphabetically, numerically, and in many other ways. 



 

 

 

 

When sorting data, it's important to first decide if you would like the sort to apply to the entire worksheet or just 

a cell range. 

Sort sheet organizes all of the data in your worksheet by one column. 

Sort range sorts the data in a range of cells, which can be helpful when working with a sheet that contains 

several tables. Sorting a range will not affect other content on the worksheet. 

 

To sort a sheet  

In our example, we'll sort a T-shirt order form alphabetically by Last Name (column C). 

Select a cell in the column you wish to sort by. In our example, we'll select cell C2. 

 

 

 

Select the Data tab on the Ribbon, then click the Ascending command  to Sort A to Z, or the Descending 

command  to Sort Z to A. In our example, we'll click the Ascending command. 

 

 

The worksheet will be sorted by the selected column. In our example, the worksheet is now sorted by last name.  



 

 

 

 

 
 

 

Filtering Data 

 

If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters can be used to 

narrow down the data in your worksheet, allowing you to view only the information you need.  

To filter data  

In order for filtering to work correctly, your worksheet should include a header row, which is used to identify 

the name of each column. 

Select the Data tab, then click the Filter command. 

 

 

A drop-down arrow will appear in the header cell for each column. 

Click the drop-down arrow for the column you wish to filter. 



 

 

 

 

The Filter menu will appear. 

Uncheck the box next to Select All to quickly deselect all data. 

Check the boxes next to the data you wish to filter, then click OK. 

To remove all filters from your worksheet, click the Filter command on the Data tab. 

 

 

Working with Charts 

 

Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart types that you can 

choose from when you create a chart. Excel offers Pie, Line, Bar, and Column charts to name but a few. 

Showing data in a chart can make it clearer, more interesting and easier to read. Charts can also help you 

evaluate your data and make comparisons between different values. 

 

 

Understanding charts 

 

Excel has several different types of charts, allowing you to choose the one that best fits your data. In order to 

use charts effectively, you'll need to understand how different charts are used. 

Types of Charts: 

Column charts use vertical bars to represent data. They can work with many different types of data, but they're 

most frequently used for comparing information. 

Line charts are ideal for showing trends. The data points are connected with lines, making it easy to see whether 

values are increasing or decreasing over time. 

Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so it's easy to see 

which values make up the percentage of a whole. 

Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars.  

Area charts are similar to line charts, except that the areas under the lines are filled in. 

Surface charts allow you to display data across a 3D landscape. They work best with large data sets, allowing 

you to see a variety of information at the same time. 

 

 

To insert a chart  

  

Select the cells you want to chart, including the column titles and row labels. These cells will be the source data 

for the chart. 



 

 

 

 

From the Insert tab, click the desired Chart command. 

Choose the desired chart type from the drop-down menu. 

 

 

 

 

The selected chart will be inserted in the worksheet. 

 TIP: If you're not sure which type of chart to use, the Recommended Charts command will suggest several 

different charts based on the source data. 

 

 

 

Chart layout and style 

 

After inserting a chart, there are several things you may want to change about the way your data is displayed. 

It's easy to edit a chart's layout and style from the Design tab. 

Excel allows you to add chart elements—such as chart titles, legends, and data labels—to make your chart 

easier to read. To add a chart element, click the Add Chart Element command on the Design tab, then choose 

the desired element from the drop-down menu. 



 

 

 

 

 
 

 

To edit a chart element, like a chart title, simply double-click the placeholder and begin typing. 

 

 

If you don't want to add chart elements individually, you can use one of Excel's predefined layouts. Simply click 

the Quick Layout command, then choose the desired layout from the drop-down menu. 

Excel also includes several different chart styles, which allow you to quickly modify the look and feel of your 

chart. To change the chart style, select the desired style from the Chart styles group. 



 

 

 

 

 
 

 TIP: You can also use the chart formatting shortcut buttons to quickly add chart elements, change the chart 

style, and filter the chart data. 

 

 

 

 

Other chart options 

 

There are lots of other ways to customize and organize your charts. For example, Excel allows you to rearrange 

a chart's data, change the chart type, and even move the chart to a different location in the workbook. 

To switch row and column data  

Sometimes you may want to change the way charts group your data. For example, in the chart below, the Book 

Sales data are grouped by year, with columns for each genre. However, we could switch the rows and columns 

so the chart will group the data by genre, with columns for each year. In both cases, the chart contains the same 

data—it's just organized differently. 

Select the chart you wish to modify. 



 

 

 

 

From the Design tab, select the Switch Row/Column command. 

 

The rows and columns will be switched. 

 

 

To change the chart type  

If you find that your data isn't well suited to a certain chart, it's easy to switch to a new chart type. In our 

example, we'll change our chart from a Column chart to a Line chart. 

From the Design tab, click the Change Chart Type command. 

 

The Change Chart Type dialog box will appear. 

The selected chart type will appear. 

 

 

To move a chart  

Whenever you insert a new chart, it will appear as an object on the same worksheet that contains its source data. 

Alternatively, you can move the chart to a new worksheet to help keep your data organized. 

Select the chart you wish to move. 

Click the Design tab, then select the Move Chart command. 

 



 

 

 

 

The Move Chart dialog box will appear. Select the desired location for the chart. 

Click OK. 

The chart will appear in the selected location. 

 

 

Challenge! 

Open an existing Excel workbook. 

Use worksheet data to create a chart. 

Change the chart layout. 

Apply a chart style. 

Move the chart. 

 

 

Printing Workbooks 

 

There may be times when you want to print a workbook to view and share your data offline. Once you've 

chosen your page layout settings, it's easy to preview and print a workbook from Excel using the Print pane.  

 

 

To access the Print pane  

Select the File tab. Backstage view will appear. 

 

 

 

 

 

Select Print. The Print pane will appear. 



 

 

 

 

 

 

Here you can choose how many copies of the workbook you wish to print. 

 

 

When you are ready to print the workbook, click the Print button. 

 

You may need to select the printer you want to use if your computer is connected to multiple printers.  

 

 

 

 

 

Here you can choose to print the active sheets, the entire workbook, or a selection of 

 

 

 

 

If you are printing multiple copies, you 

can choose whether you want the 

copies collated or uncollated. 

Here you can choose whether to print on 

one side or both sides of the paper. 

 

 

 

If your printer uses different paper sizes, 

you can choose the paper size you wish 

to use. 

 

 

Here you can choose how to scale your 

worksheets for the printed page. You can 

scale worksheets at their actual size, fit 

the entire worksheet on one page, fit all 

columns on one page, or fit all rows on 

one page. 

Here you can choose Portrait 

or Landscape orientation. 

 

 

 

Here you can adjust the page 

margins, which can help your data 

fit more comfortably on the page. 

 

 

 

Choosing a print area 

 

Before you print an Excel workbook, it's important to decide exactly what information you want to print. For 

example, if you have multiple worksheets in your workbook, you will need to decide if you want to print the 

entire workbook or only active worksheets. There may also be times when you want to print only a selection of 

content from your workbook. 



 

 

 

 

To print active sheets  

Worksheets are considered active when selected. 

Select the worksheet you want to print. To print multiple worksheets, click the first worksheet, hold the Ctrl key 

on your keyboard, then click any other worksheets you want to select. 

 

Navigate to the Print pane. 

Select Print Active Sheets from the Print Range drop-down menu. 

 

Click the Print button. 

 

 

 

 

 

To print the entire workbook  

Navigate to the Print pane. 

Select Print Entire Workbook from the Print Range drop-down menu. 



 

 

 

 

 
 

Click the Print button. 

 

 

 

To print a selection  

Select the cells you wish to print. 

Navigate to the Print pane. 

Select Print Selection from the Print Range drop-down menu. 

 

A preview of your selection will appear in the Preview pane. 

Click the Print button to print the selection. 



 

 

 

 

 
 

 TIP: If you prefer, you can also set the print area in advance so you'll be able to visualize which cells will be 

printed as you work in Excel. Simply select the cells you want to print, click the Page Layout tab, select the 

Print Area command, then choose Set Print Area. 

 

 

 

 

 

 

Fitting and scaling content 

 

On occasion, you may need to make small adjustments from the Print pane to fit your workbook content neatly 

onto a printed page. The Print pane includes several tools to help fit and scale your content, such as scaling and 

page margins. 

  



 

 

 

 

To fit content before printing  

If some of your content is being cut off by the printer, you can use scaling to fit your workbook to the page 

automatically. 

Navigate to the Print pane. 

Select the desired option from the Scaling drop-down menu. In our example, we'll select Fit Sheet on One Page. 

 

The worksheet will be condensed to fit onto a single page. 

When you're satisfied with the scaling, click Print. 

 

 

To modify margins in the Preview pane  

Sometimes you may only need to adjust a single margin to make your data fit more comfortably. You can 

modify individual page margins from the Preview pane. 

Navigate to the Print pane, then click the Show Margins button in the lower-right corner. 



 

 

 

 

 
The page margins will appear in the Preview pane. Hover the mouse over one of the margin 

markers until the cursor becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the margin width. 

Release the mouse. The margin will be modified. In our example, we were able to fit an additional column on 

the page. 

 

 

Show Margins 
button. 



 

 

 

Unit-1 

 

Opening Excel 

 

Using Windows 7  

 

Click on the Start Button. 

In the Search Program and Files box type Excel. 

Click on Excel 2013 from the Program results. 

The Microsoft Excel 2013 program will open. 

 

 

Using Windows 8   

 

Press the Windows key on the keyboard. 

Type Excel. 

Click on Excel 2013 under the Apps results. 

 

 

Using iOS 7  

 

Click on Launchpad. 

Select Microsoft Excel. 

 

 

Getting Started 

 

When you open Excel 2013 for the first time, the Excel Start Screen will appear. From here, you'll be able to 

create a new workbook, choose a template, and access your recently edited workbooks. 

 

From the Excel Start Screen, locate and select Blank workbook to access the Excel interface.  

Click Open Other Workbooks to work on an existing workbook. 



 

 

 

 

 
 

 

 

To set up Excel so it automatically opens a new workbook   

 

Click File then Options. 

On the General tab, under Start up options, uncheck the Show the Start screen when this application starts box.  

The next time you start Excel, it opens a blank workbook automatically similar to older versions of Excel. 

 

The Excel Interface 

 

After starting Excel, you will see two windows - one within the other. The outer window is the Application 

Window and the inner window is the Workbook Window. When maximized, the Excel Workbook Window 

blends in with the Application Window. 

 

After completing this module, you should be able to: 

 

Identify the components of the Application Window. 

Identify the components of the Workbook Window. 

Create a new workbook 

Open an existing workbook 



 

 

 

 

 
 

 

The Application Window 

 

The Application Window provides the space for your worksheets and workbook elements such as charts. The 

components of the Application Window are described below. 

 

The Quick Access Toolbar 

 

The Quick Access Toolbar lets you access common commands no matter which tab is selected.  

 

By default, it includes the Save, Undo, and Repeat commands. You can add other commands depending on your 

preference. 

 

To add commands to the Quick Access toolbar  

 

Click the drop-down arrow to the right of the Quick Access toolbar. 

Quick Access Toolbar 

The Ribbon 

Command Group 

Name Box Formula Bar 
Colum 

Cell 

Row 

Vertical and Horizontal Scroll Bars 

Worksheets 

Worksheet View Option Zoom Control 



 

 

 

 

Select the command you wish to add from the drop-down menu. To choose from more commands, select More 

Commands. 

 

 

 

 

The command will be added to the Quick Access toolbar. 

 

 

 

 

 

 

The Ribbon 

 

Excel 2013 uses a tabbed Ribbon system instead of traditional menus. The Ribbon contains multiple tabs, each 

with several groups of commands. You will use these tabs to perform the most common tasks in Excel.  



 

 

 

 

 

 
 

 

 

To minimize and maximize the Ribbon  

 

The Ribbon is designed to respond to your current task, but you can choose to minimize it if you find that it 

takes up too much screen space. 

 

Click the Ribbon Display Options arrow in the upper-right corner of the Ribbon. 

 

Click a tab to see 

more commands 

Each tab is divided 
into groups 



 

 

 

 

Select the desired minimizing option from the drop-down menu: 

 

Auto-hide Ribbon: Auto-hide displays your workbook in full-screen mode and completely hides the Ribbon. To 

show the Ribbon, click the Expand Ribbon command at the top of screen. 

 

 

Show Tabs: This option hides all command groups when not in use, but tabs will remain visible. To show the 

Ribbon, simply click a tab. 

 Show Tabs and Commands: This option maximizes the Ribbon. All of the tabs and commands will be visible. 

This option is selected by default when you open Excel for the first time. 

 

To Customize the Ribbon in Excel 2013  

 

You can customize the Ribbon by creating your own tabs with whichever commands you want. Commands are 

always housed within a group, and you can create as many groups as you want in order to keep your tab 

organized. If you want, you can even add commands to any of the default tabs, as long as you create a custom 

group in the tab. 

 

Right-click the Ribbon and then select Customize the Ribbon... from the drop-down menu. 

 

 

The Excel Options dialog box will appear. Locate and select New Tab. 

Ribbon is hidden and workbook 

appears in full screen 
Click the Expand Ribbon 

command to show the Ribbon 



 

 

 

 

 
 

Make sure the New Group is selected, select a command, and then click Add. You can also drag commands 

directly into a group. 

When you are done adding commands, click OK. The commands will be added to the Ribbon. 

 

 

Select 
commands and 

click Add 



 

 

 

Unit-II 

 

 

The Formula Bar 

 

In the formula bar, you can enter or edit data, a formula, or a function that will appear in a specific cell. 

 

In the image below, cell C1 is selected and 1984 is entered into the formula bar. Note how the data appears in 

both the formula bar and in cell C1. 

 

 

 

The Name Box 

 

The Name box displays the location, or "name" of a selected cell. 

 

In the image below, cell B4 is selected. Note that cell B4 is where column B and row 4 intersect.  

 

 

The Backstage View (The File Menu) 

 

Click the File tab on the Ribbon. Backstage view will appear. 

 

 



 

 

 

 

 

 

 
 

 

The Worksheet Views 

 

Excel 2013 has a variety of viewing options that change how your workbook is displayed. You can choose to 

view any workbook in Normal view, Page Layout view, or Page Break view. These views can be useful for 

various tasks, especially if you're planning to print the spreadsheet. 

 

To change worksheet views, locate and select the desired worksheet view command in the bottom-right corner 

of the Excel window. 

Return to Excel 
Info contains 

information about the 
current workbook. You 

can also inspect the 
workbook and set 

protection controls. 
New: you can create a new, blank 
workbook, or choose from a large 

selection of templates. 

Open: you can open 
recent workbooks, as 

well as workbooks saved 

to your OneDrive or on Use Save and Save As to save 

your computer. your workbook to your computer 

or to Office 365. 

From the Print pane, 
you can change the 

print settings and print 

your workbook. You 

can also see a preview 

of your workbook. 

Share: you can invite people to view and 
collaborate on your workbook. You can also share 

your workbook by emailing it as an attachment. 

Export: you can choose 
to export your 

workbook in another 
format, such as 

PDF/XPS or Excel 
1997-2003. 

Close the current workbook. 
 

From the Account pane, you can access your 
Microsoft account information, modify your theme 

and background, and sign out of your account. 

Options: you can change various Excel options. For 
example, you can control the Quick Analysis preferences, 

Auto Recover settings, or Language preferences. 



 

 

 

 

 
 

 

Zoom Control 

 

To use the Zoom control, click and drag the slider. The number to the right of the slider reflects the zoom 

percentage. 

 

 

Page Layout 

View 

Normal View Page Break 

View 



 

 

 

 

The Workbook Window 

 

In Excel 2013, when you open up a new workbook it now contains only 1 worksheet There can be a max of 

1,048,576 rows and 16,384 columns in an excel work sheet. 

 

The Worksheet 

 

Excel files are called workbooks. Each workbook holds one or more worksheets (also known as "spreadsheets").  

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. A worksheet is a grid 

of columns and rows where columns are designated by letters running across the top of the worksheet and rows 

are designated by numbers running down the left side of the worksheet. 

 

 

 

When working with a large amount of data, you can create multiple worksheets to help organize your workbook 

and make it easier to find content. You can also group worksheets to quickly add information to multiple 

worksheets at the same time. 

 

To rename a worksheet  

 

Whenever you create a new Excel workbook, it will contain one worksheet named Sheet1. You can rename a 

worksheet to better reflect its content. In our example, we will create a training log organized by month.  

 

Right-click the worksheet you wish to rename, then select Rename from the worksheet menu. 



 

 

 

 

 
 

Type the desired name for the worksheet. 

 

 

Click anywhere outside of the worksheet, or press Enter on your keyboard. The worksheet will be renamed.  

 

 

To insert a new worksheet  

 

Locate and select the New sheet button. 

 

 

Click to add a 

new worksheet 



 

 

 

 

A new, blank worksheet will appear. 

 

 TIP: To change the default number of worksheets, navigate to Backstage view, click Options, and then 

choose the desired number of worksheets to include in each new workbook. 

 

 

 

To delete a worksheet  

 

Right-click the worksheet you wish to delete, then select Delete from the worksheet menu. 

 

 

The worksheet will be deleted from your workbook. 



 

 

 

 

 
 

 

 

Alternatively, from the Home Tab in the Cells Group click on Delete and select Delete Sheet. Warning: The 

Undo button will not undo the deletion of a worksheet. 

To copy a worksheet  

 

If you need to duplicate the content of one worksheet to another, Excel allows you to copy an existing 

worksheet. 

 

Right-click the worksheet you want to copy, then select Move or Copy from the worksheet menu. 

 

 

 

 

The Move or Copy dialog box will appear. Choose where the sheet will appear in the Before sheet: field. In our 

example, we'll choose (move to end) to place the worksheet to the right of the existing worksheet.  

Check the box next to Create a copy, then click OK. 



 

 

 

 

 
 

The worksheet will be copied. It will have the same title as the original worksheet, as well as a version number.  

 

TIP: You can also copy a worksheet to an entirely different workbook. You can select any workbook that is 

currently open from the To book: drop-down menu. 

 

 

To move a worksheet  

 

Sometimes you may want to move a worksheet to rearrange your workbook. 

 

Select the worksheet you wish to move. The cursor will become a small worksheet icon . 

Hold and drag the mouse until a small black arrow appears above the desired location. 



 

 

 

 

 
 

Release the mouse. The worksheet will be moved. 

 

To change the worksheet color  

 

You can change a worksheet's color to help organize your worksheets and make your workbook easier to 

navigate. 

 

Right-click the desired worksheet, and hover the mouse over Tab Color. The Color menu will appear.  

Select the desired color. A live preview of the new worksheet color will appear as you hover the mouse over 

different options. In our example, we'll choose Red. 

The worksheet color will be changed. 



 

 

 

 

The worksheet color is considerably less noticeable when the worksheet is selected. Select another worksheet to 

see how the color will appear when the worksheet is not selected. 

 

 

 

 

 

. 

 



 

 

 

 

The Scroll Bars 

 

Your spreadsheet may frequently have more data than you can see on the screen at once. Click, hold and drag 

the vertical or horizontal scroll bar depending on what part of the page you want to see. 

 

 

 

 

 

Creating and Opening Workbooks 

 

Excel files are called workbooks. Whenever you start a new project in Excel, you'll need to create a new 

workbook. There are several ways to start working with a workbook in Excel 2013. You can choose to create a 

new workbook—either with a blank workbook or a predesigned template—or open an existing workbook. 

 

Create a new blank workbook 

 

Select the File tab. Backstage view will appear. 

 

Vertical 

scroll bar 

Horizontal 

scroll bar 



 

 

 

 

Select New, then click Blank workbook. 

A new blank workbook will appear. 

 

Open an existing workbook 

 

In addition to creating new workbooks, you'll often need to open a workbook that was previously saved.  

Navigate to Backstage view, then click Open. 

 

 

 

 

Select Computer, and then click Browse. 

 



 

 

 

 

The Open dialog box will appear. Locate and select your workbook, then click Open. 

 

 

 

 TIP: If you've opened the desired workbook recently, you can browse your Recent Workbooks rather than 

searching for the file. 

 



 

 

 

 

To pin a workbook  

If you frequently work with the same workbook, you can pin it to Backstage view for quick access.  

Navigate to Backstage view and then click Open. Your recently edited workbooks will appear. 

Hover the mouse over the workbook you wish to pin. A pushpin icon will appear next to the workbook. Click 

the pushpin icon. 

 

 

The workbook will stay in Recent Workbooks. To unpin a workbook, simply click the pushpin icon again.  

 

 TIP: You can also pin folders to Backstage view for quick access. From Backstage view, click Open, then 

locate the folder you wish to pin and click the pushpin icon. 

 

 

Compatibility mode 

 

Sometimes you may need to work with workbooks that were created in earlier versions of Microsoft Excel, such 

as Excel 2003 or Excel 2000. When you open these kinds of workbooks, they will appear in Compatibility 

mode. 

 



 

 

 

 

Compatibility mode disables certain features, so you'll only be able to access commands found in the program 

that was used to create the workbook. For example, if you open a workbook created in Excel 2003, you can only 

use tabs and commands found in Excel 2003. 

In order to exit Compatibility mode, you'll need to convert the workbook to the current version type. However, 

if you're collaborating with others who only have access to an earlier version of Excel, it's best to leave the 

workbook in Compatibility mode so the format will not change. 

To convert a workbook  

If you want access to all of the Excel 2013 features, you can convert the workbook to the 2013 file format. Note 

that converting a file may cause some changes to the original layout of the workbook. 

Click the File tab to access Backstage view. 

Locate and select Convert command. 

 

 

 

 

The Save As dialog box will appear. Select the location where you wish to save the workbook, enter a file name 

for the presentation, and click Save. 

The workbook will be converted to the newest file type. 

 

 



 

 

 

 

Saving and Sharing Workbooks 

 

Whenever you create a new workbook in Excel, you'll need to know how to save it in order to access and edit it 

later. As with previous versions of Excel, you can save files locally to your computer. But unlike older versions, 

Excel 2013 also lets you save a workbook to the cloud using OneDrive. You can also export and share 

workbooks with others directly from Excel. 

 

Save and Save As 

 

Excel offers two ways to save a file: Save and Save As. These options work in similar ways, with a few 

important differences: 

Save: When you create or edit a workbook, you'll use the Save command to save your changes. You'll use this 

command most of the time. When you save a file, you'll only need to choose a file name and location the first 

time. After that, you can just click the Save command to save it with the same name and location. 

Save As: You'll use this command to create a copy of a workbook while keeping the original. When you use 

Save As, you'll need to choose a different name and/or location for the copied version. 

 

To save a workbook  

  

It's important to save your workbook whenever you start a new project or make changes to an existing one. 

Saving early and often can prevent your work from being lost. You'll also need to pay close attention to where 

you save the workbook so it will be easy to find later. 

 

Locate and select the Save command on the Quick Access Toolbar. 

 

 

If you're saving the file for the first time, the Save As pane will appear in Backstage view. 

You'll then need to choose where to save the file and give it a file name. To save the workbook to your 

computer, select Computer, then click Browse. Alternatively, you can click OneDrive to save the file to your 

OneDrive. 

The Save As dialog box will appear. Select the location where you wish to save the workbook. 



 

 

 

 

Enter a file name for the workbook, then click Save. 

 

 

 

The workbook will be saved. You can click the Save command again to save your changes as you modify the 

workbook. 

 

Using Save As to make a copy  

  

If you want to save a different version of a workbook while keeping the original, you can create a copy. For 

example, if you have a file named "Sales Data" you could save it as "Sales Data 2" so you'll be able to edit the 

new file and still refer back to the original version. 

To do this, you'll click the Save As command in Backstage view. Just like when saving a file for the first time, 

you'll need to choose where to save the file and give it a new file name. 

 

AutoRecover 

 

Excel automatically saves your workbooks to a temporary folder while you are working on them. If you forget 

to save your changes, or if Excel crashes, you can restore the file using AutoRecover.  

 

To use Auto Recover  

  

Open Excel 2013. If auto-saved versions of a file are found, the Document Recovery pane will appear. 

Choose a location, and 

then type the file name. 



 

 

 

 

Click to open an available file. The workbook will be recovered. 

 

 

 

 

 

 TIP: By default, Excel autosaves every 10 minutes. If you are editing a workbook for less than 10 minutes,  

Excel may not create an autosaved version. 

If you don't see the file you need, you can browse all autosaved files from Backstage view. Just select the File 

tab, click Manage Versions, and then choose Recover Unsaved Workbooks. 

 

 

Exporting workbooks 

 

By default, Excel workbooks are saved in the .xlsx file type. However, there may be times when you need to use 

another file type, such as a PDF or Excel 97-2003 workbook. It's easy to export your workbook from Excel in a 

variety of file types. 

To export a workbook as a PDF file  

Exporting your workbook as an Adobe Acrobat document, commonly known as a PDF file, can be especially 

useful if sharing a workbook with someone who does not have Excel. A PDF will make it possible for recipients 

to view, but not edit, the content of your workbook. 

Click the File tab to access Backstage view. 

Click Export, then select Create PDF/XPS. 



 

 

 

 

 
 

 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Publish. 

 

 TIP: By default, Excel will only export the active worksheet. If you have multiple worksheets and want to 

save all of them in the same PDF file, click Options in the Save as dialog box. The Options dialog box will 

appear. Select Entire workbook, then click OK. 

 

 

 

 

To export a workbook in other file types  

  

You may also find it helpful to export your workbook in other file types, such as an Excel 97-2003 Workbook if 

you need to share with people using an older version of Excel, or a .CSV file if you need a plain-text version of 

your workbook. 



 

 

 

 

Click the File tab to access Backstage view. 

Click Export, then select Change File Type. 

Select a common file type, then click Save As. 

The Save As dialog box will appear. Select the location where you wish to export the workbook, enter a file 

name, and then click Save. 

 

 

Challenge! 

Create a new blank workbook. 

Use the Save command to save the workbook to your desktop. 

Save the workbook to OneDrive and invite someone else to view it. 

Export the workbook as a PDF file. 

 

 

Cell Basics 

 

Whenever you work with Excel, you'll enter information, or content, into cells. Cells are the basic building 

blocks of a worksheet. You'll need to learn the basics of cells and cell content to calculate,  analyze, and organize 

data in Excel. 

 

 

Understanding Cells 

 

Every worksheet is made up of thousands of rectangles, which are called cells. A cell is the intersection of a row 

and a column. Columns are identified by letters (A, B, C), while rows are identified by numbers (1, 2, 3). 

 

Colum 

Row Cell 



 

 

 

 

Each cell has its own name, or cell address, based on its column and row. In this example, the selected cell 

intersects column C and row 5, so the cell address is C5. The cell address will also appear in the Name box. 

Note that a cell's column and row headings are highlighted when the cell is selected. 

 

 

 

 

You can also select multiple cells at the same time. A group of cells is known as a cell range. Rather than a 

single cell address, you will refer to a cell range using the cell addresses of the first and last cells in the cell 

range, separated by a colon. For example, a cell range that included cells A1, A2, A3, A4, and A5 would be 

written as A1:A5. 

 

In the images below, two different cell ranges are selected: 

 

Cell range A1:A8 

 

 

Cell range A1:B8 

Cell Address 



 

 

 

 

 
 

To select a cell range  

 

Sometimes you may want to select a larger group of cells, or a cell range. 

 

Click, hold, and drag the mouse until all of the adjoining cells you wish to select are highlighted. 

Release the mouse to select the desired cell range. The cells will remain selected until you click another cell in 

the worksheet. 

Cell Content 

 

Any information you enter into a spreadsheet will be stored in a cell. Each cell can contain several different 

kinds of content, including text, formatting, formulas, and functions. 

 

Text 

Cells can contain text, such as letters, numbers, and dates. 

 



 

 

 

Unit-III 

 

Formatting Attributes 

Cells can contain formatting attributes that change the way letters, numbers, and dates are displayed. For 

example, percentages can appear as 0.15 or 15%. You can even change a cell's background color.  

 

Formulas and Functions 

Cells can contain formulas and functions that calculate cell values. In our example, SUM(B4:B7) adds the value 

of each cell in cell range B4:B7 and displays the total in cell B8. 

 

 

To insert content  

Click a cell to select it. 

 

Type content into the selected cell, then press Enter on your keyboard. The content will appear in the cell and 

the formula bar. You can also input and edit cell content in the formula bar. 

 

 

 
 
 
 

Content appears in cell 

and formula bar 



 

 

 

 

To delete cell content  

Select the cell with content you wish to delete. 

Press the Delete or Backspace key on your keyboard. The cell's contents will be deleted. 

To delete cells  

There is an important difference between deleting the content of a cell and deleting the cell itself. If you delete 

the entire cell, the cells below it will shift up and replace the deleted cells. 

Select the cell(s) you wish to delete. 

Select the Delete command from the Home tab on the Ribbon. 

The cells below will shift up. 

 

 

 

 

To copy and paste cell content  

Excel allows you to copy content that is already entered into your spreadsheet and paste that content to other 

cells, which can save you time and effort. 

Select the cell(s) you wish to copy. 

Click the Copy command on the Home tab, or press Ctrl+C on your keyboard. 



 

 

 

 

 
 

 

Select the cell(s) where you wish to paste the content. The copied cells will now have a dashed box around 

them. 

Click the Paste command on the Home tab, or press Ctrl+V on your keyboard. 

The content will be pasted into the selected cells. 

 

 

To access more paste options  

You can also access additional paste options, which are especially convenient when working with cells that 

contain formulas or formatting. 

 To access more paste options, click the drop-down arrow on the Paste command. 

 



 

 

 

 

 TIP: Rather than choosing commands from the Ribbon, you can access commands quickly by right- clicking. 

Simply select the cell(s) you wish to format, then right-click the mouse. A drop-down menu will appear, where 

you'll find several commands that are also located on the Ribbon. 

 

 

To drag and drop cells  

Rather than cutting, copying, and pasting, you can drag and drop cells to move their contents.  

Select the cell(s) you wish to move. 

Hover the mouse over the border of the selected cell(s) until the cursor changes from a white cross to a black 

cross with four arrows. 

Click, hold, and drag the cells to the desired location. 

Release the mouse, and the cells will be dropped in the selected location. 

 

 

To use the fill handle  

There may be times when you need to copy the content of one cell to several other cells in your worksheet. You 

could copy and paste the content into each cell, but this method would be very time consuming. Instead, you can 

use the fill handle to quickly copy and paste content to adjacent cells in the same row or column. 

Select the cell(s) containing the content you wish to use. The fill handle will appear as a small square in the 

bottom-right corner of the selected cell(s). 



 

 

 

 

 
Click, hold, and drag the fill handle until all of the cells you wish to fill are selected. 

 

 

 

 

Release the mouse to fill the selected cells. 

 

To continue a series with the fill handle  

The fill handle can also be used to continue a series. Whenever the content of a row or column follows a 

sequential order, like numbers (1, 2, 3) or days (Monday, Tuesday, Wednesday), the fill handle can guess what 

should come next in the series. In many cases, you may need to select multiple cells before using the fill handle 

to help Excel determine the series order. In our example below, the fill handle is used to extend a series of dates 

in a column. 

The fill handle 



 

 

 

 

 

 

  
 

 

 

 

Find and Replace 

 

When working with a lot of data in Excel, it can be difficult and time consuming to locate specific information. 

You can easily search your workbook using the Find feature, which also allows you to modify content using the 

Replace feature. 

To find content  

From the Home tab, click the Find and Select command, then select Find... from the drop-down menu. 

 

 

 

 

 

 

 

 

 

 

The Find and Replace dialog box will appear. Enter the content you wish to find. 

Click Find Next. If the content is found, the cell containing that content will be selected. 



 

 

 

 

 
 

 

 

Click Find Next to find further instances or Find All to see every instance of the search term. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 TIP: You can also access the Find command by pressing Ctrl+F on your keyboard. 

 TIP: Click Options to see advanced search criteria in the Find and Replace dialog box. 

 

 

 

 

To replace cell content  

At times, you may discover that you've repeatedly made a mistake throughout your workbook (such as 

misspelling someone's name), or that you need to exchange a particular word or phrase for another. You can use 

Excel's Find and Replace feature to make quick revisions. 



 

 

 

 

From the Home tab, click the Find and Select command, then select Replace... from the drop- down menu. 

The Find and Replace dialog box will appear. Type the text you wish to find in the Find what: field.  

Type the text you wish to replace it with in the Replace with: field, then click Find Next. 

If the content is found, the cell containing that content will be selected. 

Review the text to make sure you want to replace it. 

If you wish to replace it, select one of the replace options: 

Replace will replace individual instances. 

Replace All will replace every instance of the text throughout the workbook. In our example, we'll choose this 

option to save time. 

A dialog box will appear, confirming the number of replacements made. Click OK to continue. 

When you are finished, click Close to exit the Find and Replace dialog box. 

 

 

Formatting Cells 

 

All cell content uses the same formatting by default, which can make it difficult to read a workbook with a lot of 

information. Basic formatting can customize the look and feel of your workbook, allowing you to draw attention 

to specific sections and making your content easier to view and understand. You can also apply number 

formatting to tell Excel exactly what type of data you’re using in the workbook, such as percentages (%),  

currency ($), and so on. 



 

 

 

 

Font Formatting 

 

To change the font  

By default, the font of each new workbook is set to Calibri. However, Excel provides a variety of other fonts 

you can use to customize your cell text. In the example below, we'll format our title cell to help distinguish it 

from the rest of the worksheet. 

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font command on the Home tab. The Font drop-down menu will appear. 

Select the desired font. A live preview of the new font will appear as you hover the mouse over different 

options. 

 

 

 

The text will change to the selected font. 

 

 TIP: When creating a workbook in the workplace, you'll want to select a font that is easy to read. 

Along with Calibri, standard reading fonts include Cambria, Times New Roman, and Arial. 

To change the font size  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Size command on the Home tab. The Font Size drop- down menu 

will appear. 

Select the desired font size. A live preview of the new font size will appear as you hover the mouse over 

different options. 

The text will change to the selected font size. 

 TIP: You can also use the Increase Font Size and Decrease Font Size commands or enter a custom font size 

using your keyboard. 



 

 

 

 
 

To change the font color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Font Color command on the Home tab. The Color menu will appear.  

Select the desired font color. A live preview of the new font color will appear as you hover the mouse over 

different options. 

 

 

The text will change to the selected font color. 

 

 

To use the Bold, Italic, and Underline commands  

Select the cell(s) you wish to modify. 

Click the Bold (B), Italic (I), or Underline (U) command on the Home tab. In our example, we'll make the 

selected cells bold. 

Entering a custom 

font size 
Increase and 
Decrease Font 

Size commands 



 

 

 

 

 
 

 

The selected style will be applied to the text. 

 TIP: You can also press Ctrl+B on your keyboard to make selected text bold, Ctrl+I to apply italics,  and 

Ctrl+U to apply an underline. 

 

Text Alignment 

 

By default, any text entered into your worksheet will be aligned to the bottom-left of a cell. Any numbers will 

be aligned to the bottom-right of a cell. Changing the alignment of your cell content allows you to choose how 

the content is displayed in any cell, which can make your cell content easier to read. 

To change horizontal text alignment  

Select the cell(s) you wish to modify. 

Select one of the three horizontal alignment commands on the Home tab. In our example, we'll choose Center 

Align. 

 

The text will realign. 

To change vertical text alignment  

Select the cell(s) you wish to modify. 

Select one of the three vertical alignment commands on the Home tab. In our example, we'll choose Middle 

Align. 



 

 

 

 

 
 

The text will realign. 

 

 

Cell borders and fill colors 

 

Cell borders and fill colors allow you to create clear and defined boundaries for different sections of your 

worksheet. 

To add a border  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Borders command on the Home tab. The Borders drop- down menu will 

appear. 

 

 

Select the border style you want to use. 

The selected border style will appear. 

 TIP: You can draw borders and change the line style and color of borders with the Draw Borders tools at the 

bottom of the Borders drop-down menu. 



 

 

 

 

 
 

 

To add a fill color  

Select the cell(s) you wish to modify. 

Click the drop-down arrow next to the Fill Color command on the Home tab. The Fill Color menu will appear. 

Select the fill color you want to use. A live preview of the new fill color will appear as you hover the mouse 

over different options. In our example, we'll choose Light Green. 

 

 

The selected fill color will appear in the selected cells. 



 

 

 

 

Cell styles 

 

Rather than formatting cells manually, you can use Excel's predesigned cell styles. Cell styles are a quick way to 

include professional formatting for different parts of your workbook, such as titles and headers.  

To apply a cell style  

Select the cell(s) you wish to modify. 

Click the Cell Styles command on the Home tab, then choose the desired style from the drop-down menu. 

 

 

The selected cell style will appear. 

 TIP: Applying a cell style will replace any existing cell formatting except for text alignment. You may not 

want to use cell styles if you've already added a lot of formatting to your workbook. 

 

Formatting text and numbers 

 

One of the most powerful tools in Excel is the ability to apply specific formatting for text and numbers. Instead 

of displaying all cell content in exactly the same way, you can use formatting to change the appearance of dates, 

times, decimals, percentages (%), currency ($), and much more. 

To apply number formatting  

Select the cells(s) you wish to modify. 

Click the drop-down arrow next to the Number Format command on the Home tab. The Number Formatting 

drop-down menu will appear. 

Select the desired formatting option. 

The selected cells will change to the new formatting style. 



 

 

 

General is the default format for any cell. 
When you enter a number into the cell, 

Excel will guess the number format that is 

most appropriate. 
Number formats numbers 

with decimal places. 

Currency formats numbers as currency 

with a currency symbol. 

Short Date formats numbers 

as M/D/YYYY. 

Accounting formats numbers as monetary 
values like the Currency format, but it also 

aligns currency symbols and decimal 

places within columns. 

Long Date formats numbers as 

Weekday, Month DD, YYYY. 

Time formats numbers as HH/MM/SS 
and notes AM or PM. 

Percentage formats numbers with 
decimal places and the percent sign. 

Fraction formats numbers as fractions 

separated by the forward slash. 

Scientific formats numbers 

in scientific notation. 

Text formats numbers as text, meaning 
that what you enter into the cell will 

appear exactly as it was entered. 

You can easily customize any format in 

More Number Formats. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Challenge! 

Open an existing Excel 2013 workbook. 

Select a cell and change the font style, size, and color of the text. 

Apply bold, italics, or underline to a cell. 

Try changing the vertical and horizontal text alignment for some cells. 

Add a border to a cell range. 

Change the fill color of a cell range. 

Try changing the formatting of a number. 



 

 

 

 

Modifying Columns, Rows and Cells 

 

By default, every row and column of a new workbook is always set to the same height and width. Excel allows 

you to modify column width and row height in different ways, including wrapping text and merging cells.  

 

 

To modify column width  

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

 

Click, hold, and drag the mouse to increase or decrease the column width. 

Release the mouse. The column width will be changed. 

 TIP: If you see pound signs (#######) in a cell, it means that the column is not wide enough to display the 

cell content. Simply increase the column width to show the cell content. 

 

 

To AutoFit column width  

The AutoFit feature will allow you to set a column's width to fit its content automatically. 

Position the mouse over the column line in the column heading so the white cross becomes a double arrow 

. 

Double-click the mouse. The column width will be changed automatically to fit the content. 

 TIP: You can also AutoFit the width for several columns at the same time. Simply select the columns you 

would like to AutoFit, then select the AutoFit Column Width command from the Format drop- down menu on 

the Home tab. This method can also be used for Row height. 



 

 

 

 

 

 
To modify row height  

Position the cursor over the row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse. The height of the selected row will be changed. 

 

 

To modify all rows or columns  

Rather than resizing rows and columns individually, you can modify the height and width of every row and 

column at the same time. This method allows you to set a uniform size for every row and column in your 

worksheet. 

Locate and click the Select All button just below the formula bar to select every cell in the worksheet. 

 

 

 

 

 

 

 

 

 

 

Position the mouse over a row line so the white cross becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the row height. 

Release the mouse when you are satisfied with the new row height for the worksheet.  



 

 

 

 

Inserting, deleting, moving, and hiding rows and columns 

 

After you've been working with a workbook for a while, you may find that you want to insert new columns or 

rows, delete certain rows or columns, move them to a different location in the worksheet, or even hide them.  

To insert rows  

Select the row heading below where you want the new row to appear. 

Click the Insert command on the Home tab. 

 

The new row will appear above the selected row. 

 

 TIP: When inserting new rows, columns, or cells, you will see the Insert Options button next to the 

inserted cells. This button allows you to choose how Excel formats these cells. By default, Excel formats 

inserted rows with the same formatting as the cells in the row above. To access more options, hover your mouse 

over the Insert Options button, then click the drop-down arrow. 

 

 



 

 

 

 

To insert columns  

Select the column heading to the right of where you want the new column to appear.  

Click the Insert command on the Home tab. 

 

The new column will appear to the left of the selected column. 

 

 TIP: When inserting rows and columns, make sure you select the entire row or column by clicking the 

heading. If you select only a cell in the row or column, the Insert command will only insert a new cell.  

 

To delete rows  

It's easy to delete any row that you no longer need in your workbook. 

Select the row(s) you want to delete. 

Click the Delete command on the Home tab. 

 



 

 

 

 

The selected row(s) will be deleted, and the rows below will shift up. 

To delete columns  

Select the columns(s) you want to delete. 

Click the Delete command on the Home tab. 

 

 

 

 

 

 

 

The selected columns(s) will be deleted, and the columns to the right will shift left.  

 TIP: It's important to understand the difference between deleting a row or column and simply clearing its 

contents. If you want to remove the content of a row or column without causing others to shift, right-click a 

heading, then select Clear Contents from the drop-down menu. 

 

 



 

 

 

 

To move a row or column  

Sometimes you may want to move a column or row to rearrange the content of your worksheet. 

Select the desired column heading for the column you wish to move, then click the Cut command on the Home 

tab or press Ctrl+X on your keyboard. 

Select the column heading to the right of where you want to move the column. For example, if you want to 

move a column between columns B and C, select column C. 

Click the Insert command on the Home tab, then select Insert Cut Cells from the drop-down menu. 

 

The column will be moved to the selected location, and the columns to the right will shift right. 

 

 TIP: You can also access the Cut and Insert commands by right-clicking the mouse and then selecting the 

desired commands from the drop-down menu. 

 

 

To hide and unhide a row or column  

At times, you may want to compare certain rows or columns without changing the organization of your 

worksheet. Excel allows you to hide rows and columns as needed. 

Select the column(s) you wish to hide, right-click the mouse, then select Hide from the formatting menu. 



 

 

 

 

The columns will be hidden. The green column line indicates the location of the hidden columns. 

 

 

 

 

To unhide the columns, select the columns to the left and right of the hidden columns (in other words, the 

columns on both sides of the hidden columns). 

Right-click the mouse, then select Unhide from the formatting menu. The hidden columns will reappear.  

 

 

Wrapping text and merging cells 

 

Whenever you have too much cell content to be displayed in a single cell, you may decide to wrap the text or 

merge the cell rather than resizing a column. Wrapping the text will automatically modify a cell's row height, 

allowing cell contents to be displayed on multiple lines. Merging allows you to combine a cell with adjacent, 

empty cells to create one large cell. 

Select the cells you wish to wrap. 

Select the Wrap Text command on the Home tab. 

 

Green 

column line 



 

 

 

 

The text in the selected cells will be wrapped. 

 TIP: Click the Wrap Text command again to unwrap the text. 

 

 

To merge cells using the Merge & Center command  

Select the cell range you want to merge together. 

Select the Merge & Center command on the Home tab. 

 

 

 

The selected cells will be merged, and the text will be centered. 

To access more merge options  

Click the drop-down arrow next to the Merge & Center command on the Home tab. The Merge drop-down 

menu will appear. From here, you can choose to: 

Merge & Center: Merges the selected cells into one cell and centers the text 

Merge Across: Merges the selected cells into larger cells while keeping each row separate 

Merge Cells: Merges the selected cells into one cell, but does not center the text 

Unmerge Cells: Unmerges selected cells 

 



 

 

 

 

 

Formulas and Functions 

 

One of the most powerful features in Excel is the ability to calculate numerical information using formulas. 

 

 

Simple Formulas 

 

Just like a calculator, Excel can add, subtract, multiply, and divide. In this lesson, we'll show you how to use 

cell references to create simple formulas. 

Mathematical operators  

Excel uses standard operators for formulas, such as a plus sign for addition (+), a minus sign for subtraction ( -), 

an asterisk for multiplication (*), a forward slash for division (/), and a caret (^) for exponents. 

 

 

 

All formulas in Excel must begin with an equals sign (=). This is because the cell contains, or is equal to, the 

formula and the value it calculates. 



 

 

 

 

Understanding cell references  

While you can create simple formulas in Excel manually (for example, =2+2 or =5*5), most of the time you will 

use cell addresses to create a formula. This is known as making a cell reference. Using cell references will 

ensure that your formulas are always accurate because you can change the value of referenced cells without 

having to rewrite the formula. 

 

 

 

By combining a mathematical operator with cell references, you can create a variety of simple formulas in 

Excel. Formulas can also include a combination of cell references and numbers, as in the examples below: 

 

  

 
 
 

 
The formula in cell A3 

refers to the value in cell A1 

plus the value in cell A2 

 

The formula calculates 

and displays the answer  

to the equation A1 plus A2 



 

 

 

 

To create a formula  

Select the cell that will contain the formula. 

Type the equals sign (=). Notice how it appears in both the cell and the formula bar. 

 

 

 

 

Type the cell address of the cell you wish to reference first in the formula: cell D1 in our example.  A blue 

border will appear around the referenced cell. 

Type the mathematical operator you wish to use. In our example, we'll type the addition sign (+).  

Type the cell address of the cell you wish to reference second in the formula: cell D2 in our example. A red 

border will appear around the referenced cell. 

 

 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell.  

 TIP: If the result of a formula is too  large to  be displayed  in  a  cell, it may appear as  pound  signs 

(#######) instead of a value. This means that the column is not wide enough to display the cell content. Simply 

increase the column width to show the cell content. 

 

 

Modifying values with cell references  

The true advantage of cell references is that they allow you to update data in your worksheet without having to 

rewrite formulas. 

 TIP: Excel will not always tell you if your formula contains an error, so it's up to you to check all of your 

formulas. 

 
 
 

 
Formula will appear in 

both the cell and the 

formula bar. 



 

 

 

 

To create a formula using the point-and-click method  

Rather than typing cell addresses manually, you can point and click on the cells you wish to include in your 

formula. This method can save a lot of time and effort when creating formulas. In our example below, we'll 

create a formula to calculate the cost of ordering several boxes of plastic silverware. 

Select the cell that will contain the formula. In our example, we'll select cell D3. 

 

 

 

Type the equals sign (=). 

Select the cell you wish to reference first in the formula: cell B3 in our example. The cell address will appear in 

the formula, and a dashed blue line will appear around the referenced cell. 

 

 

 

Type the mathematical operator you wish to use. In our example, we'll type the multiplication sign (*).  

Select the cell you wish to reference second in the formula: cell C3 in our example. The cell address will appear 

in the formula, and a dashed red line will appear around the referenced cell. 



 

 

 

 

 
 

Press Enter on your keyboard. The formula will be calculated, and the value will be displayed in the cell. 

 

 

 

Formulas can also be copied to adjacent cells with the fill handle, which can save a lot of time and effort if you 

need to perform the same calculation multiple times in a worksheet. 

To edit a formula  

Sometimes you may want to modify an existing formula. In the example below, we've entered an incorrect cell 

address in our formula, so we'll need to correct it. 

Select the cell containing the formula you wish to edit. 

Click the formula bar to edit the formula. You can also double-click the cell to view and edit the formula 

directly within the cell. 

A border will appear around any referenced cells. 

 

When finished, press Enter on your keyboard or select the Enter command in the formula bar. 

The formula will be updated, and the new value will be displayed in the cell. 

 TIP: If you change your mind, you can press the Esc key on your keyboard or click the Cancel command

 in the formula bar to avoid accidentally making changes to your formula. 



 

 

 

 

 TIP: To show all of the formulas in a spreadsheet, you can hold the Ctrl key and press ` (grave accent). The 

grave accent key is usually located in the upper-left corner of the keyboard. You can press Ctrl+` again to 

switch back to the normal view. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

Unit-IV 

 

Complex Formulas 

 

A simple formula is a mathematical expression with one operator, such as 7+9. A complex formula has more 

than one mathematical operator, such as 5+2*8. When there is more than one operation in a formula, the order 

of operations tells Excel which operation to calculate first. In order to use Excel to calculate complex formulas, 

you will need to understand the order of operations. 

Order of operations  

Excel calculates formulas based on the following order of operations: 

Operations enclosed in parentheses 

Exponential calculations (3^2, for example) 

Multiplication and division, whichever comes first 

Addition and subtraction, whichever comes first 

 

 

Creating complex formulas  

In the example below, we will demonstrate how Excel solves a complex formula using the order of operations. 

Here, we want to calculate the cost of sales tax for an invoice. To do this, we'll write our formula as 

=(D2+D3)*0.075 in cell D4. This formula will add the prices of our items together and then multiply that value 

by the 7.5% tax rate (which is written as 0.075) to calculate the cost of sales tax. 



 

 

 

 

 
 

 

 TIP: It is especially important to enter complex formulas with the correct order of operations. Otherwise, 

Excel will not calculate the results accurately. In our example, if the parentheses are not included, the 

multiplication is calculated first and the result is incorrect. Parentheses are the best way to define which 

calculations will be performed first in Excel. 

 

 

Relative and Absolute Cell References 

 

There are two types of cell references: relative and absolute. Relative and absolute references behave differently 

when copied and filled to other cells. Relative references change when a formula is copied to another cell. 

Absolute references, on the other hand, remain constant, no matter where they are copied. 

 

 

Relative cell references 

 

By default, all cell references are relative references. When copied across multiple cells, they change based on 

the relative position of rows and columns. For example, if you copy the formula =A1+B1 from row 1 to row 2, 

the formula will become =A2+B2. Relative references are especially convenient whenever you need to repeat 

the same calculation across multiple rows or columns. 

 

 

To create and copy a formula using relative references  

In the following example, we want to create a formula that will multiply each item's price by the quantity. 

Rather than creating a new formula for each row, we can create a single formula in cell D2 and then copy 



 

 

 

 

it to the other rows. We'll use relative references so the formula correctly calculates the total for each item. 

Select the cell that will contain the formula. In our example, we'll select cell D2. 

Enter the formula to calculate the desired value. In our example, we'll type =B2*C2. 

 

 

 

 

 

Press Enter on your keyboard. The formula will be calculated, and the result will be displayed in the cell.  

Locate the fill handle in the lower-right corner of the desired cell. In our example, we'll locate the fill handle for 

cell D2. 

 

 

 

 

The fill handle 



 

 

 

 

 

 

Click, hold, and drag the fill handle over the cells you wish to fill. 

 

 

 

 

 

Release the mouse. The formula will be copied to the selected cells with relative references, and the values will 

be calculated in each cell. 

 

 

 TIP: You can double-click the filled cells to check their formulas for accuracy. The relative cell references 

should be different for each cell, depending on their rows. 

 

 

 

Click, hold and drag the fill handle to 

copy the formula to adjacent cells 



 

 

 

 

Absolute cell references 

 

There may be times when you do not want a cell reference to change when filling cells. Unlike relative 

references, absolute references do not change when copied or filled. You can use an absolute reference to keep a 

row and/or column constant. 

An absolute reference is designated in a formula by the addition of a dollar sign ($). It can precede the column 

reference, the row reference, or both. 

 

You will generally use the $A$2 format when creating formulas that contain absolute references. The other two 

formats are used much less frequently. 

 TIP: When writing a formula, you can press the F4 key on your keyboard to switch between relative and 

absolute cell references. This is an easy way to quickly insert an absolute reference. 

 

 

To create and copy a formula using absolute references  

In our example, we'll use the 7.5% sales tax rate in cell E1 to calculate the sales tax for all items in column 

D. We'll need to use the absolute cell reference $E$1 in our formula. Since each formula is using the same tax 

rate, we want that reference to remain constant when the formula is copied and filled to other cells in column D.  

Select the cell that will contain the formula. In our example, we'll select cell D3. 

Enter the formula to calculate the desired value. In our example, we'll type =(B3*C3)*$E$1. 

Press Enter on your keyboard. The formula will calculate, and the result will display in the cell.  



 

 

 

 

 

 
 

 

Locate the fill handle in the lower-right corner of the desired cell. 

Release the mouse. The formula will be copied to the selected cells with an absolute reference, and the values 

will be calculated in each cell. 

Challenge! 

Open an existing Excel workbook. 

Create a formula that uses a relative reference. Double-click a cell to see the copied formula and the relative cell 

references. 

Create a formula that uses an absolute reference. 

 

Functions 

 

A function is a predefined formula that performs calculations using specific values in a particular order. Excel 

includes many common functions that can be useful for quickly finding the sum, average, count, maximum 

value, and minimum value for a range of cells. In order to use functions correctly, you'll need to understand the 

different parts of a function and how to create arguments to calculate values and cell references.  

 

 

 

 

The parts of a function  

Formula =A1+A2+A3+A4+A5+A6+A7+A8 

Function =SUM(A1:A8) 

 

In order to work correctly, a function must be written a specific way, which is called the syntax. The basic 

syntax for a function is an equals sign (=), the function name (SUM, for example), and one or more arguments. 

Arguments contain the information you want to calculate. 



 

 

 

 

 

 

 
 

Working with arguments  

Arguments can refer to both individual cells and cell ranges and must be enclosed within parentheses. You can 

include one argument or multiple arguments, depending on the syntax required for the function. 

 

 

For example, the function =AVERAGE(B1:B9) would calculate the average of the values in the cell range 

B1:B9. This function contains only one argument. 

 

 

Multiple arguments must be separated by a comma. For example, the function =SUM(A1:A3, C1:C2, E2) will 

add the values of all the cells in the three arguments. 

=SUM(A1:A20) 

Equal sign Argument 

Function name 



 

 

 

 

 

 
 

Creating a function 

 

Excel has a variety of functions available. Here are some of the most common functions you'll use:  

SUM: This function adds all of the values of the cells in the argument. 

AVERAGE: This function determines the average of the values included in the argument. It calculates the sum 

of the cells and then divides that value by the number of cells in the argument. 

COUNT: This function counts the number of cells with numerical data in the argument. This function is useful 

for quickly counting items in a cell range. 

MAX: This function determines the highest cell value included in the argument. 

MIN: This function determines the lowest cell value included in the argument. 

 

 

To create a basic function  

In our example below, we'll create a basic function to calculate the average price per unit for a list of recently 

ordered items using the AVERAGE function. 

Select the cell that will contain the function. 

Type the equals sign (=) and enter the desired function name. You can also select the desired function from the 

list of suggested functions that will appear below the cell as you type. In our example, we'll type =AVERAGE. 



 

 

 

 

 
 

Enter the cell range for the argument inside parentheses. In our example, we'll type (D3:D12). 

Press Enter on your keyboard. The function will be calculated, and the result will appear in the cell.  

 

 

To create a function using the AutoSum command  

The AutoSum command allows you to automatically insert the most common functions into your formula, 

including SUM, AVERAGE, COUNT, MIN, and MAX. In our example below, we'll create a function to 

calculate the total cost for a list of recently ordered items using the SUM function. 

Select the cell that will contain the function. 

In the Editing group on the Home tab, locate and select the arrow next to the AutoSum command and then 

choose the desired function from the drop-down menu. In our example, we'll select Sum. 

 



 

 

 

 

The selected function will appear in the cell. If logically placed, the AutoSum command will automatically 

select a cell range for the argument. You can also manually enter the desired cell range into the argument.  

 

 

Press Enter on your keyboard. 

 

 

The Function Library 

 

While there are hundreds of functions in Excel, the ones you use most frequently will depend on the type of data 

your workbooks contains. There is no need to learn every single function, but exploring some of the different 

types of functions will be helpful as you create new projects. You can search for functions by category, such as 

Financial, Logical, Text, Date & Time, and more from the Function Library on the Formulas tab.  

 To access the Function Library, select the Formulas tab on the Ribbon. The Function Library will appear. 

 

 



 

 

 

 

 
 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. 

The AutoSum command allows you to automatically return results for common functions, like SUM, 

AVERAGE, and COUNT. 

The Recently Used command gives you access to functions that you have recently worked with.  

The Financial category contains functions for financial calculations like determining a payment (PMT) or 

interest rate for a loan (RATE). 

Functions in the Logical category check arguments for a value or condition. For example, if an order is over  

$50 add $4.99 for shipping, but if it is over $100, do not charge for shipping (IF). 

The Text category contains functions that work with the text in arguments to perform tasks, such as converting 

text to lowercase (LOWER) or replacing text (REPLACE). 

The Date & Time category contains functions for working with dates and time and will return results like the 

current date and time (NOW) or the seconds (SECOND). 

The Lookup & Reference category contains functions that will return results for finding and referencing 

information. For example, you can add a hyperlink (HYPERLINK) to a cell or return the value of a particular 

row and column intersection (INDEX). 

The Math & Trig category includes functions for numerical arguments. For example, you can round values 

(ROUND), find the value of Pi (PI) multiply (PRODUCT), subtotal (SUBTOTAL), and much more. 

More Functions contains additional functions under categories for Statistical, Engineering, Cube, Information, 

and Compatibility. 

 

To insert a function from the Function Library  

 

Select the cell that will contain the function. 

 

Click the Formulas tab on the Ribbon to access the Function Library. 

 

From the Function Library group, select the desired function category. 

 

Select the desired function from the drop-down menu. 



 

 

 

 

 
 

 

 

The Function Arguments dialog box will appear. From here, you'll be able to enter or select the cells  that will 

make up the arguments in the function. 

 

 

 

When you're satisfied with the arguments, click OK. 

 

The function will be calculated, and the result will appear in the cell. 



 

 

 

 

Like formulas, functions can be copied to adjacent cells. Hover the mouse over the cell that contains the 

function, then click, hold, and drag the fill handle over the cells you wish to fill. The function will be copied, 

and values for those cells will be calculated relative to their rows or columns. 

 

 

 

 

 

 

The Insert Function command 

 

If you're having trouble finding the right function, the Insert Function command allows you to search for 

functions using keywords. While it can be extremely useful, this command is sometimes a little difficult to use. 

If you don't have much experience with functions, you may have more success browsing the Function Library 

instead. For more advanced users, however, the Insert Function command can be a powerful way to find a 

function quickly. 

 

 

To use the Insert Function command  

Select the cell that will contain the function. 

Click the Formulas tab on the Ribbon, then select the Insert Function command. 

The Insert Function dialog box will appear. 

Type a few keywords describing the calculation you want the function to perform, then click Go. 

Review the results to find the desired function, then click OK. 



 

 

 

 

 
 

 

The Function Arguments dialog box will appear. 

When you're satisfied, click OK. 

The function will be calculated, and the result will appear in the cell. 

 

 



 

 

 

Unit-V 

 

 

SUM 

Formula: =SUM(5, 5) or =SUM(A1, B1) or =SUM(A1:B5) 

The SUM formula does exactly what you would expect. It allows you to add 2 or more numbers together. You 

can use cell references as well in this formula. 

 

 

COUNT 

Formula: =COUNT(A1:A10) 

The count formula counts the number of cells in a range that have numbers in them. 

 

 

It only counts the cells where there are numbers. 

 

 

COUNTA 

Formula: =COUNTA(A1:A10) 

Counts the number of non-empty cells in a range. It will count cells that have numbers and/or any other 

characters in them. 

The COUNTA Formula works with all data types. 



 

 

 

 

 
 

 

It counts the number of non-empty cells no matter the data type. 

LEN 

Formula: =LEN(A1) 

The LEN formula counts the number of characters in a cell. This includes spaces! 

 

Notice the difference in the formula results: 10 characters without spaces in between the words, 12 with spaces 

between the words. 

VLOOKUP 

Formula: =VLOOKUP(lookup_value, table_array, col_index_num, range_lookup) 

Basically, VLOOKUP lets you search for specific information in your spreadsheet. For example, if you have a 

list of products with prices, you could search for the price of a specific item. 

We’re going to use VLOOKUP to find the price of the Photo frame. You can probably already see that the price 

is $9.99, but that’s because this is a simple example. Once you learn how to use VLOOKUP, you’ll be able to 

use it with larger, more complex spreadsheets, and that’s when it will become truly useful.  



 

 

 

 

 
 

As with any formula, you’ll start with an equal sign (=). Then, type the formula name.  

=VLOOKUP(“Photo frame” 

The second argument is the cell range that contains the data. In this example, our data is in A2:B16. As with any 

function, you’ll need to use a comma to separate each argument: 

=VLOOKUP(“Photo frame”, A2:B16 

Note: It’s important to know that VLOOKUP will always search the first column in this range. In this example, 

it will search column A for “Photo frame”. In some cases, you may need to move the columns around so that the 

first column contains the correct data. 

The third argument is the column index number. It’s simpler than it sounds: The first column in the range is 1, 

the second column is 2, etc. In this case, we are trying to find the price of the item, and the prices are contained 

in the second column. That means our third argument will be 2: 

=VLOOKUP(“Photo frame”, A2:B16, 2 

The fourth argument tells VLOOKUP whether to look for approximate matches, and it can be either TRUE or 

FALSE. If it is TRUE, it will look for approximate matches. Generally, this is only useful if the first column has 

numerical values that have been sorted. Since we’re only looking for exact matches, the fourth argument should 

be FALSE. This is our last argument, so go ahead and close the parentheses: 

=VLOOKUP(“Photo frame”, A2:B16, 2, FALSE) 

And that’s it! When you press enter, it should give you the answer, which is 9.99. 



 

 

 

 

 
 

 

IF Statements 

Formula: =IF(logical_statement, return this if logical statement is true, return this if logical statement is false). 

Example 

Let’s say a salesperson has a quota to meet. You used VLOOKUP to put the revenue next to the name. Now you 

can use an IF statement that says: “IF the salesperson met their quota, say “Met quota”, if not say “Did not meet 

quota” 

=IF(C3>D3, “Met Quota”, “Did Not Meet Quota”) 

This IF statement will tell us if the first salesperson met their quota or not. We would then copy and paste this 

formula along all the entries in the list. It would change for each sales person. 

 

 



 

 

 

 

Working with Data 

 

Whenever you're working with a lot of data, it can be difficult to compare information in your workbook.  

Freezing Panes and View Options 

 

Excel includes several tools that make it easier to view content from different parts of your workbook at the 

same time, such as the ability to freeze panes and split your worksheet. 

To freeze rows  

You may want to see certain rows or columns all the time in your worksheet, especially header cells. By 

freezing rows or columns in place, you'll be able to scroll through your content while continuing to view the 

frozen cells. 

Select the row below the row(s) you wish to freeze. 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

 

 

 

The rows will be frozen in place, as indicated by the gray line. You can scroll down the worksheet while 

continuing to view the frozen rows at the top. 

To freeze columns  

Select the column to the right of the column(s) you wish to freeze. 



 

 

 

 

Click the View tab on the Ribbon. 

Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu. 

The column will be frozen in place, as indicated by the gray line. You can scroll across the worksheet while 

continuing to view the frozen column on the left. 

To unfreeze rows or columns, click the Freeze Panes command, then select Unfreeze Panes from the drop-down 

menu. 

 

 

To split a worksheet  

Sometimes you may want to compare different sections of the same workbook without creating a new window. 

The Split command allows you to divide the worksheet into multiple panes that scroll separately.  

Select the cell where you wish to split the worksheet. 

Click the View tab on the Ribbon, then select the Split command. 

 

The workbook will be split into different panes. You can scroll through each pane separately using the scroll 

bars, allowing you to compare different sections of the workbook. 

To remove the split, click the Split command again. 

 

 

. 

 

Sorting Data 

 

As you add more content to a worksheet, organizing that information becomes especially important. You can 

quickly reorganize a worksheet by sorting your data. For example, you could organize a list of contact 

information by last name. Content can be sorted alphabetically, numerically, and in many other ways. 



 

 

 

 

When sorting data, it's important to first decide if you would like the sort to apply to the entire worksheet or just 

a cell range. 

Sort sheet organizes all of the data in your worksheet by one column. 

Sort range sorts the data in a range of cells, which can be helpful when working with a sheet that contains 

several tables. Sorting a range will not affect other content on the worksheet. 

 

To sort a sheet  

In our example, we'll sort a T-shirt order form alphabetically by Last Name (column C). 

Select a cell in the column you wish to sort by. In our example, we'll select cell C2. 

 

 

 

Select the Data tab on the Ribbon, then click the Ascending command  to Sort A to Z, or the Descending 

command  to Sort Z to A. In our example, we'll click the Ascending command. 

 

 

The worksheet will be sorted by the selected column. In our example, the worksheet is now sorted by last name.  



 

 

 

 

 
 

 

Filtering Data 

 

If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters can be used to 

narrow down the data in your worksheet, allowing you to view only the information you need.  

To filter data  

In order for filtering to work correctly, your worksheet should include a header row, which is used to identify 

the name of each column. 

Select the Data tab, then click the Filter command. 

 

 

A drop-down arrow will appear in the header cell for each column. 

Click the drop-down arrow for the column you wish to filter. 



 

 

 

 

The Filter menu will appear. 

Uncheck the box next to Select All to quickly deselect all data. 

Check the boxes next to the data you wish to filter, then click OK. 

To remove all filters from your worksheet, click the Filter command on the Data tab. 

 

 

Working with Charts 

 

Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart types that you can 

choose from when you create a chart. Excel offers Pie, Line, Bar, and Column charts to name but a few. 

Showing data in a chart can make it clearer, more interesting and easier to read. Charts can also help you 

evaluate your data and make comparisons between different values. 

 

 

Understanding charts 

 

Excel has several different types of charts, allowing you to choose the one that best fits your data. In order to 

use charts effectively, you'll need to understand how different charts are used. 

Types of Charts: 

Column charts use vertical bars to represent data. They can work with many different types of data, but they're 

most frequently used for comparing information. 

Line charts are ideal for showing trends. The data points are connected with lines, making it easy to see whether 

values are increasing or decreasing over time. 

Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so it's easy to see 

which values make up the percentage of a whole. 

Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars.  

Area charts are similar to line charts, except that the areas under the lines are filled in. 

Surface charts allow you to display data across a 3D landscape. They work best with large data sets, allowing 

you to see a variety of information at the same time. 

 

 

To insert a chart  

  

Select the cells you want to chart, including the column titles and row labels. These cells will be the source data 

for the chart. 



 

 

 

 

From the Insert tab, click the desired Chart command. 

Choose the desired chart type from the drop-down menu. 

 

 

 

 

The selected chart will be inserted in the worksheet. 

 TIP: If you're not sure which type of chart to use, the Recommended Charts command will suggest several 

different charts based on the source data. 

 

 

 

Chart layout and style 

 

After inserting a chart, there are several things you may want to change about the way your data is displayed. 

It's easy to edit a chart's layout and style from the Design tab. 

Excel allows you to add chart elements—such as chart titles, legends, and data labels—to make your chart 

easier to read. To add a chart element, click the Add Chart Element command on the Design tab, then choose 

the desired element from the drop-down menu. 



 

 

 

 

 
 

 

To edit a chart element, like a chart title, simply double-click the placeholder and begin typing. 

 

 

If you don't want to add chart elements individually, you can use one of Excel's predefined layouts. Simply click 

the Quick Layout command, then choose the desired layout from the drop-down menu. 

Excel also includes several different chart styles, which allow you to quickly modify the look and feel of your 

chart. To change the chart style, select the desired style from the Chart styles group. 



 

 

 

 

 
 

 TIP: You can also use the chart formatting shortcut buttons to quickly add chart elements, change the chart 

style, and filter the chart data. 

 

 

 

 

Other chart options 

 

There are lots of other ways to customize and organize your charts. For example, Excel allows you to rearrange 

a chart's data, change the chart type, and even move the chart to a different location in the workbook. 

To switch row and column data  

Sometimes you may want to change the way charts group your data. For example, in the chart below, the Book 

Sales data are grouped by year, with columns for each genre. However, we could switch the rows and columns 

so the chart will group the data by genre, with columns for each year. In both cases, the chart contains the same 

data—it's just organized differently. 

Select the chart you wish to modify. 



 

 

 

 

From the Design tab, select the Switch Row/Column command. 

 

The rows and columns will be switched. 

 

 

To change the chart type  

If you find that your data isn't well suited to a certain chart, it's easy to switch to a new chart type. In our 

example, we'll change our chart from a Column chart to a Line chart. 

From the Design tab, click the Change Chart Type command. 

 

The Change Chart Type dialog box will appear. 

The selected chart type will appear. 

 

 

To move a chart  

Whenever you insert a new chart, it will appear as an object on the same worksheet that contains its source data. 

Alternatively, you can move the chart to a new worksheet to help keep your data organized. 

Select the chart you wish to move. 

Click the Design tab, then select the Move Chart command. 

 



 

 

 

 

The Move Chart dialog box will appear. Select the desired location for the chart. 

Click OK. 

The chart will appear in the selected location. 

 

 

Challenge! 

Open an existing Excel workbook. 

Use worksheet data to create a chart. 

Change the chart layout. 

Apply a chart style. 

Move the chart. 

 

 

Printing Workbooks 

 

There may be times when you want to print a workbook to view and share your data offline. Once you've 

chosen your page layout settings, it's easy to preview and print a workbook from Excel using the Print pane.  

 

 

To access the Print pane  

Select the File tab. Backstage view will appear. 

 

 

 

 

 

Select Print. The Print pane will appear. 



 

 

 

 

 

 

Here you can choose how many copies of the workbook you wish to print. 

 

 

When you are ready to print the workbook, click the Print button. 

 

You may need to select the printer you want to use if your computer is connected to multiple printers.  

 

 

 

 

 

Here you can choose to print the active sheets, the entire workbook, or a selection of 

 

 

 

 

If you are printing multiple copies, you 

can choose whether you want the 

copies collated or uncollated. 

Here you can choose whether to print on 

one side or both sides of the paper. 

 

 

 

If your printer uses different paper sizes, 

you can choose the paper size you wish 

to use. 

 

 

Here you can choose how to scale your 

worksheets for the printed page. You can 

scale worksheets at their actual size, fit 

the entire worksheet on one page, fit all 

columns on one page, or fit all rows on 

one page. 

Here you can choose Portrait 

or Landscape orientation. 

 

 

 

Here you can adjust the page 

margins, which can help your data 

fit more comfortably on the page. 

 

 

 

Choosing a print area 

 

Before you print an Excel workbook, it's important to decide exactly what information you want to print. For 

example, if you have multiple worksheets in your workbook, you will need to decide if you want to print the 

entire workbook or only active worksheets. There may also be times when you want to print only a selection of 

content from your workbook. 



 

 

 

 

To print active sheets  

Worksheets are considered active when selected. 

Select the worksheet you want to print. To print multiple worksheets, click the first worksheet, hold the Ctrl key 

on your keyboard, then click any other worksheets you want to select. 

 

Navigate to the Print pane. 

Select Print Active Sheets from the Print Range drop-down menu. 

 

Click the Print button. 

 

 

 

 

 

To print the entire workbook  

Navigate to the Print pane. 

Select Print Entire Workbook from the Print Range drop-down menu. 



 

 

 

 

 
 

Click the Print button. 

 

 

 

To print a selection  

Select the cells you wish to print. 

Navigate to the Print pane. 

Select Print Selection from the Print Range drop-down menu. 

 

A preview of your selection will appear in the Preview pane. 

Click the Print button to print the selection. 



 

 

 

 

 
 

 TIP: If you prefer, you can also set the print area in advance so you'll be able to visualize which cells will be 

printed as you work in Excel. Simply select the cells you want to print, click the Page Layout tab, select the 

Print Area command, then choose Set Print Area. 

 

 

 

 

 

 

Fitting and scaling content 

 

On occasion, you may need to make small adjustments from the Print pane to fit your workbook content neatly 

onto a printed page. The Print pane includes several tools to help fit and scale your content, such as scaling and 

page margins. 

  



 

 

 

 

To fit content before printing  

If some of your content is being cut off by the printer, you can use scaling to fit your workbook to the page 

automatically. 

Navigate to the Print pane. 

Select the desired option from the Scaling drop-down menu. In our example, we'll select Fit Sheet on One Page. 

 

The worksheet will be condensed to fit onto a single page. 

When you're satisfied with the scaling, click Print. 

 

 

To modify margins in the Preview pane  

Sometimes you may only need to adjust a single margin to make your data fit more comfortably. You can 

modify individual page margins from the Preview pane. 

Navigate to the Print pane, then click the Show Margins button in the lower-right corner. 



 

 

 

 

 
The page margins will appear in the Preview pane. Hover the mouse over one of the margin 

markers until the cursor becomes a double arrow . 

Click, hold, and drag the mouse to increase or decrease the margin width. 

Release the mouse. The margin will be modified. In our example, we were able to fit an additional column on 

the page. 

 

 

Show Margins 
button. 
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